summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoris Momčilović2019-05-11 14:36:07 +0200
committerBoris Momčilović2019-05-11 14:36:07 +0200
commit931cbf408723c16d33d02c527c6be20c99ca6982 (patch)
treec87839cfd232d471b1dd3f9713488a5389625780
parentfcd5bd3f7da93a2aed369770e88e742b0b065a30 (diff)
downloadaur-931cbf408723c16d33d02c527c6be20c99ca6982.tar.gz
Bump, switch to mason/ninja
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e05cda771bb..3185b05a6a76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libui-git
pkgdesc = A portable GUI library for C
- pkgver = alpha4.1.r93.g751ce562
+ pkgver = alpha4.1.r314.g17486fd1
pkgrel = 1
url = https://github.com/andlabs/libui
arch = i686
@@ -9,6 +9,8 @@ pkgbase = libui-git
makedepends = make
makedepends = gcc
makedepends = cmake
+ makedepends = meson
+ makedepends = ninja
depends = gtk3
depends = libx11
depends = libxcb
diff --git a/PKGBUILD b/PKGBUILD
index 30126568dad3..fbb708979517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=libui
pkgname=${_pkgname}-git
-pkgver=alpha4.1.r93.g751ce562
+pkgver=alpha4.1.r314.g17486fd1
pkgrel=1
pkgdesc='A portable GUI library for C'
arch=('i686' 'x86_64')
url='https://github.com/andlabs/libui'
license=('MIT')
depends=('gtk3' 'libx11' 'libxcb' 'libffi')
-makedepends=('make' 'gcc' 'cmake')
+makedepends=('make' 'gcc' 'cmake' 'meson' 'ninja')
provides=('libui')
conflicts=('libui')
source=("$pkgname::git://github.com/andlabs/libui.git")
@@ -23,16 +23,17 @@ pkgver() {
build() {
cd $pkgname
mkdir -p build
- cd build
- cmake ..
- make
+ meson build
+ ninja -C build
+ cd build/meson-out
+ ln -sf libui.so.0 libui.so
}
package() {
cd $pkgname
mkdir -p $pkgdir/usr/{lib,include}
- install build/out/libui.so ${pkgdir}/usr/lib/
- install build/out/libui.so.0 ${pkgdir}/usr/lib/
+ install build/meson-out/libui.so ${pkgdir}/usr/lib/
+ install build/meson-out/libui.so.0 ${pkgdir}/usr/lib/
install ui.h ${pkgdir}/usr/include/
install ui_unix.h ${pkgdir}/usr/include/
}