summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-01-20 18:12:28 +0100
committerDavide Depau2019-01-20 18:12:28 +0100
commit62dcc5ef40054d6b3b2dabadc409e0666d8b2664 (patch)
tree46915d6c947e0b92aaabe2f796bdeaffa1e6f5eb
downloadaur-62dcc5ef40054d6b3b2dabadc409e0666d8b2664.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..355d379f16f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libuinputplus-git
+ pkgdesc = Easy-to-use uinput library in C++
+ pkgver = v0.1.3.r0.gd8f8650
+ pkgrel = 1
+ url = https://github.com/YukiWorkshop/libuInputPlus
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
+ makedepends = pkg-config
+ provides = libuinputplus
+ conflicts = libuinputplus
+ source = libuinputplus::git+https://github.com/YukiWorkshop/libuInputPlus.git
+ sha256sums = SKIP
+
+pkgname = libuinputplus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dbb27a17406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Davide Depau <davide@depau.eu>
+
+_pkgname=libuinputplus
+pkgname=$_pkgname-git
+pkgver=v0.1.3.r0.gd8f8650
+pkgrel=1
+pkgdesc="Easy-to-use uinput library in C++"
+arch=('i686' 'x86_64')
+makedepends=('cmake' 'git' 'make' 'pkg-config')
+url="https://github.com/YukiWorkshop/libuInputPlus"
+license=('MIT')
+source=(${_pkgname}::git+https://github.com/YukiWorkshop/libuInputPlus.git)
+sha256sums=('SKIP')
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ mkdir -p build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install -C build/
+}