summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Kauselmann2017-10-22 14:03:05 +0200
committerFelix Kauselmann2017-10-22 14:03:05 +0200
commit2ea1486e9a07318e7e502088778921818a89d167 (patch)
tree8867ca521378f2fd935dfaf4b056cd30bbb2b19d
parentce37447f087c4307d24870cd3824c270c98b8738 (diff)
downloadaur-2ea1486e9a07318e7e502088778921818a89d167.tar.gz
Add support for tags to pkgver function
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8f5fa9c6d41..44da33b2aa56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fr Sep 1 19:08:05 UTC 2017
+# Sun Oct 22 12:02:17 UTC 2017
pkgbase = libunarr-git
pkgdesc = A lightweight decompression library with support for rar, tar and zip archives.
- pkgver = r214.65e7b2c
+ pkgver = 1.0.0.r1.g62e744b
pkgrel = 1
url = https://github.com/selmf/unarr
arch = i686
@@ -13,6 +13,7 @@ pkgbase = libunarr-git
depends = zlib
depends = bzip2
depends = xz
+ provides = libunarr
source = git+https://github.com/selmf/unarr
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3b59e59a120a..789c069c4f1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Felix Kauselmann <licorn at gmail dot com>
pkgname=libunarr-git
-pkgver=r214.65e7b2c
+pkgver=1.0.0.r1.g62e744b
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/selmf/unarr"
@@ -9,12 +9,13 @@ pkgdesc="A lightweight decompression library with support for rar, tar and zip a
source=('git+https://github.com/selmf/unarr')
makedepends=('cmake' 'git')
depends=('zlib' 'bzip2' 'xz')
+provides=('libunarr')
md5sums=('SKIP')
pkgver() {
cd "${srcdir}/unarr"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {