summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Girard2021-11-27 13:14:32 +0100
committerCorentin Girard2021-11-27 13:14:32 +0100
commit04fdf5886d4b64dbb51c3aedcdf3e54d9157be87 (patch)
tree729e91ea1849ec96178d877f5615731fcd912b98
parent6e9696086c755e66fe4b87780fa9582aebd24fe7 (diff)
downloadaur-04fdf5886d4b64dbb51c3aedcdf3e54d9157be87.tar.gz
Revert 0.52 --> 0.44
-rwxr-xr-x.SRCINFO6
-rw-r--r--0001-Fix-optional-types.patch39
-rw-r--r--PKGBUILD11
3 files changed, 6 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33db624b4ce1..d844c9767895 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libunity
pkgdesc = Library for instrumenting and integrating with all aspects of the Unity shell
pkgver = 7.1.4
- pkgrel = 11
+ pkgrel = 12
url = https://launchpad.net/libunity
arch = i686
arch = x86_64
@@ -9,15 +9,13 @@ pkgbase = libunity
makedepends = gnome-common
makedepends = gobject-introspection
makedepends = intltool
- makedepends = vala0.52
+ makedepends = vala0.44
depends = dee
depends = gtk3
depends = libdbusmenu-glib
source = https://launchpad.net/ubuntu/+archive/primary/+files/libunity_7.1.4+19.04.20190319.orig.tar.gz
source = https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
- source = 0001-Fix-optional-types.patch
sha256sums = 56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492
sha256sums = 98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262
- sha256sums = dd6ea48c848da79b251c09ec86579f2bc26014c10a67ad4df88c3487064a1661
pkgname = libunity
diff --git a/0001-Fix-optional-types.patch b/0001-Fix-optional-types.patch
deleted file mode 100644
index 924ce261a04d..000000000000
--- a/0001-Fix-optional-types.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 064e97636588f2e0c81ea50d4fccdec039172c32 Mon Sep 17 00:00:00 2001
-From: Corentin Girard <corentingirard.dev@gmail.com>
-Date: Tue, 23 Nov 2021 00:17:46 +0100
-Subject: [PATCH] Fix optional types
-
----
- protocol/protocol-icon.vala | 2 +-
- src/unity-scope-channel.vala | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/protocol/protocol-icon.vala b/protocol/protocol-icon.vala
-index be13a5d..ff92eb2 100644
---- a/protocol/protocol-icon.vala
-+++ b/protocol/protocol-icon.vala
-@@ -185,7 +185,7 @@ public class AnnotatedIcon : Object, GLib.Icon
- }
-
- /* Added to GIcon interface in 2.37 */
-- private Variant serialize ()
-+ private Variant? serialize ()
- {
- Variant? ret = null;
- return ret;
-diff --git a/src/unity-scope-channel.vala b/src/unity-scope-channel.vala
-index 2cb55f6..f959da8 100644
---- a/src/unity-scope-channel.vala
-+++ b/src/unity-scope-channel.vala
-@@ -312,7 +312,7 @@ internal class ScopeChannel : Object
- DBusSignalFlags.NONE, this.owner_changed);
- }
-
-- private void owner_changed (DBusConnection con, string sender_name,
-+ private void owner_changed (DBusConnection con, string? sender_name,
- string obj_path, string ifc_name,
- string sig_name, Variant parameters)
- {
---
-2.34.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 05abaeb06585..aeadede50a28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,23 +9,20 @@
pkgname=libunity
pkgver=7.1.4
-pkgrel=11
+pkgrel=12
pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
arch=('i686' 'x86_64')
url="https://launchpad.net/libunity"
license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
-makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala0.52')
+makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala0.44')
source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+19.04.20190319.orig.tar.gz"
- "https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch"
- "0001-Fix-optional-types.patch")
+ "https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch")
sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492'
- '98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262'
- 'dd6ea48c848da79b251c09ec86579f2bc26014c10a67ad4df88c3487064a1661')
+ '98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262')
prepare() {
patch -p1 < 0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
- patch -p1 < 0001-Fix-optional-types.patch
}
build() {