summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorentin Girard2021-11-23 00:40:02 +0100
committerCorentin Girard2021-11-23 00:40:02 +0100
commitc6a50ece4247f880ee0e21481428595418d6c38e (patch)
tree0a9d052735d0a9d5b653fa9750da719cb00eaf4c
parentf3b103070f901064c5789ae5bb0493a7b7729465 (diff)
downloadaur-c6a50ece4247f880ee0e21481428595418d6c38e.tar.gz
Add patch to fix optional types
-rw-r--r--0001-Fix-optional-types.patch39
-rw-r--r--PKGBUILD7
2 files changed, 44 insertions, 2 deletions
diff --git a/0001-Fix-optional-types.patch b/0001-Fix-optional-types.patch
new file mode 100644
index 000000000000..924ce261a04d
--- /dev/null
+++ b/0001-Fix-optional-types.patch
@@ -0,0 +1,39 @@
+From 064e97636588f2e0c81ea50d4fccdec039172c32 Mon Sep 17 00:00:00 2001
+From: Corentin Girard <corentingirard.dev@gmail.com>
+Date: Tue, 23 Nov 2021 00:17:46 +0100
+Subject: [PATCH] Fix optional types
+
+---
+ protocol/protocol-icon.vala | 2 +-
+ src/unity-scope-channel.vala | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/protocol/protocol-icon.vala b/protocol/protocol-icon.vala
+index be13a5d..ff92eb2 100644
+--- a/protocol/protocol-icon.vala
++++ b/protocol/protocol-icon.vala
+@@ -185,7 +185,7 @@ public class AnnotatedIcon : Object, GLib.Icon
+ }
+
+ /* Added to GIcon interface in 2.37 */
+- private Variant serialize ()
++ private Variant? serialize ()
+ {
+ Variant? ret = null;
+ return ret;
+diff --git a/src/unity-scope-channel.vala b/src/unity-scope-channel.vala
+index 2cb55f6..f959da8 100644
+--- a/src/unity-scope-channel.vala
++++ b/src/unity-scope-channel.vala
+@@ -312,7 +312,7 @@ internal class ScopeChannel : Object
+ DBusSignalFlags.NONE, this.owner_changed);
+ }
+
+- private void owner_changed (DBusConnection con, string sender_name,
++ private void owner_changed (DBusConnection con, string? sender_name,
+ string obj_path, string ifc_name,
+ string sig_name, Variant parameters)
+ {
+--
+2.34.0
+
diff --git a/PKGBUILD b/PKGBUILD
index f8b8bae5e6c7..05abaeb06585 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,12 +17,15 @@ license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala0.52')
source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+19.04.20190319.orig.tar.gz"
- "https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch")
+ "https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch"
+ "0001-Fix-optional-types.patch")
sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492'
- '98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262')
+ '98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262'
+ 'dd6ea48c848da79b251c09ec86579f2bc26014c10a67ad4df88c3487064a1661')
prepare() {
patch -p1 < 0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
+ patch -p1 < 0001-Fix-optional-types.patch
}
build() {