summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Dewar2019-10-18 13:02:24 +0100
committerAlex Dewar2019-10-18 13:02:24 +0100
commitccbfcc8abecc6d3954924da99a9f0cd606c99d7b (patch)
tree75a13e51f0d9691daebc5089c1db7dab55f7708e
parent06405023e8d2a51cd353c42c26b4a4a5519f38bb (diff)
downloadaur-ccbfcc8abecc6d3954924da99a9f0cd606c99d7b.tar.gz
Fix build error
-rwxr-xr-x.SRCINFO4
-rw-r--r--.gitignore14
-rw-r--r--[-rwxr-xr-x]PKGBUILD11
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f011db36b02..5dcd5011997e 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libunity
pkgdesc = Library for instrumenting and integrating with all aspects of the Unity shell
pkgver = 7.1.4
- pkgrel = 8
+ pkgrel = 9
url = https://launchpad.net/libunity
arch = i686
arch = x86_64
@@ -14,7 +14,9 @@ pkgbase = libunity
depends = gtk3
depends = libdbusmenu-glib
source = https://launchpad.net/ubuntu/+archive/primary/+files/libunity_7.1.4+19.04.20190319.orig.tar.gz
+ source = https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
sha256sums = 56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492
+ sha256sums = 98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262
pkgname = libunity
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8033debfc69f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.patch
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 0df19812d964..ab176c9319c3 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,24 +5,27 @@
pkgname=libunity
pkgver=7.1.4
-pkgrel=8
+pkgrel=9
pkgdesc='Library for instrumenting and integrating with all aspects of the Unity shell'
arch=('i686' 'x86_64')
url='https://launchpad.net/libunity'
license=('LGPL')
depends=('dee' 'gtk3' 'libdbusmenu-glib')
makedepends=('gnome-common' 'gobject-introspection' 'intltool' 'vala')
-source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+19.04.20190319.orig.tar.gz")
-sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}+19.04.20190319.orig.tar.gz"
+ "https://launchpadlibrarian.net/443817430/0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch")
+sha256sums=('56ecb380d74bf74caba193d9e8ad6b0c85ccf9eeb461bc9731c2b8636e1f1492'
+ '98a2562dcf3b3a864d1c05331b4dc672d8bff4b592ca796a0bc132a416f33262')
prepare() {
cd "${srcdir}"
+ patch -p1 < ../0001-Fix-FTB-with-recent-vala-requiring-non-public-abstra.patch
NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
}
build() {
cd "${srcdir}"
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --disable-static
make
}