summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12018-04-04 19:05:31 +0800
committerChocobo12018-04-04 19:19:19 +0800
commit15c469df10a92f9673940f2f1411d9580c7d2476 (patch)
treeae8cadf2ccc6e810907c79ef7bc4f060d5ddfd86
downloadaur-15c469df10a92f9673940f2f1411d9580c7d2476.tar.gz
newpkg: liburcu-git 0.10.1.r16.gfdfad81-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b12d31fb367c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = liburcu-git
+ pkgdesc = Userspace RCU implementation
+ pkgver = 0.10.1.r16.gfdfad81
+ pkgrel = 1
+ url = http://liburcu.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ depends = glibc
+ provides = liburcu
+ conflicts = liburcu
+ options = staticlibs
+ source = git+https://github.com/urcu/userspace-rcu.git
+ sha256sums = SKIP
+
+pkgname = liburcu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e87633779d3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=liburcu-git
+pkgver=0.10.1.r16.gfdfad81
+pkgrel=1
+pkgdesc="Userspace RCU implementation"
+arch=('i686' 'x86_64')
+url="http://liburcu.org/"
+license=('custom')
+depends=('glibc')
+makedepends=('git')
+provides=('liburcu')
+conflicts=('liburcu')
+options=('staticlibs')
+source=("git+https://github.com/urcu/userspace-rcu.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "userspace-rcu"
+
+ _tag=$(git tag -l --sort -v:refname | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/v//'
+}
+
+build() {
+ cd "userspace-rcu"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "userspace-rcu"
+
+ make check
+}
+
+package() {
+ cd "userspace-rcu"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ rm "$pkgdir/usr/share/doc/userspace-rcu/LICENSE"
+}