summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrolex2017-07-03 21:30:29 +0300
committerrolex2017-07-03 21:30:29 +0300
commit99633f04c11618e16a5c7efb8d2a9d53092e5eeb (patch)
treeea1961ddfd05eb8290364645193b14f05ccfd373
downloadaur-99633f04c11618e16a5c7efb8d2a9d53092e5eeb.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a779698db29b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libusbgx-git
+ pkgdesc = C library encapsulating the kernel USB gadget-configfs userspace API functionality
+ pkgver = r325.b8941d1
+ pkgrel = 1
+ url = https://github.com/libusbgx/libusbgx
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ license = LGPL
+ depends = libconfig
+ source = libusbgx::git+https://github.com/libusbgx/libusbgx.git
+ sha256sums = SKIP
+
+pkgname = libusbgx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0df5075030c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Rostislav Uralskiy <rolex@ukr.net>
+
+_pkgname=libusbgx
+pkgname=$_pkgname-git
+pkgver=r325.b8941d1
+pkgrel=1
+pkgdesc="C library encapsulating the kernel USB gadget-configfs userspace API functionality"
+arch=('i686' 'x86_64' 'aarch64')
+url="https://github.com/libusbgx/libusbgx"
+depends=('libconfig')
+license=('LGPL')
+source=("$_pkgname::git+https://github.com/libusbgx/libusbgx.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make -j1
+}
+
+package () {
+ make -C "$_pkgname" DESTDIR="$pkgdir" install
+ cd "$_pkgdir"
+ rm -rf $pkgdir/usr/bin
+}