summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-07 13:44:28 +0100
committerBartłomiej Piotrowski2018-01-07 13:44:28 +0100
commit5743039fb4b712cf202e0c6518c9cb1bbb83b7e1 (patch)
treefa0960bd9a01b95ed9fceefbf0cfcbf476b9ba39
downloadaur-5743039fb4b712cf202e0c6518c9cb1bbb83b7e1.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c40fd76f2f7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libuser
+ pkgdesc = A standardized interface for manipulating and administering user and group accounts.
+ pkgver = 0.62
+ pkgrel = 2
+ url = https://pagure.io/libuser/
+ arch = x86_64
+ license = LGPL
+ depends = python2
+ depends = glib2
+ depends = popt
+ backup = etc/libuser.conf
+ source = https://releases.pagure.org/libuser/libuser-0.62.tar.xz
+ sha256sums = a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b
+
+pkgname = libuser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e4a2736e3597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Thomas Dziedzic < gostrc at gmail >
+
+pkgname=libuser
+pkgver=0.62
+pkgrel=2
+pkgdesc='A standardized interface for manipulating and administering user and group accounts.'
+arch=('x86_64')
+license=('LGPL')
+url='https://pagure.io/libuser/'
+depends=('python2' 'glib2' 'popt')
+backup=('etc/libuser.conf')
+source=("https://releases.pagure.org/libuser/libuser-${pkgver}.tar.xz")
+sha256sums=('a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ export PYTHON=python2
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --sbindir=/usr/bin \
+ --disable-gtk-doc-html \
+ --disable-rpath
+ sed -i 's/SUBDIRS = po docs/SUBDIRS = po/' Makefile
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+}