summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlois Nespor2017-10-24 22:05:10 +0200
committerAlois Nespor2017-10-24 22:05:10 +0200
commit60cd8b0baa1371bacc49f54003f535667e63ac85 (patch)
tree3a4508d1b5a21c4193d3732cb58c277d74e4ee7f
parent2377994d852c12638ec5cca08697c61b442be716 (diff)
downloadaur-60cd8b0baa1371bacc49f54003f535667e63ac85.tar.gz
VAAPI 2.0 is incoming - use same version of libva+libva-intel-driver and update both together
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
2 files changed, 58 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a455761a553..96b173c21862 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,35 @@
# Generated by mksrcinfo v8
-# Tue May 30 20:38:46 UTC 2017
+# Tue Oct 24 20:04:49 UTC 2017
pkgbase = libva-intel-driver-g45-h264
pkgdesc = VA-API implementation for Intel G45 chipsets with H264 support.
pkgver = 1.8.2
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://01.org/linuxmedia/vaapi
arch = i686
arch = x86_64
license = MIT
- depends = libva
- optdepends = libva-utils: Applications and Scripts for libva (vainfo and others)
- provides = libva-intel-driver
- conflicts = libva-intel-driver
- replaces = libva-intel-driver
+ makedepends = mesa
source = https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-1.8.2.tar.gz
+ source = https://github.com/01org/libva/releases/download/1.8.2/libva-1.8.2.tar.bz2
source = fix_surface_querys.patch
sha256sums = 86afce92c83555abf16412689f181c3a7cfeef9727109f87c373466bffb22329
+ sha256sums = 9ed3e3ddc8f47a715d4c6ec366beb21c83fc4e8a3d4d39a811baff76f0a0cede
sha256sums = 64bb9d0fae82adba367de0e6ee21737cdb23a7d7eed1bae9f1536af1becbae92
+pkgname = libva-g45-h264
+ pkgdesc = Video Acceleration (VA) API for Linux
+ depends = libdrm
+ depends = libgl
+ depends = libxfixes
+ optdepends = libva-utils: Applications and Scripts for libva (vainfo and others)
+ provides = libva
+ conflicts = libva
+ replaces = libva
+
pkgname = libva-intel-driver-g45-h264
+ depends = libva-g45-h264
+ provides = libva-intel-driver
+ conflicts = libva-intel-driver
+ replaces = libva-intel-driver
diff --git a/PKGBUILD b/PKGBUILD
index 71da97f837f2..8a5811375341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,24 @@
# Maintainer : Alois Nešpor <info@aloisnespor.info>
# Contributor : Pedro Martinez-Julia <pedromj@um.es>
-# Contributor : Anugrah Redja Kusuma <anugrah.redja@gmail.com>
-# Contributor : Vincent B. <vbmithr@gmail.com>
-pkgname=libva-intel-driver-g45-h264
+pkgbase=libva-intel-driver-g45-h264
+pkgname=(libva-g45-h264 libva-intel-driver-g45-h264)
epoch=1
pkgver=1.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="VA-API implementation for Intel G45 chipsets with H264 support."
arch=('i686' 'x86_64')
url='https://01.org/linuxmedia/vaapi'
license=(MIT)
-depends=(libva)
-conflicts=('libva-intel-driver')
-provides=('libva-intel-driver')
-replaces=('libva-intel-driver')
-optdepends=('libva-utils: Applications and Scripts for libva (vainfo and others)')
+makedepends=(mesa)
+
source=(https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-$pkgver.tar.gz
+ https://github.com/01org/libva/releases/download/$pkgver/libva-$pkgver.tar.bz2
fix_surface_querys.patch)
prepare () {
- cd intel-vaapi-driver
- #./autogen.sh --prefix=/usr
+ cd intel-vaapi-driver
+ #./autogen.sh --prefix=/usr
patch -Np1 -i ../fix_surface_querys.patch
# Only relevant if intel-gpu-tools is installed,
# since then the shaders will be recompiled
@@ -29,15 +26,44 @@ prepare () {
}
build() {
- cd intel-vaapi-driver
+ cd $srcdir/libva-${pkgver}
+ ./configure \
+ --prefix='/usr'
+ make
+
+ cd $srcdir/intel-vaapi-driver
./autogen.sh --prefix=/usr
make
}
-package () {
+package_libva-g45-h264() {
+
+pkgdesc='Video Acceleration (VA) API for Linux'
+depends=('libdrm' 'libgl' 'libxfixes')
+conflicts=('libva')
+provides=('libva')
+replaces=('libva')
+optdepends=('libva-utils: Applications and Scripts for libva (vainfo and others)')
+
+
+ cd libva-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 COPYING -t "${pkgdir}"/usr/share/licenses/libva
+}
+
+package_libva-intel-driver-g45-h264() {
+
+depends=('libva-g45-h264')
+conflicts=('libva-intel-driver')
+provides=('libva-intel-driver')
+replaces=('libva-intel-driver')
+
cd intel-vaapi-driver
make DESTDIR="${pkgdir}" install
install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}
+
sha256sums=('86afce92c83555abf16412689f181c3a7cfeef9727109f87c373466bffb22329'
+ '9ed3e3ddc8f47a715d4c6ec366beb21c83fc4e8a3d4d39a811baff76f0a0cede'
'64bb9d0fae82adba367de0e6ee21737cdb23a7d7eed1bae9f1536af1becbae92')