summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2020-12-22 20:05:13 -0500
committerVincent Grande2020-12-22 20:05:13 -0500
commita215b0acf9287f5fb42510d0d58dbcbd180ff2c1 (patch)
treece4790c265718babb22a3f3f05461db5544ac665
downloadaur-a215b0acf9287f5fb42510d0d58dbcbd180ff2c1.tar.gz
initial upload
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f759a231cfb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = libva-git
+ pkgdesc = Video Acceleration (VA) API for Linux
+ pkgver = 2.10.0
+ pkgrel = 1
+ url = https://01.org/linuxmedia/vaapi
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = libglvnd
+ makedepends = mesa
+ makedepends = meson
+ depends = libdrm
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = libxfixes
+ depends = wayland
+ optdepends = intel-media-driver: backend for Intel GPUs (>= Broadwell)
+ optdepends = libva-vdpau-driver: backend for Nvidia and AMD GPUs
+ optdepends = libva-intel-driver: backend for Intel GPUs (<= Haswell)
+ provides = libva-drm.so
+ provides = libva-glx.so
+ provides = libva-wayland.so
+ provides = libva-x11.so
+ provides = libva.so
+ provides = libva
+ conflicts = libva
+ backup = etc/libva.conf
+ source = git+https://github.com/intel/libva.git
+ sha256sums = SKIP
+
+pkgname = libva-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d09611a3969
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@archlonux.org>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=libva-git
+pkgver=2.10.0
+pkgrel=1
+pkgdesc='Video Acceleration (VA) API for Linux'
+arch=(x86_64)
+url=https://01.org/linuxmedia/vaapi
+license=(MIT)
+depends=(
+ libdrm
+ libgl
+ libx11
+ libxext
+ libxfixes
+ wayland
+)
+makedepends=(
+ git
+ libglvnd
+ mesa
+ meson
+)
+optdepends=(
+ 'intel-media-driver: backend for Intel GPUs (>= Broadwell)'
+ 'libva-vdpau-driver: backend for Nvidia and AMD GPUs'
+ 'libva-intel-driver: backend for Intel GPUs (<= Haswell)'
+)
+provides=(
+ libva-drm.so
+ libva-glx.so
+ libva-wayland.so
+ libva-x11.so
+ libva.so
+ libva
+)
+conflicts=(libva)
+backup=(etc/libva.conf)
+source=(git+https://github.com/intel/libva.git)
+sha256sums=(SKIP)
+
+pkgver() {
+ cd libva
+
+ git describe --tags
+}
+
+build() {
+ arch-meson libva build -D enable_docs=false -D enable_va_messaging=false
+ ninja $NINJAFLAGS -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+ install -Dm 644 libva/COPYING -t "${pkgdir}"/usr/share/licenses/libva
+
+ install -Dm 644 /dev/stdin "${pkgdir}"/etc/libva.conf <<END
+LIBVA_MESSAGING_LEVEL=1
+END
+}
+
+# vim: ts=2 sw=2 et: