summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndre Vallestero2020-02-14 20:01:32 -0500
committerAndre Vallestero2020-02-14 20:01:32 -0500
commit495e55d33411d4eab58ef85c4c9c0e7812d074d8 (patch)
treef7788c57f110354ce2466eb5802fb7cb1a82caf7
downloadaur-495e55d33411d4eab58ef85c4c9c0e7812d074d8.tar.gz
Added hantro h264 support based on pH5 fork
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7da1e338fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libva-v4l2-request-hantro-h264-git
+ pkgdesc = LibVA implementation for the Linux Video4Linux2 Request API (Hantro 264 support, git version)
+ pkgver = r240.406420a
+ pkgrel = 1
+ url = https://github.com/pH5/libva-v4l2-request
+ arch = aarch64
+ license = LGPL2.1
+ license = MIT
+ makedepends = meson
+ makedepends = git
+ depends = libva
+ depends = libdrm>=2.4.52
+ provides = v4l2_request_drv_video.so
+ conflicts = libva-v4l2-request
+ source = git+https://github.com/pH5/libva-v4l2-request.git#branch=hantro-h264
+ sha256sums = SKIP
+
+pkgname = libva-v4l2-request-hantro-h264-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e5878386e75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Andre Vallestero < gmail-com: andrevallestero >
+
+pkgname=libva-v4l2-request-hantro-h264-git
+_srcname=libva-v4l2-request
+pkgver=r240.406420a
+pkgrel=1
+pkgdesc='LibVA implementation for the Linux Video4Linux2 Request API (Hantro 264 support, git version)'
+arch=('aarch64')
+url="https://github.com/pH5/libva-v4l2-request"
+license=('LGPL2.1' 'MIT')
+depends=('libva' 'libdrm>=2.4.52')
+makedepends=('meson' 'git')
+provides=('v4l2_request_drv_video.so')
+conflicts=('libva-v4l2-request')
+source=('git+https://github.com/pH5/libva-v4l2-request.git#branch=hantro-h264')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_srcname"
+ meson --prefix /usr --buildtype=release build
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/$_srcname"
+ DESTDIR="$pkgdir" ninja -C build install
+ mkdir -p "$pkgdir/usr/share/licenses/${pkgname}"
+ install -D -m644 COPYING* "$pkgdir/usr/share/licenses/$_srcname/"
+}