summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAseem Athale2023-07-25 20:14:38 +0530
committerAseem Athale2023-07-25 20:16:28 +0530
commit381fbcac996fbe73e71c9f685d9fc55ae1c6f11e (patch)
tree2e1c481d3b91da2e0cea6069c03e97b92ca63512
parent7dcfb460ba9afbbcdaaf18e834008a9c00df43b4 (diff)
downloadaur-381fbcac996fbe73e71c9f685d9fc55ae1c6f11e.tar.gz
libvarnam: Clean-up PKGBUILD a bit
Signed-off-by: Aseem Athale <athaleaseem@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7015e1d15b42..b955ef961f5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = libvarnam
pkgdesc = Transliteration and reverse transliteration for Indian languages
pkgver = 3.2.6
- pkgrel = 1
+ pkgrel = 2
url = https://www.varnamproject.com/
arch = x86_64
license = MPL
makedepends = cmake
depends = ruby
depends = ruby-ffi
- provides = varnamc
source = https://github.com/varnamproject/libvarnam/releases/download/v3.2.6/libvarnam-3.2.6.tar.gz
sha256sums = 17d856c6b2e1a3d009d9907e9d0b0a49d82f403e71a0307a9c11ba5681a35481
pkgname = libvarnam
-
diff --git a/PKGBUILD b/PKGBUILD
index 52f8c93d64e5..b5c585e862bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,23 @@
pkgname=libvarnam
pkgver=3.2.6
-pkgrel=1
+pkgrel=2
pkgdesc="Transliteration and reverse transliteration for Indian languages"
arch=('x86_64')
url="https://www.varnamproject.com/"
license=('MPL')
makedepends=('cmake')
-source=("https://github.com/varnamproject/libvarnam/releases/download/v3.2.6/$pkgname-$pkgver.tar.gz")
+source=("https://github.com/varnamproject/libvarnam/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
sha256sums=('17d856c6b2e1a3d009d9907e9d0b0a49d82f403e71a0307a9c11ba5681a35481')
-depends=(
- 'ruby'
- 'ruby-ffi'
-)
-provides=('varnamc')
-
-prepare() {
- mkdir -p build
-}
+depends=('ruby' 'ruby-ffi')
build() {
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ../${pkgname}-${pkgver}
+ cd ${pkgname}-${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- cd build
+ cd ${pkgname}-${pkgver}
make DESTDIR="$pkgdir/" install
}
-