summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Hague2015-09-27 12:32:28 +0100
committerMatthew Hague2015-09-27 12:32:28 +0100
commit0ef0fe9a02f8952f66f307f1705720fcfadc0bc7 (patch)
treef3f44f5dbbd7ce563b4bf68deb816ec048c41d7e
downloadaur-0ef0fe9a02f8952f66f307f1705720fcfadc0bc7.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f775b2d68f8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libvc-git
+ pkgdesc = vCard library, part of rolo project.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/yourealwaysbe/libvc
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = flex
+ makedepends = git
+ makedepends = autoconf
+ depends = glibc
+ provides = libvc
+ conflicts = libvc
+ source = git://github.com/yourealwaysbe/libvc.git
+ md5sums = SKIP
+
+pkgname = libvc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b56b79326b2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Matthew Hague <matthewhague@zoho.com>
+# Maintainer: Loui Chang <base64:bG91aXBjLmlzdEBnbWFpbC5jb20=>
+# Contributor: Jeff Mickey <j@codemac.net>
+
+pkgname=libvc-git
+pkgver=1
+pkgrel=1
+pkgdesc="vCard library, part of rolo project."
+arch=('i686' 'x86_64')
+url="https://github.com/yourealwaysbe/libvc"
+license=("LGPL")
+depends=('glibc')
+makedepends=('flex' 'git' 'autoconf')
+conflicts=(libvc)
+provides=(libvc)
+source=(git://github.com/yourealwaysbe/libvc.git)
+md5sums=('SKIP')
+
+build() {
+ cd ${srcdir}/libvc
+ autoreconf -f -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/libvc
+ make DESTDIR=${pkgdir} install
+ find ${pkgdir} -name '*.la' -exec rm {} \;
+}
+