summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2019-03-13 21:57:50 +0100
committerGFdevelop2019-03-13 21:57:50 +0100
commit1e03d8d7b8ac7df73ec03c867ee96cdcbceec9a1 (patch)
tree95e5542ad337e343481a6275ae58418fe3802dc0
downloadaur-1e03d8d7b8ac7df73ec03c867ee96cdcbceec9a1.tar.gz
First commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..35bcd567a64c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libvdestack-git
+ pkgdesc = Internet of Threads through Network Namespaces
+ pkgver = r11.d9070d4
+ pkgrel = 1
+ url = https://github.com/rd235/libvdestack
+ arch = any
+ license = GPL2
+ depends = s2argv-execs-git
+ depends = vdeplug4-git
+ provides = libvdestack
+ conflicts = libvdestack
+ source = git+https://github.com/rd235/libvdestack.git
+ md5sums = SKIP
+
+pkgname = libvdestack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65622dfcde58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="libvdestack"
+
+pkgname="$_pkgname-git"
+pkgver=r11.d9070d4
+pkgrel=1
+pkgdesc="Internet of Threads through Network Namespaces"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+depends=('s2argv-execs-git' 'vdeplug4-git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ autoreconf -if
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}