summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora.kudelin2019-12-01 17:32:41 +0300
committera.kudelin2019-12-01 17:32:41 +0300
commit22ef611e999faab7561b48f226c36ff65bd38e10 (patch)
tree145fac6511aa39ce522c65b7e5656e61c3427229
downloadaur-22ef611e999faab7561b48f226c36ff65bd38e10.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f582fa92d22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libvdwxc
+ pkgdesc = A library for vdW-DF exchange-correlation functionals
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://libvdwxc.org/
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ depends = fftw-mpi
+ source = https://gitlab.com/libvdwxc/libvdwxc/-/archive/0.4.0/libvdwxc-0.4.0.tar.bz2
+ sha256sums = 5fcd37253489931b94ce865bb4e6942250665e269057a50bd532c8697ac19dc7
+
+pkgname = libvdwxc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6a27cbde711
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+
+pkgname=libvdwxc
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A library for vdW-DF exchange-correlation functionals"
+arch=("x86_64")
+url="https://libvdwxc.org/"
+license=('GPL')
+depends=('fftw-mpi')
+makedepends=('gcc-fortran')
+source=("https://gitlab.com/$pkgname/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.bz2")
+sha256sums=('5fcd37253489931b94ce865bb4e6942250665e269057a50bd532c8697ac19dc7')
+
+prepare() {
+ cd $pkgname-$pkgver
+ autoreconf -if
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --with-fftw3 \
+ --with-mpi
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}