summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Medoc2016-05-24 09:21:21 +0000
committerOlivier Medoc2016-05-24 09:21:21 +0000
commitf059238ba14d4e7eb8ec1df8ddc04d5d9b318ea3 (patch)
tree4115d857fd15633957f723a43307ff025d7352ee
downloadaur-f059238ba14d4e7eb8ec1df8ddc04d5d9b318ea3.tar.gz
first commit
-rw-r--r--.SRCINFO28
-rwxr-xr-xPKGBUILD45
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fefe29d7acb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = libvhdi
+ pkgdesc = Library and tools to access the Virtual Hard Disk (VHD) image format
+ pkgver = 20160424
+ pkgrel = 1
+ url = https://github.com/libyal/libvhdi/
+ arch = any
+ license = LGPLv3+
+ makedepends = python2
+ makedepends = python
+ makedepends = gcc
+ makedepends = git
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = gettext
+ makedepends = libtool
+ makedepends = pkg-config
+ makedepends = fuse
+ depends = python2
+ depends = python
+ depends = fuse
+ provides = libvhdi
+ provides = python2-libvhdi
+ provides = python3-libvhdi
+ source = https://github.com/libyal/libvhdi/archive/20160424.zip
+ md5sums = 1e70dc38ab301c13f3dcef8913efd81f
+
+pkgname = libvhdi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4c9c3af818a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+pkgname=('libvhdi')
+_realname=libvhdi
+pkgver=20160424
+pkgrel=1
+pkgdesc="Library and tools to access the Virtual Hard Disk (VHD) image format"
+url="https://github.com/libyal/libvhdi/"
+arch=('any')
+license=('LGPLv3+')
+
+provides=('libvhdi' 'python2-libvhdi' 'python3-libvhdi')
+depends=('python2' 'python' 'fuse')
+makedepends=('python2' 'python' 'gcc' 'git' 'automake' 'autoconf' 'gettext' 'libtool' 'pkg-config' 'fuse')
+source=(https://github.com/libyal/${_realname}/archive/${pkgver}.zip)
+
+prepare() {
+ cd $srcdir/${_realname}-${pkgver}
+
+ ./synclibs.sh
+ ./autogen.sh
+}
+
+build() {
+ cd $srcdir/${_realname}-${pkgver}
+ ./configure --prefix=/usr --enable-python2 --enable-python3
+ make
+}
+
+#Check will break ./configure options
+#check() {
+# cd $srcdir/${_realname}-${pkgver}
+# ./runtests.sh
+#}
+
+package_libvhdi() {
+ cd $srcdir/${_realname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+
+#setup.py will break ./configure options
+#package_python2-libvhdi() {
+# cd $srcdir/${_realname}-${pkgver}
+# python2 setup.py install --root="${pkgdir}"
+#}
+
+md5sums=('1e70dc38ab301c13f3dcef8913efd81f')