summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors3rj1k2022-06-03 17:25:49 +0300
committers3rj1k2022-06-03 17:25:49 +0300
commitc4b80cf567e02bcc62df71c80bfdcb6d01760f75 (patch)
tree247fa407011222e89fd1c51ebb5980de8f8d9310
downloadaur-c4b80cf567e02bcc62df71c80bfdcb6d01760f75.tar.gz
release 4.0.0-1
Signed-off-by: s3rj1k <evasive.gyron@gmail.com>
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD63
-rw-r--r--libvirt-glib-meson.build.patch37
3 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5618cc3fae0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libvirt-glib-vnc
+ pkgdesc = Libvirt-Glib runtime libraries and headers exclusively for VNC support.
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = https://gitlab.com/libvirt/libvirt-glib
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = gobject-introspection
+ makedepends = intltool
+ makedepends = meson
+ makedepends = python
+ makedepends = vala
+ depends = libcap-ng
+ depends = libvirt-vnc
+ conflicts = libvirt-glib
+ source = https://libvirt.org/sources/glib/libvirt-glib-4.0.0.tar.xz
+ source = https://libvirt.org/sources/glib/libvirt-glib-4.0.0.tar.xz.asc
+ source = libvirt-glib-meson.build.patch
+ validpgpkeys = 453B65310595562855471199CA68BE8010084C9C
+ validpgpkeys = DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF
+ sha256sums = 8423f7069daa476307321d1c11e2ecc285340cd32ca9fc05207762843edeacbd
+ sha256sums = SKIP
+ sha256sums = 274acd43b641abfc5b378ad866ac0dad78abd942ac347e2049eefa3ce2e5362c
+
+pkgname = libvirt-glib-vnc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a9c59901555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: s3rj1k <evasive dot gyron at gmail dot com>
+# Do not forget to run `makepkg --printsrcinfo > .SRCINFO`
+
+pkgname=libvirt-glib-vnc
+pkgver=4.0.0
+pkgrel=1
+pkgdesc='Libvirt-Glib runtime libraries and headers exclusively for VNC support.'
+arch=('x86_64')
+url="https://gitlab.com/libvirt/libvirt-glib"
+license=(
+ 'LGPL2.1'
+)
+depends=(
+ 'libcap-ng'
+ 'libvirt-vnc'
+)
+makedepends=(
+ 'gobject-introspection'
+ 'intltool'
+ 'meson'
+ 'python'
+ 'vala'
+)
+conflicts=(
+ 'libvirt-glib'
+)
+source=(
+ "https://libvirt.org/sources/glib/libvirt-glib-${pkgver}.tar.xz"{,'.asc'}
+ "libvirt-glib-meson.build.patch"
+)
+sha256sums=(
+ '8423f7069daa476307321d1c11e2ecc285340cd32ca9fc05207762843edeacbd'
+ 'SKIP'
+ '274acd43b641abfc5b378ad866ac0dad78abd942ac347e2049eefa3ce2e5362c'
+)
+validpgpkeys=(
+ '453B65310595562855471199CA68BE8010084C9C' # Jiří Denemark <jdenemar@redhat.com>
+ 'DAF3A6FDB26B62912D0E8E3FBE86EBB415104FDF' # Daniel P. Berrange <dan@berrange.com>
+)
+
+prepare() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ patch meson.build < "${srcdir}/libvirt-glib-meson.build.patch"
+}
+
+build() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ arch-meson build \
+ --prefix=/usr \
+ --buildtype=plain \
+ --auto-features disabled \
+ -Ddocs=disabled \
+ -Dintrospection=disabled \
+ -Dtests=disabled \
+ -Dvapi=disabled
+
+ ninja -C build
+}
+
+package() {
+ cd "${srcdir}/libvirt-glib-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}
diff --git a/libvirt-glib-meson.build.patch b/libvirt-glib-meson.build.patch
new file mode 100644
index 000000000000..dfd2227faad6
--- /dev/null
+++ b/libvirt-glib-meson.build.patch
@@ -0,0 +1,37 @@
+--- meson.build.old 2021-02-15 14:23:04.609036200 +0200
++++ meson.build.new 2022-06-03 11:01:25.629915217 +0300
+@@ -141,7 +141,7 @@
+ input: 'libvirt-gconfig-1.0.pc.in',
+ output: 'libvirt-gconfig-1.0.pc',
+ configuration: conf_data,
+- install: true,
++ install: false,
+ install_dir: pkgconfdir
+ )
+
+@@ -149,7 +149,7 @@
+ input: 'libvirt-gobject-1.0.pc.in',
+ output: 'libvirt-gobject-1.0.pc',
+ configuration: conf_data,
+- install: true,
++ install: false,
+ install_dir: pkgconfdir
+ )
+
+@@ -530,11 +530,11 @@
+
+
+ subdir('libvirt-glib')
+-subdir('libvirt-gconfig')
+-subdir('libvirt-gobject')
+-subdir('po')
+-subdir('examples')
+-subdir('docs')
++#subdir('libvirt-gconfig')
++#subdir('libvirt-gobject')
++#subdir('po')
++#subdir('examples')
++#subdir('docs')
+ if build_tests
+ subdir('tests')
+ endif