summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhwangeug2020-11-28 17:30:37 -0800
committerhwangeug2020-11-28 17:30:37 -0800
commit041aacea7390635a2d1d9629d57316c3f2cf8c88 (patch)
tree7a6d95d4c4e59cde06843099aacea0cc4b7bbe81
downloadaur-041aacea7390635a2d1d9629d57316c3f2cf8c88.tar.gz
first commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc0725dc254a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libvirt-hook-helper-git
+ pkgdesc = Helper tool to run scripts on libvirt VM startup or shutdown
+ pkgver = r42.0bdc0aa
+ pkgrel = 1
+ arch = any
+ license = MIT
+ provides = libvirt-hook-helper
+ conflicts = libvirt-hook-helper
+ source = libvirt-hook-helper::git://github.com/PassthroughPOST/VFIO-Tools
+ sha256sums = SKIP
+
+pkgname = libvirt-hook-helper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bbd2058494e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: eugene hwang <hwang dot eug at gmail dot com>
+
+_reponame=VFIO-Tools
+_binname=qemu
+_pkgname=libvirt-hook-helper
+pkgname=libvirt-hook-helper-git
+pkgver=r42.0bdc0aa
+pkgrel=1
+pkgdesc="Helper tool to run scripts on libvirt VM startup or shutdown"
+arch=('any')
+license=('MIT')
+provides=('libvirt-hook-helper')
+conflicts=('libvirt-hook-helper')
+source=("${_pkgname}::git://github.com/PassthroughPOST/VFIO-Tools")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}/libvirt_hooks/${_binname}" "${pkgdir}/etc/libvirt/hooks/${_binname}"
+}