summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlain Kalker2015-10-28 11:54:47 +0100
committerAlain Kalker2015-10-28 12:02:14 +0100
commitb9e4c3ba42ebe7513b4734f19142395958a61bf1 (patch)
tree41396bc707c2963d9addb814c50bca406ffe41e0
downloadaur-b9e4c3ba42ebe7513b4734f19142395958a61bf1.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91da778fb282
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libvirt-sandbox
+ pkgdesc = An application sandbox toolkit
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = http://sandbox.libvirt.org/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = intltool
+ depends = libvirt-glib
+ depends = libselinux
+ depends = cpio
+ optdepends = dhclient: for sandbox network configuration using DHCP
+ optdepends = python2-gobject: for virt-sandbox-service
+ source = http://libvirt.org/sources/sandbox/libvirt-sandbox-0.6.0.tar.gz
+ source = http://libvirt.org/sources/sandbox/libvirt-sandbox-0.6.0.tar.gz.asc
+ md5sums = 546eb0caaa79d50a723adf58f32da87f
+ md5sums = 633854ecab0fb2a4f5f4ee958a731daf
+
+pkgname = libvirt-sandbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33c4b51a2a49
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Alain Kalker <a.c.kalker@gmail.com>
+pkgname=libvirt-sandbox
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="An application sandbox toolkit"
+arch=('i686' 'x86_64')
+url="http://sandbox.libvirt.org/"
+license=('LGPL')
+depends=('libvirt-glib' 'libselinux' 'cpio')
+makedepends=('gobject-introspection' 'intltool')
+optdepends=('dhclient: for sandbox network configuration using DHCP'
+ 'python2-gobject: for virt-sandbox-service')
+source=(http://libvirt.org/sources/sandbox/$pkgname-$pkgver.tar.gz{,.asc})
+md5sums=('546eb0caaa79d50a723adf58f32da87f'
+ '633854ecab0fb2a4f5f4ee958a731daf')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Use python2
+ sed -i -e '1s/python/&2/' bin/virt-sandbox-service
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # Work around linker error caused by missing static library liblzma.a
+ # by disabling LZMA support for now.
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/$pkgname \
+ --sysconfdir=/etc \
+ --enable-introspection \
+ --without-lzma
+ make
+}
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make -k check
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: