summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Corcoran2018-03-22 07:17:12 +1300
committerMichael Corcoran2018-03-22 07:17:12 +1300
commitfa81d2254b1b39f9557e7d7fa847bdb2d9872998 (patch)
treee29fae41cf16f9e3b6890f09d0a71a6e5545e599
parente4e4124744b0ef28b99c2d8a2c5713e5cf803225 (diff)
downloadaur-fa81d2254b1b39f9557e7d7fa847bdb2d9872998.tar.gz
Remove U64 patch, I upstreamed it
-rw-r--r--.SRCINFO6
-rw-r--r--001-u64-to-counter64.patch106
-rw-r--r--PKGBUILD11
3 files changed, 4 insertions, 119 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8a93eb1741f..65c03403836a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libvirt-snmp-git
pkgdesc = net-snmp agent for libvirt virtualization management
- pkgver = r28.5370943
- pkgrel = 2
+ pkgver = r30.1ad3cf3
+ pkgrel = 1
url = http://libvirt.org/
install = libvirt-snmp.install
arch = x86_64
@@ -13,11 +13,9 @@ pkgbase = libvirt-snmp-git
provides = libvirt-snmp
conflicts = libvirt-snmp
source = libvirt-snmp-git::git+https://github.com/libvirt/libvirt-snmp.git
- source = 001-u64-to-counter64.patch
source = libvirt-snmp.service
source = libvirt-snmp.install
md5sums = SKIP
- md5sums = 062bf2ba6682cc44e1483dddb64278c9
md5sums = f4b8b6345abe4fadab45e81290799029
md5sums = a101751363499dbb87492e040c6702ae
diff --git a/001-u64-to-counter64.patch b/001-u64-to-counter64.patch
deleted file mode 100644
index 6038f5b25a6f..000000000000
--- a/001-u64-to-counter64.patch
+++ /dev/null
@@ -1,106 +0,0 @@
-diff --git a/src/defaults/node-libvirtGuestCpuTime.m2d b/src/defaults/node-libvirtGuestCpuTime.m2d
-index 795f697..9889f77 100644
---- a/src/defaults/node-libvirtGuestCpuTime.m2d
-+++ b/src/defaults/node-libvirtGuestCpuTime.m2d
-@@ -11,7 +11,7 @@
- ## If you do, it is likely to break lots of generated code that
- ## you will have to fix.
- ##
--## @eval $m2c_decl = U64@
-+## @eval $m2c_decl = struct counter64@
- ##
- ########################################################################
- ## Generate/use mapping functions? Useful if the MIB defines
-diff --git a/src/libvirtGuestTable-README-libvirtGuestTable.txt b/src/libvirtGuestTable-README-libvirtGuestTable.txt
-index 5a74dae..2383e8b 100644
---- a/src/libvirtGuestTable-README-libvirtGuestTable.txt
-+++ b/src/libvirtGuestTable-README-libvirtGuestTable.txt
-@@ -722,7 +722,7 @@ The CPU time used by the virtual guest, in nanoseconds.
- *
- *
- * Its syntax is COUNTER64 (based on perltype COUNTER64)
-- * The net-snmp type is ASN_COUNTER64. The C type decl is U64 (U64)
-+ * The net-snmp type is ASN_COUNTER64. The C type decl is struct counter64 (U64)
- */
- /*---------------------------------------------------------------------
- * LIBVIRT-MIB::libvirtGuestEntry.libvirtGuestRowStatus
-diff --git a/src/libvirtGuestTable.h b/src/libvirtGuestTable.h
-index ca27abd..fcb3194 100644
---- a/src/libvirtGuestTable.h
-+++ b/src/libvirtGuestTable.h
-@@ -121,7 +121,7 @@ typedef struct libvirtGuestTable_data_s {
- /*
- * libvirtGuestCpuTime(7)/COUNTER64/ASN_COUNTER64/U64(U64)//l/A/w/e/r/d/h
- */
-- U64 libvirtGuestCpuTime;
-+ struct counter64 libvirtGuestCpuTime;
-
- /*
- * libvirtGuestRowStatus(9)/RowStatus/ASN_INTEGER/long(u_long)//l/A/W/E/r/d/h
-diff --git a/src/libvirtGuestTable_data_get.c b/src/libvirtGuestTable_data_get.c
-index b252bdd..7334743 100644
---- a/src/libvirtGuestTable_data_get.c
-+++ b/src/libvirtGuestTable_data_get.c
-@@ -442,7 +442,7 @@ The CPU time used by the virtual guest, in nanoseconds.
- *
- *
- * Its syntax is COUNTER64 (based on perltype COUNTER64)
-- * The net-snmp type is ASN_COUNTER64. The C type decl is U64 (U64)
-+ * The net-snmp type is ASN_COUNTER64. The C type decl is struct counter64 (U64)
- */
- /**
- * Extract the current value of the libvirtGuestCpuTime data.
-@@ -459,7 +459,7 @@ The CPU time used by the virtual guest, in nanoseconds.
- * @retval MFD_ERROR : Any other error
- */
- int
--libvirtGuestCpuTime_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, U64 * libvirtGuestCpuTime_val_ptr )
-+libvirtGuestCpuTime_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, struct counter64 * libvirtGuestCpuTime_val_ptr )
- {
- /** we should have a non-NULL pointer */
- netsnmp_assert( NULL != libvirtGuestCpuTime_val_ptr );
-diff --git a/src/libvirtGuestTable_data_get.h b/src/libvirtGuestTable_data_get.h
-index 450d112..6a0e7ff 100644
---- a/src/libvirtGuestTable_data_get.h
-+++ b/src/libvirtGuestTable_data_get.h
-@@ -55,7 +55,7 @@ extern "C" {
- int libvirtGuestCpuCount_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long * libvirtGuestCpuCount_val_ptr );
- int libvirtGuestMemoryCurrent_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long * libvirtGuestMemoryCurrent_val_ptr );
- int libvirtGuestMemoryLimit_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long * libvirtGuestMemoryLimit_val_ptr );
-- int libvirtGuestCpuTime_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, U64 * libvirtGuestCpuTime_val_ptr );
-+ int libvirtGuestCpuTime_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, struct counter64 * libvirtGuestCpuTime_val_ptr );
- int libvirtGuestRowStatus_get( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long * libvirtGuestRowStatus_val_ptr );
-
-
-diff --git a/src/libvirtGuestTable_data_set.h b/src/libvirtGuestTable_data_set.h
-index cce0fe7..873f9f5 100644
---- a/src/libvirtGuestTable_data_set.h
-+++ b/src/libvirtGuestTable_data_set.h
-@@ -80,9 +80,9 @@ int libvirtGuestMemoryLimit_undo_setup( libvirtGuestTable_rowreq_ctx *rowreq_ctx
- int libvirtGuestMemoryLimit_set( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long libvirtGuestMemoryLimit_val );
- int libvirtGuestMemoryLimit_undo( libvirtGuestTable_rowreq_ctx *rowreq_ctx );
-
--int libvirtGuestCpuTime_check_value( libvirtGuestTable_rowreq_ctx *rowreq_ctx, U64 libvirtGuestCpuTime_val);
-+int libvirtGuestCpuTime_check_value( libvirtGuestTable_rowreq_ctx *rowreq_ctx, struct counter64 libvirtGuestCpuTime_val);
- int libvirtGuestCpuTime_undo_setup( libvirtGuestTable_rowreq_ctx *rowreq_ctx );
--int libvirtGuestCpuTime_set( libvirtGuestTable_rowreq_ctx *rowreq_ctx, U64 libvirtGuestCpuTime_val );
-+int libvirtGuestCpuTime_set( libvirtGuestTable_rowreq_ctx *rowreq_ctx, struct counter64 libvirtGuestCpuTime_val );
- int libvirtGuestCpuTime_undo( libvirtGuestTable_rowreq_ctx *rowreq_ctx );
-
- int libvirtGuestRowStatus_check_value( libvirtGuestTable_rowreq_ctx *rowreq_ctx, u_long libvirtGuestRowStatus_val);
-diff --git a/src/libvirtGuestTable_interface.c b/src/libvirtGuestTable_interface.c
-index ce29c3b..75616d1 100644
---- a/src/libvirtGuestTable_interface.c
-+++ b/src/libvirtGuestTable_interface.c
-@@ -844,9 +844,9 @@ rc = libvirtGuestMemoryLimit_get(rowreq_ctx, (u_long *)var->val.string );
-
- /* libvirtGuestCpuTime(7)/COUNTER64/ASN_COUNTER64/U64(U64)//l/A/w/e/r/d/h */
- case COLUMN_LIBVIRTGUESTCPUTIME:
-- var->val_len = sizeof(U64);
-+ var->val_len = sizeof(struct counter64);
- var->type = ASN_COUNTER64;
--rc = libvirtGuestCpuTime_get(rowreq_ctx, (U64 *)var->val.string );
-+rc = libvirtGuestCpuTime_get(rowreq_ctx, (struct counter64 *)var->val.string );
- break;
-
- /* libvirtGuestRowStatus(9)/RowStatus/ASN_INTEGER/long(u_long)//l/A/W/E/r/d/h */
diff --git a/PKGBUILD b/PKGBUILD
index 8d559711f885..b90828619cd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Michael Corcoran <tracer@outlook.co.nz>
pkgname=libvirt-snmp-git
_pkgname=libvirt-snmp
-pkgver=r28.5370943
-pkgrel=2
+pkgver=r30.1ad3cf3
+pkgrel=1
pkgdesc="net-snmp agent for libvirt virtualization management"
arch=('x86_64')
url="http://libvirt.org/"
@@ -15,11 +15,9 @@ provides=($_pkgname)
conflicts=($_pkgname)
install=${_pkgname}.install
source=("$pkgname::git+https://github.com/libvirt/libvirt-snmp.git"
- '001-u64-to-counter64.patch'
"${_pkgname}.service"
"${_pkgname}.install")
md5sums=('SKIP'
- '062bf2ba6682cc44e1483dddb64278c9'
'f4b8b6345abe4fadab45e81290799029'
'a101751363499dbb87492e040c6702ae')
@@ -28,11 +26,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$pkgname"
- patch -p1 -i "${srcdir}/001-u64-to-counter64.patch"
-}
-
build() {
cd "$pkgname"
./autogen.sh