summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 19:51:23 +0200
committerAntonio Rojas2022-04-01 19:51:23 +0200
commit6bb7673a77abe0047b359377df1a8f9d24282e2d (patch)
treea4b4cc4bb1ed7e8cd7610daf71cb0091dd4ca9d5
downloadaur-6bb7673a77abe0047b359377df1a8f9d24282e2d.tar.gz
import from community
-rw-r--r--.SRCINFO30
-rw-r--r--02_64-bit_JESS_fix.patch58
-rw-r--r--03_build_against_gl_fixes.patch372
-rw-r--r--04_lv_analyzer_build_fix.patch12
-rw-r--r--050_all_automagic.patch50
-rw-r--r--05_fix_po.patch127
-rw-r--r--60_no-const-vispluginfo-in-nastyfft.patch18
-rw-r--r--PKGBUILD51
8 files changed, 718 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d9e69a71f27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = libvisual-plugins
+ pkgdesc = plugins for libvisual
+ pkgver = 0.4.0
+ pkgrel = 11
+ url = https://sourceforge.net/projects/libvisual/
+ arch = x86_64
+ license = GPL
+ makedepends = mesa
+ makedepends = gtk2
+ depends = libvisual
+ depends = glu
+ depends = alsa-lib
+ depends = jack
+ depends = gdk-pixbuf2
+ source = https://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-0.4.0.tar.bz2
+ source = 02_64-bit_JESS_fix.patch
+ source = 03_build_against_gl_fixes.patch
+ source = 04_lv_analyzer_build_fix.patch
+ source = 05_fix_po.patch
+ source = 050_all_automagic.patch
+ source = 60_no-const-vispluginfo-in-nastyfft.patch
+ sha256sums = 518eef40a8a41946a0c2c0d59ede40d53ba7c142873af71aa4d2d8f297396601
+ sha256sums = 49efe3991dd90c712916af06e4c1104bfc016f3004f77daaaba2be4a92eee251
+ sha256sums = c9e673b36c125fda5015fcb6462a69e5ab3ff55828342c8b8483e76f84853ef8
+ sha256sums = 083d3e16aacaf7853de713d604a1b2a06bc5f739d9c94a7bfe5099bf27da8670
+ sha256sums = be20595c8092dee1c07184a2fa4eb924decf9de752ee973d997688d192e0e346
+ sha256sums = b85bc97614d75f76f8f7fa9a0f6a1292813727229e615556f426b3386af625b5
+ sha256sums = 4906fd72097cb33fc4b88b89384cbb00685fee3de29d321178f92e8fb9610856
+
+pkgname = libvisual-plugins
diff --git a/02_64-bit_JESS_fix.patch b/02_64-bit_JESS_fix.patch
new file mode 100644
index 000000000000..1d7f99e566d8
--- /dev/null
+++ b/02_64-bit_JESS_fix.patch
@@ -0,0 +1,58 @@
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/JESS/renderer.c libvisual-plugins-0.4.0.new/plugins/actor/JESS/renderer.c
+--- libvisual-plugins-0.4.0/plugins/actor/JESS/renderer.c 2006-02-06 05:47:26.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/JESS/renderer.c 2007-07-04 18:12:58.000000000 +1000
+@@ -282,7 +282,7 @@
+
+ void render_deformation(JessPrivate *priv, int defmode)
+ {
+- uint32_t bmax;
++ intptr_t bmax;
+ uint32_t *tab1 = NULL, *tab2, *tab3, *tab4, i;
+ uint8_t *pix = priv->pixel, *buf = priv->buffer, *aux;
+
+@@ -294,7 +294,7 @@
+ tab2 = priv->table2;
+ tab3 = priv->table3;
+ tab4 = priv->table4;
+- bmax = priv->resx * priv->resy + (uint32_t) priv->pixel;
++ bmax = priv->resx * priv->resy + (intptr_t) priv->pixel;
+
+ switch(defmode)
+ {
+@@ -352,7 +352,7 @@
+ }
+ for (i = 0; i < priv->resy * priv->resx; i++)
+ {
+- aux = (uint8_t *) ((*(tab1) << 2 ) + (uint32_t) priv->buffer);
++ aux = (uint8_t *) ((*(tab1) << 2 ) + (intptr_t) priv->buffer);
+ *(pix++) = *(aux++) ;
+ *(pix++) = *(aux++);
+ *(pix++) = *(aux);
+@@ -373,7 +373,8 @@
+ /* j'ai mis pixel par defaut... */
+
+ uint8_t *pix = priv->pixel;
+- uint32_t bmax,pitch_4;
++ intptr_t bmax;
++ uint32_t pitch_4;
+
+ pix = priv->pixel;
+ if (priv->pixel == NULL)
+@@ -387,7 +388,7 @@
+ if (priv->video == 8)
+ {
+ if (visual_cpu_get_mmx ()) {
+- bmax = priv->resx * (priv->resy-1) + (uint32_t) priv->pixel;
++ bmax = priv->resx * (priv->resy-1) + (intptr_t) priv->pixel;
+ #if defined(VISUAL_ARCH_X86) || defined(VISUAL_ARCH_X86_64)
+ __asm __volatile
+ ("\n\t pxor %%mm6, %%mm6"
+@@ -423,7 +424,7 @@
+ else
+ {
+ pitch_4 = priv->pitch+4;
+- bmax = priv->pitch*(priv->resy-1) + (uint32_t) priv->pixel;
++ bmax = priv->pitch*(priv->resy-1) + (intptr_t) priv->pixel;
+
+ if (visual_cpu_get_mmx ()) {
+ #if defined(VISUAL_ARCH_X86) || defined(VISUAL_ARCH_X86_64)
diff --git a/03_build_against_gl_fixes.patch b/03_build_against_gl_fixes.patch
new file mode 100644
index 000000000000..b21558232cf3
--- /dev/null
+++ b/03_build_against_gl_fixes.patch
@@ -0,0 +1,372 @@
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/bumpscope/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/bumpscope/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/bumpscope/Makefile.am 2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/bumpscope/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_bumpscope.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_bumpscope_la_LDFLAGS = -module -avoid-version
++actor_bumpscope_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_bumpscope_la_SOURCES = actor_bumpscope.c \
+ actor_bumpscope.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/corona/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/corona/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/corona/Makefile.am 2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/corona/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_corona.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CXXFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_corona_la_LDFLAGS = -module -avoid-version
++actor_corona_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_corona_la_SOURCES = actor_corona.cpp \
+ autopal.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/gdkpixbuf/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/gdkpixbuf/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/gdkpixbuf/Makefile.am 2006-02-24 00:34:48.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/gdkpixbuf/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_gdkpixbuf.la
+
+-LIBS += $(LIBVISUAL_LIBS) $(GTK_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS) $(GTK_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_gdkpixbuf_la_LDFLAGS = -module -avoid-version
++actor_gdkpixbuf_la_LIBADD = $(LIBVISUAL_LIBS) $(GTK_LIBS)
+
+ actor_gdkpixbuf_la_SOURCES = actor_gdkpixbuf.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/gstreamer/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/gstreamer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/gstreamer/Makefile.am 2006-02-23 20:03:27.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/gstreamer/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,14 +2,13 @@
+
+ actor_plugin_LTLIBRARIES = actor_gstreamer.la
+
+-LIBS += $(LIBVISUAL_LIBS) $(GSTREAMER_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS) $(GSTREAMER_CFLAGS)
+
+ INCLUDES = $(all_includes) \
+ -I$(top_srcdir)
+
+ actor_gstreamer_la_LDFLAGS = -module -avoid-version
++actor_gstreamer_la_LIBADD = $(LIBVISUAL_LIBS) $(GSTREAMER_LIBS)
+
+ actor_gstreamer_la_SOURCES = actor_gstreamer.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/infinite/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/infinite/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/infinite/Makefile.am 2006-02-23 20:03:27.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/infinite/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_infinite.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_infinite_la_LDFLAGS = -module -avoid-version
++actor_infinite_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_infinite_la_SOURCES = compute.c compute.h \
+ display.c display.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/jakdaw/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/jakdaw/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/jakdaw/Makefile.am 2006-02-23 20:03:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/jakdaw/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_jakdaw.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_jakdaw_la_LDFLAGS = -module -avoid-version
++actor_jakdaw_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_jakdaw_la_SOURCES = actor_jakdaw.c \
+ actor_jakdaw.h \
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/JESS/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/JESS/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/JESS/Makefile.am 2006-02-23 20:03:24.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/JESS/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_JESS.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_JESS_la_LDFLAGS = -module -avoid-version
++actor_JESS_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_JESS_la_SOURCES = analyser.c analyser.h analyser_struct.h\
+ distorsion.c distorsion.h\
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_analyzer/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_analyzer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_analyzer/Makefile.am 2006-02-23 20:03:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_analyzer/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,14 +2,13 @@
+
+ actor_plugin_LTLIBRARIES = actor_lv_analyzer.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) \
+ -I$(top_srcdir)
+
+ actor_lv_analyzer_la_LDFLAGS = -module -avoid-version
++actor_lv_analyzer_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_lv_analyzer_la_SOURCES = actor_lv_analyzer.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_gltest/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_gltest/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_gltest/Makefile.am 2006-02-24 22:24:49.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_gltest/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -4,5 +4,5 @@
+
+ actor_lv_gltest_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+ actor_lv_gltest_la_LDFLAGS = -module -avoid-version
+-actor_lv_gltest_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
++actor_lv_gltest_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
+ actor_lv_gltest_la_SOURCES = actor_lv_gltest.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/lv_scope/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/lv_scope/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/lv_scope/Makefile.am 2006-02-23 20:03:29.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/lv_scope/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_lv_scope.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_lv_scope_la_LDFLAGS = -module -avoid-version
++actor_lv_scope_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_lv_scope_la_SOURCES = actor_lv_scope.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/madspin/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/madspin/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/madspin/Makefile.am 2006-02-24 22:24:49.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/madspin/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -10,5 +10,5 @@
+
+ actor_madspin_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) -DSTAR_DIR=\""$(imagesdir)/"\"
+ actor_madspin_la_LDFLAGS = -module -avoid-version
+-actor_madspin_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL
++actor_madspin_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL
+ actor_madspin_la_SOURCES = madspin.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/nastyfft/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/nastyfft/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/nastyfft/Makefile.am 2006-02-24 22:24:50.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/nastyfft/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -4,5 +4,5 @@
+
+ actor_nastyfft_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+ actor_nastyfft_la_LDFLAGS = -module -avoid-version
+-actor_nastyfft_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
++actor_nastyfft_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
+ actor_nastyfft_la_SOURCES = actor_nastyfft.c
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/oinksie/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/oinksie/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/oinksie/Makefile.am 2006-02-23 20:03:31.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/oinksie/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ actor_plugin_LTLIBRARIES = actor_oinksie.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ actor_oinksie_la_LDFLAGS = -module -avoid-version
++actor_oinksie_la_LIBADD = $(LIBVISUAL_LIBS)
+
+ actor_oinksie_la_SOURCES = actor_oinksie.c\
+ oinksie.c oinksie.h\
+diff -Nur libvisual-plugins-0.4.0/plugins/actor/pseudotoad_flower/Makefile.am libvisual-plugins-0.4.0.new/plugins/actor/pseudotoad_flower/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/actor/pseudotoad_flower/Makefile.am 2006-03-09 00:06:58.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/actor/pseudotoad_flower/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -4,7 +4,7 @@
+
+ actor_flower_la_LDFLAGS = -module -avoid-version
+ actor_flower_la_CFLAGS = -I$(top_srcdir) $(LIBVISUAL_CFLAGS) $(X_CFLAGS)
+-actor_flower_la_LIBS = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
++actor_flower_la_LIBADD = $(LIBVISUAL_LIBS) $(X_LIBS) -lGL -lGLU
+
+ actor_flower_la_SOURCES = \
+ actor_flower.c \
+diff -Nur libvisual-plugins-0.4.0/plugins/input/alsa/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/alsa/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/alsa/Makefile.am 2006-02-23 20:03:35.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/alsa/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,12 +2,11 @@
+
+ input_plugin_LTLIBRARIES = input_alsa.la
+
+-LIBS += $(ALSA_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(ALSA_CFLAGS) $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir) -I$(top_builddir)
+
+ input_alsa_la_LDFLAGS = -module -avoid-version
++input_alsa_la_LIBADD = $(ALSA_LIBS) $(LIBVISUAL_LIBS)
+
+ input_alsa_la_SOURCES = input_alsa.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/debug/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/debug/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/debug/Makefile.am 2006-02-23 20:03:36.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/debug/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ input_plugin_LTLIBRARIES = input_debug.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir) -I$(top_builddir)
+
+ input_debug_la_LDFLAGS = -module -avoid-version
++input_debug_la_LIBADD = $(LIBVISUAL_LIBS)
+ input_debug_la_SOURCES = input_debug.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/esd/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/esd/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/esd/Makefile.am 2006-02-23 20:03:37.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/esd/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ input_plugin_LTLIBRARIES = input_esd.la
+
+-LIBS += $(LIBESD_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBESD_CFLAGS) $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ input_esd_la_LDFLAGS = -module -avoid-version
++input_esd_la_LIBADD = $(LIBESD_LIBS) $(LIBVISUAL_LIBS)
+ input_esd_la_SOURCES = input_esd.c
+diff -Nur libvisual-plugins-0.4.0/plugins/input/jack/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/jack/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/jack/Makefile.am 2006-02-23 20:03:37.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/jack/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,13 +2,12 @@
+
+ input_plugin_LTLIBRARIES = input_jack.la
+
+-LIBS += $(LIBJACK_LIBS) $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBJACK_CFLAGS) $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ input_jack_la_LDFLAGS = -module -avoid-version
++input_jack_la_LIBADD = $(LIBJACK_LIBS) $(LIBVISUAL_LIBS)
+
+ input_jack_la_SOURCES = input_jack.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/input/mplayer/Makefile.am libvisual-plugins-0.4.0.new/plugins/input/mplayer/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/input/mplayer/Makefile.am 2006-02-23 20:03:38.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/input/mplayer/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,12 +2,11 @@
+
+ input_plugin_LTLIBRARIES = input_mplayer.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ input_mplayer_la_LDFLAGS = -module -avoid-version
++input_mplayer_la_LIBADD = $(LIBVISUAL_LIBS)
+ input_mplayer_la_SOURCES = input_mplayer.c
+
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/alphablend/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/alphablend/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/alphablend/Makefile.am 2006-02-23 20:03:38.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/alphablend/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ morph_plugin_LTLIBRARIES = morph_alphablend.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ morph_alphablend_la_LDFLAGS = -module -avoid-version
++morph_alphablend_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_alphablend_la_SOURCES = morph_alphablend.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/flash/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/flash/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/flash/Makefile.am 2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/flash/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ morph_plugin_LTLIBRARIES = morph_flash.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ morph_flash_la_LDFLAGS = -module -avoid-version
++morph_flash_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_flash_la_SOURCES = morph_flash.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/slide/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/slide/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/slide/Makefile.am 2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/slide/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ morph_plugin_LTLIBRARIES = morph_slide.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ morph_slide_la_LDFLAGS = -module -avoid-version
++morph_slide_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_slide_la_SOURCES = morph_slide.c
+diff -Nur libvisual-plugins-0.4.0/plugins/morph/tentacle/Makefile.am libvisual-plugins-0.4.0.new/plugins/morph/tentacle/Makefile.am
+--- libvisual-plugins-0.4.0/plugins/morph/tentacle/Makefile.am 2006-02-23 20:03:39.000000000 +1100
++++ libvisual-plugins-0.4.0.new/plugins/morph/tentacle/Makefile.am 2007-07-04 18:19:43.000000000 +1000
+@@ -2,11 +2,10 @@
+
+ morph_plugin_LTLIBRARIES = morph_tentacle.la
+
+-LIBS += $(LIBVISUAL_LIBS)
+-
+ AM_CFLAGS = $(LIBVISUAL_CFLAGS)
+
+ INCLUDES = $(all_includes) -I$(top_srcdir)
+
+ morph_tentacle_la_LDFLAGS = -module -avoid-version
++morph_tentacle_la_LIBADD = $(LIBVISUAL_LIBS)
+ morph_tentacle_la_SOURCES = morph_tentacle.c
diff --git a/04_lv_analyzer_build_fix.patch b/04_lv_analyzer_build_fix.patch
new file mode 100644
index 000000000000..1fc5f7fc71b2
--- /dev/null
+++ b/04_lv_analyzer_build_fix.patch
@@ -0,0 +1,12 @@
+diff -Nur libvisual-plugins-0.4.0/configure.ac libvisual-plugins-0.4.0.new/configure.ac
+--- libvisual-plugins-0.4.0/configure.ac 2006-03-17 03:50:41.000000000 +1100
++++ libvisual-plugins-0.4.0.new/configure.ac 2007-07-04 18:22:38.000000000 +1000
+@@ -361,7 +361,7 @@
+ [ENABLE_ANALYZER=$enableval],
+ [ENABLE_ANALYZER=yes])
+
+-if test "$ENABLE_ANALYZER" = xyes; then
++if test "$ENABLE_ANALYZER" = "yes"; then
+ build_actor_plugins="$build_actor_plugins lv_analyzer"
+ fi
+
diff --git a/050_all_automagic.patch b/050_all_automagic.patch
new file mode 100644
index 000000000000..9c25fac720d3
--- /dev/null
+++ b/050_all_automagic.patch
@@ -0,0 +1,50 @@
+--- configure.ac.old 2007-02-24 23:09:08.000000000 +0100
++++ configure.ac 2007-02-24 23:13:15.000000000 +0100
+@@ -89,7 +89,18 @@
+
+ dnl Libraries
+
++dnl List of plugins to build
++build_input_plugins=""
++build_actor_plugins=""
++build_morph_plugins=""
++
+ dnl EsounD
++AC_ARG_ENABLE([esd], AS_HELP_STRING([--disable-esd],
++ [Do not build esound input plugin @<:@default=enabled@:>@]),
++ [ENABLE_INPUT_ESD=$enableval],
++ [ENABLE_INPUT_ESD=yes])
++
++if test "$ENABLE_INPUT_ESD" = "yes"; then
+ PKG_CHECK_MODULES([LIBESD], [esound >= esound_required_version],
+ [HAVE_ESD="yes"], [HAVE_ESD="no"])
+
+@@ -98,8 +109,15 @@
+ else
+ AC_MSG_WARN([*** EsounD not found or too old. The EsounD input plugin won't be built])
+ fi
++fi
+
+ dnl JACK
++AC_ARG_ENABLE([jack], AS_HELP_STRING([--disable-jack],
++ [Do not build jack input plugin @<:@default=enabled@:>@]),
++ [ENABLE_INPUT_JACK=$enableval],
++ [ENABLE_INPUT_JACK=yes])
++
++if test "$ENABLE_INPUT_JACK" = "yes"; then
+ PKG_CHECK_MODULES([LIBJACK], [jack >= jack_required_version], [HAVE_JACK="yes"], [HAVE_JACK="no"])
+ if test "$HAVE_JACK" = "yes"; then
+ build_input_plugins="$build_input_plugins jack"
+@@ -107,11 +125,7 @@
+ AC_MSG_WARN([*** libjack is too old. You can download a newer version at
+ http://jackit.sf.net/. The jackit input plugin won't be built])
+ fi
+-
+-dnl List of plugins to build
+-build_input_plugins=""
+-build_actor_plugins=""
+-build_morph_plugins=""
++fi
+
+ dnl GdkPixbuf
+ AC_ARG_ENABLE([gdkpixbuf-plugin],
diff --git a/05_fix_po.patch b/05_fix_po.patch
new file mode 100644
index 000000000000..a5413ef1ba09
--- /dev/null
+++ b/05_fix_po.patch
@@ -0,0 +1,127 @@
+diff -Nur libvisual-plugins-0.4.0/po/Makefile.in.in libvisual-plugins-0.4.0.new/po/Makefile.in.in
+--- libvisual-plugins-0.4.0/po/Makefile.in.in 2006-03-21 05:48:28.000000000 +1100
++++ libvisual-plugins-0.4.0.new/po/Makefile.in.in 2007-07-09 21:50:13.000000000 +1000
+@@ -28,7 +28,7 @@
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
++MKINSTALLDIRS = mkinstalldirs
+ mkinstalldirs = $(SHELL) $(MKINSTALLDIRS)
+
+ GMSGFMT = @GMSGFMT@
+diff -Nur libvisual-plugins-0.4.0/po/mkinstalldirs libvisual-plugins-0.4.0.new/po/mkinstalldirs
+--- libvisual-plugins-0.4.0/po/mkinstalldirs 1970-01-01 10:00:00.000000000 +1000
++++ libvisual-plugins-0.4.0.new/po/mkinstalldirs 2006-03-21 05:48:42.000000000 +1100
+@@ -0,0 +1,111 @@
++#! /bin/sh
++# mkinstalldirs --- make directory hierarchy
++# Author: Noah Friedman <friedman@prep.ai.mit.edu>
++# Created: 1993-05-16
++# Public domain
++
++errstatus=0
++dirmode=""
++
++usage="\
++Usage: mkinstalldirs [-h] [--help] [-m mode] dir ..."
++
++# process command line arguments
++while test $# -gt 0 ; do
++ case $1 in
++ -h | --help | --h*) # -h for help
++ echo "$usage" 1>&2
++ exit 0
++ ;;
++ -m) # -m PERM arg
++ shift
++ test $# -eq 0 && { echo "$usage" 1>&2; exit 1; }
++ dirmode=$1
++ shift
++ ;;
++ --) # stop option processing
++ shift
++ break
++ ;;
++ -*) # unknown option
++ echo "$usage" 1>&2
++ exit 1
++ ;;
++ *) # first non-opt arg
++ break
++ ;;
++ esac
++done
++
++for file
++do
++ if test -d "$file"; then
++ shift
++ else
++ break
++ fi
++done
++
++case $# in
++ 0) exit 0 ;;
++esac
++
++case $dirmode in
++ '')
++ if mkdir -p -- . 2>/dev/null; then
++ echo "mkdir -p -- $*"
++ exec mkdir -p -- "$@"
++ fi
++ ;;
++ *)
++ if mkdir -m "$dirmode" -p -- . 2>/dev/null; then
++ echo "mkdir -m $dirmode -p -- $*"
++ exec mkdir -m "$dirmode" -p -- "$@"
++ fi
++ ;;
++esac
++
++for file
++do
++ set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
++ shift
++
++ pathcomp=
++ for d
++ do
++ pathcomp="$pathcomp$d"
++ case $pathcomp in
++ -*) pathcomp=./$pathcomp ;;
++ esac
++
++ if test ! -d "$pathcomp"; then
++ echo "mkdir $pathcomp"
++
++ mkdir "$pathcomp" || lasterr=$?
++
++ if test ! -d "$pathcomp"; then
++ errstatus=$lasterr
++ else
++ if test ! -z "$dirmode"; then
++ echo "chmod $dirmode $pathcomp"
++ lasterr=""
++ chmod "$dirmode" "$pathcomp" || lasterr=$?
++
++ if test ! -z "$lasterr"; then
++ errstatus=$lasterr
++ fi
++ fi
++ fi
++ fi
++
++ pathcomp="$pathcomp/"
++ done
++done
++
++exit $errstatus
++
++# Local Variables:
++# mode: shell-script
++# sh-indentation: 2
++# End:
++# mkinstalldirs ends here
diff --git a/60_no-const-vispluginfo-in-nastyfft.patch b/60_no-const-vispluginfo-in-nastyfft.patch
new file mode 100644
index 000000000000..8e54e02cb338
--- /dev/null
+++ b/60_no-const-vispluginfo-in-nastyfft.patch
@@ -0,0 +1,18 @@
+The static VisPluginInfo in nastyfft was declared as const, but libvisual write
+to its refcount when it visual_object_unref()s it (nasty!). This is broken at
+various levels: libvisual shouldn't be writing to this static plugin which is
+allocated by a dlopen()ed plugin, and it should also honor the "const
+VisPluginInfo" API... Anyway, nastyfft was the only occurrence and this fixes
+the crash for now; LP: #287448.
+
+--- libvisual-plugins-0.4.0.dfsg.1.orig/plugins/actor/nastyfft/actor_nastyfft.c
++++ libvisual-plugins-0.4.0.dfsg.1/plugins/actor/nastyfft/actor_nastyfft.c
+@@ -80,7 +80,7 @@
+ .vidoptions.depth = VISUAL_VIDEO_DEPTH_GL
+ }};
+
+- static const VisPluginInfo info[] = {{
++ static VisPluginInfo info[] = {{
+ .type = VISUAL_PLUGIN_TYPE_ACTOR,
+
+ .plugname = N_("nastyfft"),
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92355e7e188f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=libvisual-plugins
+pkgver=0.4.0
+pkgrel=11
+pkgdesc="plugins for libvisual"
+arch=("x86_64")
+license=('GPL')
+url="https://sourceforge.net/projects/libvisual/"
+depends=('libvisual' 'glu' 'alsa-lib' 'jack' 'gdk-pixbuf2')
+makedepends=('mesa' 'gtk2')
+source=(https://downloads.sourceforge.net/sourceforge/libvisual/libvisual-plugins-${pkgver}.tar.bz2
+ 02_64-bit_JESS_fix.patch
+ 03_build_against_gl_fixes.patch
+ 04_lv_analyzer_build_fix.patch
+ 05_fix_po.patch
+ 050_all_automagic.patch
+ 60_no-const-vispluginfo-in-nastyfft.patch)
+sha256sums=('518eef40a8a41946a0c2c0d59ede40d53ba7c142873af71aa4d2d8f297396601'
+ '49efe3991dd90c712916af06e4c1104bfc016f3004f77daaaba2be4a92eee251'
+ 'c9e673b36c125fda5015fcb6462a69e5ab3ff55828342c8b8483e76f84853ef8'
+ '083d3e16aacaf7853de713d604a1b2a06bc5f739d9c94a7bfe5099bf27da8670'
+ 'be20595c8092dee1c07184a2fa4eb924decf9de752ee973d997688d192e0e346'
+ 'b85bc97614d75f76f8f7fa9a0f6a1292813727229e615556f426b3386af625b5'
+ '4906fd72097cb33fc4b88b89384cbb00685fee3de29d321178f92e8fb9610856')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i "${srcdir}/02_64-bit_JESS_fix.patch"
+ patch -Np1 -i "${srcdir}/03_build_against_gl_fixes.patch"
+ patch -Np1 -i "${srcdir}/04_lv_analyzer_build_fix.patch"
+ patch -Np0 -i "${srcdir}/050_all_automagic.patch"
+ patch -Np1 -i "${srcdir}/60_no-const-vispluginfo-in-nastyfft.patch"
+
+ autoreconf -fi
+ # Apply later as autoreconf overwrites po/Makefile.in.in
+ patch -Np1 -i "${srcdir}/05_fix_po.patch"
+
+ ./configure --prefix=/usr \
+ --disable-gstreamer-plugin \
+ --disable-gforce \
+ --disable-esd
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}