summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2018-10-05 22:34:13 +0200
committerGFdevelop2018-10-05 22:34:13 +0200
commitf1c2811879431b6a80722070c90aa11714d5429f (patch)
tree417b3963994ca32ce15040e8221ece5925d90866
downloadaur-f1c2811879431b6a80722070c90aa11714d5429f.tar.gz
first commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b38a19f6062
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = libvolatilestream-git
+ pkgdesc = volatile stream = stdio FILE* stream as a temporary dynamically allocated (and deallocated) memory buffer
+ pkgver = r3.6b564fc
+ pkgrel = 1
+ url = https://github.com/rd235/libvolatilestream
+ arch = any
+ license = GPL2
+ source = git+https://github.com/rd235/libvolatilestream.git
+ md5sums = SKIP
+
+pkgname = libvolatilestream-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..867b98a82537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
+
+_pkgname="libvolatilestream"
+
+pkgname="$_pkgname-git"
+pkgver=r3.6b564fc
+pkgrel=1
+pkgdesc="volatile stream = stdio FILE* stream as a temporary dynamically allocated (and deallocated) memory buffer"
+arch=('any')
+url="https://github.com/rd235/$_pkgname"
+license=('GPL2')
+source=("git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$_pkgname"
+ make DESTDIR="$pkgdir/" install
+}