summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastien Traverse2021-05-17 00:29:18 +0200
committerBastien Traverse2021-05-17 00:29:18 +0200
commitbc74fed9439193cbf74cfc7e82d162bfa4463683 (patch)
tree59465eaca332b89d5107686e4284eb86ab86a9d8
parentf7609f6a32305e3f6ad1625dcbedf6b77a7be5c9 (diff)
downloadaur-libvorbis-aotuv-lancer.tar.gz
Update to latest patch version (2021-05-10)
This fixes an error in Lancer decoding, as well as integrate the recent changes from Aoyumi's aoTuV (https://github.com/AO-Yumi/vorbis_aotuv). Ref: https://hydrogenaud.io/index.php?topic=115774.msg997396#msg997396 aotuv-lancer patches maintainer enzo1982 included Aoyumi's beta6.03-2020 release from 2021-03-21, which prompted some modifications packaging-wise; however he did so without changing the file names, so I had to get a bit creative to force a redownload of the patch files. We should really move to a -git package tracking enzo1982's repo.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 15 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5fbcc7f569b..7e1b019b26f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libvorbis-aotuv-lancer
pkgdesc = The Vorbis library with aoTuV and Lancer patches
pkgver = 1.3.7
- pkgrel = 2
+ pkgrel = 3
url = https://hydrogenaud.io/index.php?topic=115774.0
arch = i686
arch = x86_64
@@ -15,15 +15,13 @@ pkgbase = libvorbis-aotuv-lancer
conflicts = libvorbis-aotuv
source = https://downloads.xiph.org/releases/vorbis/libvorbis-1.3.7.tar.gz
source = https://downloads.xiph.org/releases/vorbis/libvorbis-1.3.7.tar.gz.asc
- source = https://freac.org/patches/libvorbis-1.3.7-aotuv-b6.03.patch
- source = https://freac.org/patches/libvorbis-1.3.7-aotuv-b6.03-lancer.patch
- source = make-check-fix.patch::https://gitlab.xiph.org/xiph/vorbis/-/commit/4e1155cc77a2c672f3dd18f9a32dbf1404693289.patch
+ source = libvorbis-1.3.7-aotuv-b6.03-2021-05-10.patch::https://freac.org/patches/libvorbis-1.3.7-aotuv-b6.03.patch
+ source = libvorbis-1.3.7-aotuv-b6.03-lancer-2021-05-10.patch::https://freac.org/patches/libvorbis-1.3.7-aotuv-b6.03-lancer.patch
validpgpkeys = B7B00AEE1F960EEA0FED66FB9259A8F2D2D44C84
sha1sums = 2b415495f89b103138a23da5017a2a00837c6c94
sha1sums = dc604e62a7e7ad60eb6fae0960cdf390a382258b
- sha1sums = ccb4725960467612c627961484065afd19c5f99e
- sha1sums = ce350ede3f6d11c09515d7e79fd8d1512d450e05
- sha1sums = ced440582403539d1b8904e003746ef75be36e1d
+ sha1sums = 98ab0c044b8e6aaf79d31861c6351b1f611f9fda
+ sha1sums = 0051b8c61bf74e68d4193cf9e2afbf02a01362e8
pkgname = libvorbis-aotuv-lancer
diff --git a/PKGBUILD b/PKGBUILD
index b33dc7a6f8b9..91116403349a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,9 @@
pkgname=libvorbis-aotuv-lancer
_srcname="${pkgname%-aotuv-lancer}"
pkgver=1.3.7
-pkgrel=2
+pkgrel=3
_aotuv_ver=aotuv-b6.03
+_patch_ver=2021-05-10
pkgdesc='The Vorbis library with aoTuV and Lancer patches'
arch=('i686' 'x86_64')
url='https://hydrogenaud.io/index.php?topic=115774.0'
@@ -23,27 +24,22 @@ provides=(
'libvorbisfile.so'
)
source=("https://downloads.xiph.org/releases/vorbis/${_srcname}-${pkgver}.tar.gz"{,.asc}
- "https://freac.org/patches/${_srcname}-${pkgver}-${_aotuv_ver}.patch"
- "https://freac.org/patches/${_srcname}-${pkgver}-${_aotuv_ver}-lancer.patch"
- "make-check-fix.patch::https://gitlab.xiph.org/xiph/vorbis/-/commit/4e1155cc77a2c672f3dd18f9a32dbf1404693289.patch")
+ "${_srcname}-${pkgver}-${_aotuv_ver}-${_patch_ver}.patch::https://freac.org/patches/${_srcname}-${pkgver}-${_aotuv_ver}.patch"
+ "${_srcname}-${pkgver}-${_aotuv_ver}-lancer-${_patch_ver}.patch::https://freac.org/patches/${_srcname}-${pkgver}-${_aotuv_ver}-lancer.patch")
validpgpkeys=(B7B00AEE1F960EEA0FED66FB9259A8F2D2D44C84) # Ralph Giles <giles@thaumas.net>
sha1sums=('2b415495f89b103138a23da5017a2a00837c6c94'
'dc604e62a7e7ad60eb6fae0960cdf390a382258b'
- 'ccb4725960467612c627961484065afd19c5f99e'
- 'ce350ede3f6d11c09515d7e79fd8d1512d450e05'
- 'ced440582403539d1b8904e003746ef75be36e1d')
+ '98ab0c044b8e6aaf79d31861c6351b1f611f9fda'
+ '0051b8c61bf74e68d4193cf9e2afbf02a01362e8')
prepare() {
cd "${_srcname}-${pkgver}"
# apply aotuv patch set
- patch -p1 -i "${srcdir}/${_srcname}-${pkgver}-${_aotuv_ver}.patch"
+ patch -p1 -i "${srcdir}/${_srcname}-${pkgver}-${_aotuv_ver}-${_patch_ver}.patch"
# apply lancer patch set
- patch -p1 -i "${srcdir}/${_srcname}-${pkgver}-${_aotuv_ver}-lancer.patch"
-
- # apply upstreamed patch to fix make check failure with lancer mod
- patch -p1 -i "${srcdir}/make-check-fix.patch"
+ patch -p1 -i "${srcdir}/${_srcname}-${pkgver}-${_aotuv_ver}-lancer-${_patch_ver}.patch"
}
build() {
@@ -63,10 +59,6 @@ check() {
package() {
cd "${_srcname}-${pkgver}"
make DESTDIR="$pkgdir" install
- # install original libvorbis specific files
- install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/${_srcname}"
- install -Dm644 AUTHORS CHANGES -t "${pkgdir}/usr/share/doc/${_srcname}-${pkgver}"
- # install libvorbis-aotuv-lancer specific files
- install -Dm644 aoTuV_README-1st.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 aoTuV_README-1st.txt aoTuV_technical.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/${pkgname}"
+ install -Dm644 AUTHORS CHANGES aoTuV_technical.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
}