summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-07 18:00:17 +0000
committerDaniel Bermond2018-05-07 18:00:17 +0000
commit51d6db57665ad368b8bf402fa0adb4857f11b766 (patch)
tree580cc96c20dee4c53a9ea546f30701cf2844084f
parentd1af728c47e5fe811904634a88109fae26372d89 (diff)
downloadaur-51d6db57665ad368b8bf402fa0adb4857f11b766.tar.gz
Cosmetic changes
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD14
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 113a5a39575b..cba7a36db696 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libvpx-full-git
pkgdesc = VP8 and VP9 video codecs (with all possible options, git version)
- pkgver = 1.7.0.r177.g2640f25072
+ pkgver = 1.7.0.r317.g28801f91c4
pkgrel = 1
url = http://www.webmproject.org/code/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index a2f21eeda674..c6a325bbcb06 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=libvpx-full-git
-pkgver=1.7.0.r177.g2640f25072
+pkgver=1.7.0.r317.g28801f91c4
pkgrel=1
pkgdesc='VP8 and VP9 video codecs (with all possible options, git version)'
arch=('i686' 'x86_64')
@@ -19,21 +19,15 @@ pkgver() {
cd "$pkgname"
# git, tags available
- printf "%s" "$(git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
cd "$pkgname"
# select target architecture
- if [ "$CARCH" = 'x86_64' ]
- then
- _target='--target=x86_64-linux-gcc'
-
- elif [ "$CARCH" = 'i686' ]
- then
- _target='--target=x86-linux-gcc'
- fi
+ [ "$CARCH" = 'x86_64' ] && _target='--target=x86_64-linux-gcc'
+ [ "$CARCH" = 'i686' ] && _target='--target=x86-linux-gcc'
./configure \
--prefix='/usr' \