summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-07 18:00:42 +0000
committerDaniel Bermond2018-05-07 18:00:42 +0000
commit4b2d8a22e7bfdccae703b035a9d26a0ca0282f47 (patch)
tree4352c29966b98bee81e11ab44f5658ad277af235
parent7a3a3ed8fe6672aa613cbf4bd2f2027bb7a2afb5 (diff)
downloadaur-4b2d8a22e7bfdccae703b035a9d26a0ca0282f47.tar.gz
Fix build. General improvements.
The '--enable-spatial-svc' configure option was removed by upstream. Removing it fixes the build process.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD65
2 files changed, 42 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f68851f94204..ef2b876a63d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libvpx-git
- pkgdesc = The VP8, VP9 & VP10 Codec SDK (git version)
- pkgver = v1.5.0.621.gbfc2a7e
+ pkgdesc = VP8 and VP9 video codecs (git version)
+ pkgver = 1.7.0.r317.g28801f91c4
pkgrel = 1
url = http://www.webmproject.org/
arch = i686
@@ -9,10 +9,12 @@ pkgbase = libvpx-git
makedepends = git
makedepends = yasm
depends = gcc-libs
- provides = libvpx=1.5.0
+ provides = libvpx
+ provides = libvpx.so
conflicts = libvpx
- source = git+https://chromium.googlesource.com/webm/libvpx
- md5sums = SKIP
+ conflicts = libvpx-full-git
+ source = libvpx-git::git+https://chromium.googlesource.com/webm/libvpx
+ sha256sums = SKIP
pkgname = libvpx-git
diff --git a/PKGBUILD b/PKGBUILD
index bcec27c45beb..7595070fb654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,55 @@
-# Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
-# Contributor: Det <gmail.com: nimetonmaili>
-# Contributor: h31 <yandex.com: h31mail>
-# Contributor: julroy67 <gmail.com: julroy67>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Jesse Jaara <gmail.com: jesse.jaara>
+# Contributor: Det <gmail.com: nimetonmaili>
+# Contributor: h31 <yandex.com: h31mail>
+# Contributor: julroy67 <gmail.com: julroy67>
pkgname=libvpx-git
-pkgver=v1.5.0.1276.gf44db14
+pkgver=1.7.0.r317.g28801f91c4
pkgrel=1
-pkgdesc="The VP8 and VP9 Codec SDK (git version)"
+pkgdesc='VP8 and VP9 video codecs (git version)'
arch=('i686' 'x86_64')
-url="http://www.webmproject.org/"
+url='http://www.webmproject.org/'
license=('BSD')
depends=('gcc-libs')
makedepends=('git' 'yasm')
-provides=('libvpx=1.5.0')
-conflicts=('libvpx')
-source=('git+https://chromium.googlesource.com/webm/libvpx')
-md5sums=('SKIP')
-_gitname='libvpx'
+provides=('libvpx' 'libvpx.so')
+conflicts=('libvpx' 'libvpx-full-git')
+source=("$pkgname"::'git+https://chromium.googlesource.com/webm/libvpx') # official repo
+#source=("$pkgname"::'git+https://github.com/webmproject/libvpx.git') # mirror
+sha256sums=('SKIP')
pkgver() {
- cd ${_gitname}
- git describe --always | sed 's|-|.|g'
+ cd "$pkgname"
+
+ # git, tags available
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
- cd "${srcdir}/${_gitname}"
-
- ./configure --prefix=/usr \
- --enable-vp8 \
- --enable-vp9 \
- --enable-vp9-highbitdepth \
+ cd "${pkgname}"
+
+ ./configure \
+ --prefix='/usr' \
--enable-runtime-cpu-detect \
--enable-shared \
- --enable-postproc \
--enable-pic \
- --enable-experimental \
- --enable-spatial-svc \
--disable-install-docs \
- --disable-install-srcs
-
- make
+ --disable-install-srcs \
+ --enable-vp8 \
+ --enable-postproc \
+ --enable-vp9 \
+ --enable-vp9-highbitdepth \
+ --enable-experimental
+
+ make
}
package() {
- cd "${srcdir}/${_gitname}/"
-
- make DIST_DIR="${pkgdir}/usr" install
- install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${pkgname}"
+
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 PATENTS "${pkgdir}/usr/share/licenses/${pkgname}/PATENTS"
}