summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaryl Chng2017-01-10 13:25:51 +0800
committerJaryl Chng2017-01-10 13:25:51 +0800
commita0175d4e87ca327682e395b5c87a9a3d23f7c37e (patch)
tree52fb603e1716886842ddf69b40e0e376ba0e3eac
downloadaur-a0175d4e87ca327682e395b5c87a9a3d23f7c37e.tar.gz
20161225.e22b93f
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7fa7e2f7d658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libvshadow-git
+ pkgdesc = Library to access the Volume Shadow Snapshot (VSS) format
+ pkgver = 20161225.e22b93f
+ pkgrel = 1
+ url = https://github.com/libyal/libvshadow
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ provides = libvshadow-git
+ conflicts = libvshadow
+ source = git+https://github.com/libyal/libvshadow.git
+ sha1sums = SKIP
+
+pkgname = libvshadow-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92f8ae6f3dc1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jaryl Chng <mrciku@gmail.com>
+pkgname=libvshadow-git
+pkgver=20161225.e22b93f
+pkgrel=1
+pkgdesc='Library to access the Volume Shadow Snapshot (VSS) format'
+arch=('i686' 'x86_64')
+url='https://github.com/libyal/libvshadow'
+license=('LGPL')
+provides=('libvshadow-git')
+conflicts=('libvshadow')
+groups=()
+depends=()
+makedepends=('git')
+optdepends=()
+options=()
+source=('git+https://github.com/libyal/libvshadow.git')
+sha1sums=('SKIP')
+
+_gitname="libvshadow"
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "$_gitname"
+
+ ./synclibs.sh
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc
+
+ make
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir/" install
+} \ No newline at end of file