summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-02-11 00:34:59 +0100
committerNarrat2020-02-11 00:34:59 +0100
commit4ec8c3948e835ccbae0b5d4a6c3fc0ed09c892b5 (patch)
tree7fa5515d573b111037b90b7f9733f6f30c1eec27
parentb977cd9e18af597633054d824f554db05efd7384 (diff)
downloadaur-libvterm-vwm.tar.gz
libvterm-vwm: update to 9.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--ncurses-import.patch12
3 files changed, 18 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e695c39499e..292155b51ce7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libvterm-vwm
pkgdesc = Terminal emulation library to mimic VT100 and rxvt capabilities
- pkgver = 9.0
+ pkgver = 9.3
pkgrel = 1
url = https://github.com/TragicWarrior/libvterm
arch = i686
@@ -9,10 +9,10 @@ pkgbase = libvterm-vwm
makedepends = cmake
makedepends = git
depends = ncurses
- source = git+https://github.com/TragicWarrior/libvterm.git#commit=65c8fc8ed27f361851b56e613fded1e837e54d62
+ source = git+https://github.com/TragicWarrior/libvterm.git#commit=55d7c847ba0fc7859708468da062a8493c3a9eff
source = ncurses-import.patch
sha256sums = SKIP
- sha256sums = 43977c763e4f4179d26f1702280bc67bfa3841b775827100c95cd9569b768c22
+ sha256sums = 90c511a2fa7822813294e215c756691f170c7083c7344135ac6b3ed780e5d4ce
pkgname = libvterm-vwm
diff --git a/PKGBUILD b/PKGBUILD
index 984e27bbd911..2b0209bce0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
_srcname=libvterm
pkgname=libvterm-vwm
-pkgver=9.0
+pkgver=9.3
pkgrel=1
-_commit=65c8fc8ed27f361851b56e613fded1e837e54d62
+_commit=55d7c847ba0fc7859708468da062a8493c3a9eff
pkgdesc="Terminal emulation library to mimic VT100 and rxvt capabilities"
arch=('i686' 'x86_64')
url="https://github.com/TragicWarrior/libvterm"
@@ -17,7 +17,7 @@ makedepends=('cmake' 'git')
source=("git+https://github.com/TragicWarrior/${_srcname}.git#commit=${_commit}"
"ncurses-import.patch")
sha256sums=('SKIP'
- '43977c763e4f4179d26f1702280bc67bfa3841b775827100c95cd9569b768c22')
+ '90c511a2fa7822813294e215c756691f170c7083c7344135ac6b3ed780e5d4ce')
prepare() {
diff --git a/ncurses-import.patch b/ncurses-import.patch
index 8ba3bca571a5..787183b305d6 100644
--- a/ncurses-import.patch
+++ b/ncurses-import.patch
@@ -69,3 +69,15 @@
#endif
#ifdef __FreeBSD__
+
+--- libvterm/nc_wrapper.c
++++ libvterm/nc_wrapper.c
+@@ -2,7 +2,7 @@
+ #include <dlfcn.h>
+
+ #ifdef __linux__
+-#include <ncursesw/curses.h>
++#include <curses.h>
+ #endif
+
+ #ifdef __FreeBSD__