summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Greenslade2016-04-27 14:18:31 -0400
committerSean Greenslade2016-04-27 14:18:31 -0400
commitb2194a5f85282bc75fc496e47c0104331be41a89 (patch)
treed8e0ada44efe675aa1987566662b79ca9e8dc826
downloadaur-b2194a5f85282bc75fc496e47c0104331be41a89.tar.gz
Initial package. Kind of messy, but it works.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD44
-rw-r--r--fix_path.patch16
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ee729f23612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libwebcam-git
+ pkgdesc = A library that is designed to simplify the development of webcam applications
+ pkgver = 20160427
+ pkgrel = 1
+ url = http://sourceforge.net/projects/libwebcam/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = linux-headers
+ depends = libxml2
+ source = fix_path.patch
+ sha512sums = bd2c86e5e32a20a85bb36cdcfb47737a6bbf6dfd2b44126de679d7cd241eefcdec8983a54236d0ee574c2439c3deafafba3d02695ce5d8128a6646d7c9395d6e
+
+pkgname = libwebcam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dfe6f0831a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: Trevor Jim
+# Maintainer: Sean Greenslade <aur AT seangreenslade DOT com>
+
+pkgname=libwebcam-git
+pkgver=20160427
+pkgrel=1
+pkgdesc="A library that is designed to simplify the development of webcam applications"
+arch=(i686 x86_64)
+url="http://sourceforge.net/projects/libwebcam/"
+license=('GPL')
+depends=('libxml2')
+makedepends=('cmake' 'linux-headers')
+source=('fix_path.patch')
+
+_gitroot="http://git.code.sf.net/p/libwebcam/code"
+_gitname="libwebcam"
+
+build() {
+ cd $srcdir
+ msg 'Connecting to GIT server...'
+ if [ -d $_gitname ] ; then
+ (cd $_gitname; git pull origin)
+ msg 'The local files are updated.'
+ else
+ git clone $_gitroot $_gitname
+ fi
+ msg "GIT checkout done or server timeout"
+
+ patch -p1 < fix_path.patch
+
+ msg "Starting make..."
+
+ rm -rf build
+ mkdir build
+ cd build
+ cmake ../$_gitname -DCMAKE_INSTALL_PREFIX=/usr -DUVCVIDEO_INCLUDE_PATH=../common/include/
+ make
+}
+
+package() {
+ cd $srcdir/build
+ make DESTDIR=$pkgdir install
+}
+sha512sums=('bd2c86e5e32a20a85bb36cdcfb47737a6bbf6dfd2b44126de679d7cd241eefcdec8983a54236d0ee574c2439c3deafafba3d02695ce5d8128a6646d7c9395d6e')
diff --git a/fix_path.patch b/fix_path.patch
new file mode 100644
index 000000000000..d88e25abdc90
--- /dev/null
+++ b/fix_path.patch
@@ -0,0 +1,16 @@
+--- a/libwebcam/uvcdynctrl/CMakeLists.txt 2016-04-27 13:52:51.432376590 -0400
++++ b/libwebcam/uvcdynctrl/CMakeLists.txt 2016-04-27 13:53:29.121677785 -0400
+@@ -102,11 +102,11 @@
+ # Note that having absolute paths here requires CPACK_SET_DESTDIR to be set to "ON".
+ install (
+ FILES udev/rules/80-uvcdynctrl.rules
+- DESTINATION /lib/udev/rules.d
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/udev/rules.d
+ )
+ install (
+ PROGRAMS udev/scripts/uvcdynctrl
+- DESTINATION /lib/udev
++ DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/udev
+ )
+ install (
+ DIRECTORY data