summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-03-11 12:41:04 +0100
committerFabioLolix2018-03-11 12:41:04 +0100
commit2ca65fc6d0dbe4720accf2d38846261c414e0f42 (patch)
treef561623a8ba152409b401e9ce5e110deb4eed3d4
parent92f56a0ffd80312bb5eae847fa508b72954e048c (diff)
downloadaur-2ca65fc6d0dbe4720accf2d38846261c414e0f42.tar.gz
removed patches, now builds
-rw-r--r--.SRCINFO10
-rw-r--r--0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch49
-rw-r--r--0002-add-libgl-to-LD-line.patch25
-rw-r--r--PKGBUILD39
4 files changed, 16 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5251be5c2af..31ed453c8d38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
pkgbase = libwebp-git
pkgdesc = WebP library and conversion tools
- pkgver = v0.4.1.530.g39216e5
+ pkgver = 0.6.1.r50.gb2db361ca
pkgrel = 1
url = https://developers.google.com/speed/webp/
arch = x86_64
arch = i686
license = BSD
+ makedepends = git
depends = libpng
depends = libjpeg
depends = libtiff
depends = giflib
provides = libwebp
conflicts = libwebp
- options = !libtool
- source = git+https://chromium.googlesource.com/webm/libwebp
- source = 0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
- source = 0002-add-libgl-to-LD-line.patch
+ source = libwebp-git::git+https://chromium.googlesource.com/webm/libwebp
sha256sums = SKIP
- sha256sums = 921596773f784832cf7c6fd5988b4272baa209cc959f658a894c9b1fdc5225df
- sha256sums = c5390acae9739f9c5c8a47677194c7f24d317bee6003d4fa1886f93fab1226ad
pkgname = libwebp-git
diff --git a/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch b/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
deleted file mode 100644
index 5281d5d7b0fa..000000000000
--- a/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 4a74e98ac6d8c5653f4667eae7185c51063a68ee Mon Sep 17 00:00:00 2001
-From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
-Date: Thu, 2 Jul 2015 17:11:13 +0200
-Subject: [PATCH 1/2] fix gcc 5.1 error, where c++14 string literals are
- detected
-
-http://sourceforge.net/p/freeimage/discussion/36110/thread/605ef8e4/
----
- src/dsp/upsampling_mips_dsp_r2.c | 6 +++---
- src/dsp/yuv_mips_dsp_r2.c | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/dsp/upsampling_mips_dsp_r2.c b/src/dsp/upsampling_mips_dsp_r2.c
-index 9c9665f..c587b1e 100644
---- a/src/dsp/upsampling_mips_dsp_r2.c
-+++ b/src/dsp/upsampling_mips_dsp_r2.c
-@@ -34,13 +34,13 @@
- G = G - t2 + kGCst; \
- B = B + kBCst; \
- __asm__ volatile ( \
-- "shll_s.w %["#R"], %["#R"], 9 \n\t" \
-+ "shll_s.w %[" #R "], %[" #R "], 9 \n\t" \
- "shll_s.w %["#G"], %["#G"], 9 \n\t" \
- "shll_s.w %["#B"], %["#B"], 9 \n\t" \
-- "precrqu_s.qb.ph %["#R"], %["#R"], $zero \n\t" \
-+ "precrqu_s.qb.ph %[" #R "], %[" #R "], $zero \n\t" \
- "precrqu_s.qb.ph %["#G"], %["#G"], $zero \n\t" \
- "precrqu_s.qb.ph %["#B"], %["#B"], $zero \n\t" \
-- "srl %["#R"], %["#R"], 24 \n\t" \
-+ "srl %[" #R "], %[" #R "], 24 \n\t" \
- "srl %["#G"], %["#G"], 24 \n\t" \
- "srl %["#B"], %["#B"], 24 \n\t" \
- : [R]"+r"(R), [G]"+r"(G), [B]"+r"(B) \
-diff --git a/src/dsp/yuv_mips_dsp_r2.c b/src/dsp/yuv_mips_dsp_r2.c
-index 43f02cc..3b9a907 100644
---- a/src/dsp/yuv_mips_dsp_r2.c
-+++ b/src/dsp/yuv_mips_dsp_r2.c
-@@ -54,7 +54,7 @@
- "srl %[temp5], %[temp5], 24 \n\t" \
- "srl %[temp6], %[temp6], 24 \n\t" \
- "srl %[temp7], %[temp7], 24 \n\t" \
-- "sb %[temp5], "#R"(%[dst]) \n\t" \
-+ "sb %[temp5], " #R "(%[dst]) \n\t" \
- "sb %[temp6], "#G"(%[dst]) \n\t" \
- "sb %[temp7], "#B"(%[dst]) \n\t" \
-
---
-2.4.5
-
diff --git a/0002-add-libgl-to-LD-line.patch b/0002-add-libgl-to-LD-line.patch
deleted file mode 100644
index ab26fbbed649..000000000000
--- a/0002-add-libgl-to-LD-line.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 1823535706a83ef47ab13530bb62c218fdffe380 Mon Sep 17 00:00:00 2001
-From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
-Date: Thu, 2 Jul 2015 17:11:43 +0200
-Subject: [PATCH 2/2] add libgl to LD line
-
----
- examples/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/examples/Makefile.am b/examples/Makefile.am
-index f79db61..e244af3 100644
---- a/examples/Makefile.am
-+++ b/examples/Makefile.am
-@@ -52,7 +52,7 @@ webpmux_LDADD = libexampleutil.la ../src/mux/libwebpmux.la ../src/libwebp.la
-
- vwebp_SOURCES = vwebp.c
- vwebp_CPPFLAGS = $(AM_CPPFLAGS) $(USE_EXPERIMENTAL_CODE) $(GL_INCLUDES)
--vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS)
-+vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS) -lGL
-
- if BUILD_LIBWEBPDECODER
- anim_diff_LDADD += ../src/libwebpdecoder.la
---
-2.4.5
-
diff --git a/PKGBUILD b/PKGBUILD
index 58f82c068b59..dbc04937a59b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,30 @@
-# $Id: PKGBUILD 184409 2013-05-06 19:38:39Z foutrelis $
-# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
-# Original Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Fabio Loli <loli_fabio@protonmail.com>
+# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
# Contributor: Jon Nordby <jononor@gmail.com>
pkgname=libwebp-git
-pkgver=v0.4.1.530.g39216e5
+pkgver=0.6.1.r50.gb2db361ca
pkgrel=1
pkgdesc="WebP library and conversion tools"
arch=(x86_64 i686)
url="https://developers.google.com/speed/webp/"
license=(BSD)
depends=(libpng libjpeg libtiff giflib)
-options=('!libtool')
+makedepends=('git')
conflicts=('libwebp')
provides=('libwebp')
-
-_gitname='libwebp'
-
-source=(
- "git+https://chromium.googlesource.com/webm/libwebp"
- "0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch"
- "0002-add-libgl-to-LD-line.patch"
-)
-
-sha256sums=(
- "SKIP"
- "921596773f784832cf7c6fd5988b4272baa209cc959f658a894c9b1fdc5225df"
- "c5390acae9739f9c5c8a47677194c7f24d317bee6003d4fa1886f93fab1226ad"
-)
+source=("${pkgname}::git+https://chromium.googlesource.com/webm/libwebp")
+sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- git describe --always | sed 's|-|.|g'
+ cd ${pkgname}
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $_gitname
-
- git am ../0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
- git am ../0002-add-libgl-to-LD-line.patch
+ cd ${pkgname}
./autogen.sh
./configure --prefix=/usr \
@@ -48,12 +33,14 @@ build() {
--enable-libwebpmux \
--enable-libwebpdemux \
--enable-libwebpdecoder \
+ --enable-libwebpextras \
--disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
make
}
package() {
- cd $_gitname
+ cd ${pkgname}
make DESTDIR="$pkgdir/" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"