summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:56:49 +0200
committerLubosz Sarnecki2015-06-22 22:56:49 +0200
commit62faa346d62da52e7c5b1f375092e9c955e869ff (patch)
treee2d68b009fe2f88a6dca90e6b242cb5ac5b531f2
downloadaur-62faa346d62da52e7c5b1f375092e9c955e869ff.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD49
-rw-r--r--gl.patch13
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28ce0024d5ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = libwebp-git
+ pkgdesc = WebP library and conversion tools
+ pkgver = v0.4.0.62.g9a463c4
+ pkgrel = 1
+ url = https://developers.google.com/speed/webp/
+ arch = x86_64
+ arch = i686
+ license = BSD
+ depends = libpng
+ depends = libjpeg
+ depends = libtiff
+ depends = giflib
+ provides = libwebp
+ conflicts = libwebp
+ options = !libtool
+ source = git+http://git.chromium.org/webm/libwebp.git
+ source = gl.patch
+ sha256sums = SKIP
+ sha256sums = 2a4771968cd01568487d9ef0427a495cded6b7fac8cc123e8f0d6ade25eab28d
+
+pkgname = libwebp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e92e469c263
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# $Id: PKGBUILD 184409 2013-05-06 19:38:39Z foutrelis $
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Original Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jon Nordby <jononor@gmail.com>
+
+pkgname=libwebp-git
+pkgver=v0.4.0.62.g9a463c4
+pkgrel=1
+pkgdesc="WebP library and conversion tools"
+arch=(x86_64 i686)
+url="https://developers.google.com/speed/webp/"
+license=(BSD)
+depends=(libpng libjpeg libtiff giflib)
+options=('!libtool')
+conflicts=('libwebp')
+provides=('libwebp')
+
+_gitname='libwebp'
+source=("git+http://git.chromium.org/webm/libwebp.git" "gl.patch")
+sha256sums=("SKIP" "2a4771968cd01568487d9ef0427a495cded6b7fac8cc123e8f0d6ade25eab28d")
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd $_gitname
+
+ patch -p1 < ../../gl.patch
+
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --enable-swap-16bit-csp \
+ --enable-experimental \
+ --enable-libwebpmux \
+ --enable-libwebpdemux \
+ --enable-libwebpdecoder \
+ --disable-static
+ make
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/gl.patch b/gl.patch
new file mode 100644
index 000000000000..b435f489d729
--- /dev/null
+++ b/gl.patch
@@ -0,0 +1,13 @@
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index 20e925a..93fbebb 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -41,7 +41,7 @@ webpmux_LDADD = libexampleutil.la ../src/mux/libwebpmux.la ../src/libwebp.la
+
+ vwebp_SOURCES = vwebp.c
+ vwebp_CPPFLAGS = $(AM_CPPFLAGS) $(USE_EXPERIMENTAL_CODE) $(GL_INCLUDES)
+-vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS)
++vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS) -lGL
+
+ if BUILD_LIBWEBPDECODER
+ dwebp_LDADD += ../src/libwebpdecoder.la