summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-07-02 17:15:24 +0200
committerLubosz Sarnecki2015-07-02 17:15:24 +0200
commit92f56a0ffd80312bb5eae847fa508b72954e048c (patch)
treefbcfcdb3e68a73af8842fa06e7a5702d9931b1a9
parent62faa346d62da52e7c5b1f375092e9c955e869ff (diff)
downloadaur-92f56a0ffd80312bb5eae847fa508b72954e048c.tar.gz
fix gcc 5.1 build. use git patches.
-rw-r--r--.SRCINFO10
-rw-r--r--0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch49
-rw-r--r--0002-add-libgl-to-LD-line.patch25
-rw-r--r--PKGBUILD19
-rw-r--r--gl.patch13
5 files changed, 95 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28ce0024d5ec..c5251be5c2af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libwebp-git
pkgdesc = WebP library and conversion tools
- pkgver = v0.4.0.62.g9a463c4
+ pkgver = v0.4.1.530.g39216e5
pkgrel = 1
url = https://developers.google.com/speed/webp/
arch = x86_64
@@ -13,10 +13,12 @@ pkgbase = libwebp-git
provides = libwebp
conflicts = libwebp
options = !libtool
- source = git+http://git.chromium.org/webm/libwebp.git
- source = gl.patch
+ source = git+https://chromium.googlesource.com/webm/libwebp
+ source = 0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
+ source = 0002-add-libgl-to-LD-line.patch
sha256sums = SKIP
- sha256sums = 2a4771968cd01568487d9ef0427a495cded6b7fac8cc123e8f0d6ade25eab28d
+ sha256sums = 921596773f784832cf7c6fd5988b4272baa209cc959f658a894c9b1fdc5225df
+ sha256sums = c5390acae9739f9c5c8a47677194c7f24d317bee6003d4fa1886f93fab1226ad
pkgname = libwebp-git
diff --git a/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch b/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
new file mode 100644
index 000000000000..5281d5d7b0fa
--- /dev/null
+++ b/0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
@@ -0,0 +1,49 @@
+From 4a74e98ac6d8c5653f4667eae7185c51063a68ee Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
+Date: Thu, 2 Jul 2015 17:11:13 +0200
+Subject: [PATCH 1/2] fix gcc 5.1 error, where c++14 string literals are
+ detected
+
+http://sourceforge.net/p/freeimage/discussion/36110/thread/605ef8e4/
+---
+ src/dsp/upsampling_mips_dsp_r2.c | 6 +++---
+ src/dsp/yuv_mips_dsp_r2.c | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/dsp/upsampling_mips_dsp_r2.c b/src/dsp/upsampling_mips_dsp_r2.c
+index 9c9665f..c587b1e 100644
+--- a/src/dsp/upsampling_mips_dsp_r2.c
++++ b/src/dsp/upsampling_mips_dsp_r2.c
+@@ -34,13 +34,13 @@
+ G = G - t2 + kGCst; \
+ B = B + kBCst; \
+ __asm__ volatile ( \
+- "shll_s.w %["#R"], %["#R"], 9 \n\t" \
++ "shll_s.w %[" #R "], %[" #R "], 9 \n\t" \
+ "shll_s.w %["#G"], %["#G"], 9 \n\t" \
+ "shll_s.w %["#B"], %["#B"], 9 \n\t" \
+- "precrqu_s.qb.ph %["#R"], %["#R"], $zero \n\t" \
++ "precrqu_s.qb.ph %[" #R "], %[" #R "], $zero \n\t" \
+ "precrqu_s.qb.ph %["#G"], %["#G"], $zero \n\t" \
+ "precrqu_s.qb.ph %["#B"], %["#B"], $zero \n\t" \
+- "srl %["#R"], %["#R"], 24 \n\t" \
++ "srl %[" #R "], %[" #R "], 24 \n\t" \
+ "srl %["#G"], %["#G"], 24 \n\t" \
+ "srl %["#B"], %["#B"], 24 \n\t" \
+ : [R]"+r"(R), [G]"+r"(G), [B]"+r"(B) \
+diff --git a/src/dsp/yuv_mips_dsp_r2.c b/src/dsp/yuv_mips_dsp_r2.c
+index 43f02cc..3b9a907 100644
+--- a/src/dsp/yuv_mips_dsp_r2.c
++++ b/src/dsp/yuv_mips_dsp_r2.c
+@@ -54,7 +54,7 @@
+ "srl %[temp5], %[temp5], 24 \n\t" \
+ "srl %[temp6], %[temp6], 24 \n\t" \
+ "srl %[temp7], %[temp7], 24 \n\t" \
+- "sb %[temp5], "#R"(%[dst]) \n\t" \
++ "sb %[temp5], " #R "(%[dst]) \n\t" \
+ "sb %[temp6], "#G"(%[dst]) \n\t" \
+ "sb %[temp7], "#B"(%[dst]) \n\t" \
+
+--
+2.4.5
+
diff --git a/0002-add-libgl-to-LD-line.patch b/0002-add-libgl-to-LD-line.patch
new file mode 100644
index 000000000000..ab26fbbed649
--- /dev/null
+++ b/0002-add-libgl-to-LD-line.patch
@@ -0,0 +1,25 @@
+From 1823535706a83ef47ab13530bb62c218fdffe380 Mon Sep 17 00:00:00 2001
+From: Lubosz Sarnecki <lubosz.sarnecki@collabora.co.uk>
+Date: Thu, 2 Jul 2015 17:11:43 +0200
+Subject: [PATCH 2/2] add libgl to LD line
+
+---
+ examples/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index f79db61..e244af3 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -52,7 +52,7 @@ webpmux_LDADD = libexampleutil.la ../src/mux/libwebpmux.la ../src/libwebp.la
+
+ vwebp_SOURCES = vwebp.c
+ vwebp_CPPFLAGS = $(AM_CPPFLAGS) $(USE_EXPERIMENTAL_CODE) $(GL_INCLUDES)
+-vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS)
++vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS) -lGL
+
+ if BUILD_LIBWEBPDECODER
+ anim_diff_LDADD += ../src/libwebpdecoder.la
+--
+2.4.5
+
diff --git a/PKGBUILD b/PKGBUILD
index 3e92e469c263..58f82c068b59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Jon Nordby <jononor@gmail.com>
pkgname=libwebp-git
-pkgver=v0.4.0.62.g9a463c4
+pkgver=v0.4.1.530.g39216e5
pkgrel=1
pkgdesc="WebP library and conversion tools"
arch=(x86_64 i686)
@@ -17,8 +17,18 @@ conflicts=('libwebp')
provides=('libwebp')
_gitname='libwebp'
-source=("git+http://git.chromium.org/webm/libwebp.git" "gl.patch")
-sha256sums=("SKIP" "2a4771968cd01568487d9ef0427a495cded6b7fac8cc123e8f0d6ade25eab28d")
+
+source=(
+ "git+https://chromium.googlesource.com/webm/libwebp"
+ "0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch"
+ "0002-add-libgl-to-LD-line.patch"
+)
+
+sha256sums=(
+ "SKIP"
+ "921596773f784832cf7c6fd5988b4272baa209cc959f658a894c9b1fdc5225df"
+ "c5390acae9739f9c5c8a47677194c7f24d317bee6003d4fa1886f93fab1226ad"
+)
pkgver() {
cd $_gitname
@@ -28,7 +38,8 @@ pkgver() {
build() {
cd $_gitname
- patch -p1 < ../../gl.patch
+ git am ../0001-fix-gcc-5.1-error-where-c-14-string-literals-are-det.patch
+ git am ../0002-add-libgl-to-LD-line.patch
./autogen.sh
./configure --prefix=/usr \
diff --git a/gl.patch b/gl.patch
deleted file mode 100644
index b435f489d729..000000000000
--- a/gl.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/examples/Makefile.am b/examples/Makefile.am
-index 20e925a..93fbebb 100644
---- a/examples/Makefile.am
-+++ b/examples/Makefile.am
-@@ -41,7 +41,7 @@ webpmux_LDADD = libexampleutil.la ../src/mux/libwebpmux.la ../src/libwebp.la
-
- vwebp_SOURCES = vwebp.c
- vwebp_CPPFLAGS = $(AM_CPPFLAGS) $(USE_EXPERIMENTAL_CODE) $(GL_INCLUDES)
--vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS)
-+vwebp_LDADD = libexampleutil.la ../src/demux/libwebpdemux.la $(GL_LIBS) -lGL
-
- if BUILD_LIBWEBPDECODER
- dwebp_LDADD += ../src/libwebpdecoder.la