summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-11-16 11:21:24 +0800
committerChocobo12020-11-16 11:28:31 +0800
commitb701dd3e6224865fe3d6c8d339d6f35ef204202f (patch)
tree866f88b88764b720628698bd2deb3628235d8c27
downloadaur-b701dd3e6224865fe3d6c8d339d6f35ef204202f.tar.gz
newpkg: libwebp2-git r6.g470e0b6-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb3a25457a31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libwebp2-git
+ pkgdesc = Successor of the WebP image format
+ pkgver = r6.g470e0b6
+ pkgrel = 1
+ url = https://chromium.googlesource.com/codecs/libwebp2/
+ arch = i686
+ arch = x86_64
+ license = apache
+ makedepends = git
+ makedepends = cmake
+ depends = gcc-libs
+ provides = libwebp2
+ conflicts = libwebp2
+ source = git+https://chromium.googlesource.com/codecs/libwebp2
+ sha256sums = SKIP
+
+pkgname = libwebp2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..899929f069f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libwebp2-git
+pkgver=r6.g470e0b6
+pkgrel=1
+pkgdesc="Successor of the WebP image format"
+arch=('i686' 'x86_64')
+url="https://chromium.googlesource.com/codecs/libwebp2/"
+license=('apache')
+depends=('gcc-libs')
+makedepends=('git' 'cmake')
+provides=('libwebp2')
+conflicts=('libwebp2')
+source=("git+https://chromium.googlesource.com/codecs/libwebp2")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libwebp2"
+
+ _rev=$(git rev-list --count --all)
+ _hash=$(git rev-parse --short HEAD)
+ printf "r%s.g%s" "$_rev" "$_hash"
+}
+
+build() {
+ cd "libwebp2"
+
+ cmake \
+ -B "_build" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_SHARED_LIBS=ON \
+ ./
+ make -C "_build"
+}
+
+check() {
+ cd "libwebp2"
+
+ #make -C "_build" test
+}
+
+package() {
+ cd "libwebp2"
+
+ make -C "_build" DESTDIR="$pkgdir" install
+}