summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Vainomaa2017-02-01 19:46:18 +0200
committerMark Vainomaa2017-02-01 19:46:18 +0200
commitcafb5ca6a69442a10ab90b84627422daa419d04e (patch)
tree03431e5bc7321615ecee6b26e611644a88852cf0
downloadaur-cafb5ca6a69442a10ab90b84627422daa419d04e.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a144652bd85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libwebsockets-libuv
+ pkgdesc = C library for websocket clients and servers
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://libwebsockets.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = openssl
+ depends = libuv
+ provides = libwebsockets
+ conflicts = libwebsockets
+ replaces = libwebsockets
+ source = https://github.com/warmcat/libwebsockets/archive/v2.1.0.tar.gz
+ md5sums = 4df3be57dee43aeebd54a3ed56568f50
+
+pkgname = libwebsockets-libuv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..313c46b45563
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+
+*.pkg.tar.xz*
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f8e3331b924
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Mark Vainomaa <mikroskeem@mikroskeem.eu>
+
+# This PKGBUILD is based off from libwebsockets package
+# Original package maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Original package contributor: Jingbei Li <i@jingbei.li>
+
+_lws=libwebsockets
+pkgname=${_lws}-libuv
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="C library for websocket clients and servers"
+arch=('i686' 'x86_64')
+url="https://libwebsockets.org"
+depends=('openssl' 'libuv')
+makedepends=('cmake')
+conflicts=('libwebsockets')
+provides=('libwebsockets')
+replaces=('libwebsockets')
+license=('LGPL')
+source=("https://github.com/warmcat/libwebsockets/archive/v$pkgver.tar.gz")
+md5sums=('4df3be57dee43aeebd54a3ed56568f50')
+
+build() {
+ cd "${_lws}-${pkgver}/"
+
+ mkdir build && cd build
+ cmake -D CMAKE_BUILD_TYPE=RelWithDebInfo -DCMAKE_INSTALL_PREFIX:PATH=/usr -DLWS_WITH_LIBUV=ON ..
+ make
+}
+
+package() {
+ cd "${_lws}-${pkgver}/build"
+ make DESTDIR="${pkgdir}" install
+
+ cd ..
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+}