summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaichi Shinozaki2016-02-11 10:56:11 +0000
committerDaichi Shinozaki2016-02-11 10:56:11 +0000
commit247f54165a44bf565c629304b9177ad97abd64fd (patch)
treefb5604278637d600ddf2b202b5eb6d0b716a6356
downloadaur-247f54165a44bf565c629304b9177ad97abd64fd.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c374dbedb80b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Thu Feb 11 10:55:36 UTC 2016
+pkgbase = libwebsockets15
+ pkgdesc = A lightweight pure C library built to use minimal CPU and memory resources, and provide fast throughput in both directions.
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://libwebsockets.org
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = LGPL
+ makedepends = cmake
+ depends = openssl
+ depends = make
+ source = https://github.com/warmcat/libwebsockets/archive/v1.5.1.tar.gz
+ md5sums = c66a7437e4d05f1f073630837a2142e9
+
+pkgname = libwebsockets15
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d306ded6f9f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jingbei Li <i@jingbei.li>
+
+pkgname=libwebsockets15
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="A lightweight pure C library built to use minimal CPU and memory resources, and provide fast throughput in both directions."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://libwebsockets.org"
+depends=('openssl' 'make')
+makedepends=('cmake')
+license=('LGPL')
+source=("https://github.com/warmcat/libwebsockets/archive/v$pkgver.tar.gz")
+md5sums=('c66a7437e4d05f1f073630837a2142e9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ rm -rf build
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/build"
+ make DESTDIR="${pkgdir}" install
+
+ cd ..
+ install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cd "$pkgdir/usr"
+}
+