summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 06:48:17 -0600
committerBrian Bidulock2015-06-10 06:48:17 -0600
commitf33979f4c7e6c41f6540091b669eee5ef058a583 (patch)
tree0283aa7979db75ecf69b25027886be0a7c5829d7
downloadaur-f33979f4c7e6c41f6540091b669eee5ef058a583.tar.gz
initial version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD36
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0b60ec71340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = libwnck+-git
+ pkgdesc = Window Navigator Construction Kit
+ pkgver = 2.31.0.r19.g7357429
+ pkgrel = 1
+ url = https://github.com/bbidulock/libwnck
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = libxt
+ makedepends = intltool
+ makedepends = gobject-introspection
+ makedepends = gnome-common
+ depends = gtk2
+ depends = startup-notification
+ depends = libxres
+ provides = libwnck=2.31.0
+ provides = libwnck+=2.31.0
+ conflicts = libwnck
+ conflicts = libwnck+
+ source = libwnck+-git::git+https://github.com/bbidulock/libwnck.git#branch=libwnck+
+ sha256sums = SKIP
+
+pkgname = libwnck+-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cda06b05380f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+pkgname=libwnck+-git
+pkgver=2.31.0.r19.g7357429
+pkgrel=1
+pkgdesc="Window Navigator Construction Kit"
+arch=('i686' 'x86_64')
+license=('LGPL')
+provides=('libwnck=2.31.0' 'libwnck+=2.31.0')
+conflicts=('libwnck' 'libwnck+')
+depends=('gtk2' 'startup-notification' 'libxres')
+makedepends=('git' 'libxt' 'intltool' 'gobject-introspection' 'gnome-common')
+url="https://github.com/bbidulock/libwnck"
+source=("$pkgname::git+https://github.com/bbidulock/libwnck.git#branch=libwnck+")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's,LIBWNCK_,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+build() {
+ cd $pkgname
+ ./autogen.sh --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static \
+ --enable-tools --enable-gtk-doc
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" install
+ # libwnck3 installs these with the normal names linked against wrong library
+ mv "${pkgdir}"/usr/bin/wnckprop "${pkgdir}"/usr/bin/wnckprop2
+ mv "${pkgdir}"/usr/bin/wnck-urgency-monitor "${pkgdir}"/usr/bin/wnck-urgency-monitor2
+}