summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkokkiemouse2020-10-18 14:45:18 +0900
committerkokkiemouse2020-10-18 14:45:18 +0900
commite72c4011de343262fe2668275cdd4bd5e82553b0 (patch)
tree80f6fb614bd9469e1ffa2b77e5c2fc17ba4fcb92
downloadaur-e72c4011de343262fe2668275cdd4bd5e82553b0.tar.gz
1st
Signed-off-by: kokkiemouse <kokkiemouse@gmail.com>
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d62dc7df8f05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libworld
+ pkgdesc = NEUTRINO WORLD Library
+ pkgver = 1.0.0
+ pkgrel = 0
+ arch = any
+ makedepends = cmake
+ makedepends = ninja
+ depends = clang
+ source = git+https://github.com/kokkiemouse/World.git
+ md5sums = SKIP
+
+pkgname = libworld
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5de3b0d6c5fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+pkgname=libworld
+pkgdesc="NEUTRINO WORLD Library"
+pkgver=1.0.0
+arch=(any)
+pkgrel=0
+depends=(clang)
+makedepends=(cmake ninja)
+source=("git+https://github.com/kokkiemouse/World.git")
+md5sums=(SKIP)
+package() {
+ cd "$srcdir/World/"
+ cd build
+ cmake .. -GNinja -DCMAKE_C_COMPILER=clang -DCMAKE_CXX_COMPILER=clang++ -DCMAKE_INSTALL_PREFIX="$pkgdir/usr"
+ ninja install
+}