summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2018-08-23 02:22:38 +0300
committerAdrian Perez de Castro2018-08-23 02:23:00 +0300
commit68d892458488edeb844f1250ce4cad7334688f33 (patch)
tree6900cb7e974c76027e78191a4d477c7f0b7ac76e
downloadaur-68d892458488edeb844f1250ce4cad7334688f33.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b9ba4c4c4ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libwpe-git
+ pkgdesc = General-purpose library specifically developed for the WPE-flavored port of WebKit.
+ pkgver = 1.0.0.r0.g4be4c7d
+ pkgrel = 1
+ url = https://github.com/WebPlatformForEmbedded/libwpe
+ arch = x86_64
+ arch = i686
+ groups = wpe
+ license = custom:BSD
+ makedepends = cmake
+ makedepends = opengl-driver
+ depends = gcc-libs
+ provides = libwpe
+ conflicts = libwpe
+ replaces = wpebackend-git
+ source = libwpe-git::git+https://github.com/WebPlatformForEmbedded/libwpe
+ sha256sums = SKIP
+
+pkgname = libwpe-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..44418f112573
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/libwpe-git/
+/*.tar
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6610bc03ec34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+pkgdesc='General-purpose library specifically developed for the WPE-flavored port of WebKit.'
+pkgname=libwpe-git
+pkgver=1.0.0.r0.g4be4c7d
+pkgrel=1
+url=https://github.com/WebPlatformForEmbedded/libwpe
+arch=(x86_64 i686)
+groups=(wpe)
+makedepends=(cmake opengl-driver)
+provides=(libwpe)
+conflicts=(libwpe)
+replaces=(wpebackend-git)
+depends=(gcc-libs)
+license=(custom:BSD)
+source=("${pkgname}::git+${url}")
+sha256sums=(SKIP)
+
+pkgver () {
+ cd "${pkgname}"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare () {
+ mkdir -p _build
+}
+
+build () {
+ cd _build
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ "../${pkgname}"
+ cmake --build .
+}
+
+package () {
+ DESTDIR="${pkgdir}" cmake --build _build --target install
+ install -Dm644 "${pkgname}/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}