summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2014-05-23 20:13:40 +0800
committerFantix King2015-12-30 12:49:56 +0800
commit0eedb7a5754585b331e31a2b2dff77a0dc62e9b4 (patch)
tree94795a4b6d8fffb118e6de617ad99d4a988e8a7a
parent5781991dccd637972d4e438a6f2a180483b47306 (diff)
downloadaur-0eedb7a5754585b331e31a2b2dff77a0dc62e9b4.tar.gz
2.5.39-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--flex-2.5.38-no-bison.patch (renamed from flex-2.5.37-no-bison.patch)104
-rw-r--r--lex.sh3
4 files changed, 82 insertions, 65 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ededc0294a6f..750716768fb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Dec 30 04:44:37 UTC 2015
+# Wed Dec 30 04:49:46 UTC 2015
pkgbase = libx32-flex
pkgdesc = A tool for generating text-scanning programs
- pkgver = 2.5.37
- pkgrel = 0.1
+ pkgver = 2.5.39
+ pkgrel = 1
url = http://flex.sourceforge.net
arch = x86_64
groups = base-devel
@@ -13,10 +13,14 @@ pkgbase = libx32-flex
depends = m4
depends = sh
depends = flex
- source = http://downloads.sourceforge.net/sourceforge/flex/flex-2.5.37.tar.bz2
- source = flex-2.5.37-no-bison.patch
- md5sums = c75940e1fc25108f2a7b3ef42abdae06
- md5sums = bd54cf8a1896da4efda41d6e27282ce7
+ options = libtool
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/flex/flex-2.5.39.tar.bz2
+ source = flex-2.5.38-no-bison.patch
+ source = lex.sh
+ sha256sums = add2b55f3bc38cb512b48fad7d72f43b11ef244487ff25fc00aabec1e32b617f
+ sha256sums = 5ee23f97533c991b82e2aadc06d4682d7d05d99ee2abaf1ef9a82225ba9d0858
+ sha256sums = 9d03016a7c4ae1adb051f50f94407b3d7dee9d55924b5c1904261c9f0c1f86f6
pkgname = libx32-flex
diff --git a/PKGBUILD b/PKGBUILD
index 6e0754b6214c..d66ea5839a04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
# Upstream Maintainer: Bill Fraser <wfraser@codewise.org>
+# Contributor: Felipe Contreras <felipe.contreras@gmail.com>
+# Contributor: jtts
#
# From flex's PKGBUILD:
# Maintainer: Allan McRae <allan@archlinux.org>
@@ -8,19 +10,22 @@
_pkgbasename=flex
pkgname=libx32-flex
-pkgver=2.5.37
-pkgrel=0.1
+pkgver=2.5.39
+pkgrel=1
pkgdesc="A tool for generating text-scanning programs"
arch=('x86_64')
url="http://flex.sourceforge.net"
license=('custom')
groups=('base-devel')
depends=('libx32-glibc' 'm4' 'sh' $_pkgbasename)
+options=(libtool staticlibs)
makedepends=('gcc-multilib-x32')
source=(http://downloads.sourceforge.net/sourceforge/flex/flex-$pkgver.tar.bz2
- flex-2.5.37-no-bison.patch)
-md5sums=('c75940e1fc25108f2a7b3ef42abdae06'
- 'bd54cf8a1896da4efda41d6e27282ce7')
+ flex-2.5.38-no-bison.patch
+ lex.sh)
+sha256sums=('add2b55f3bc38cb512b48fad7d72f43b11ef244487ff25fc00aabec1e32b617f'
+ '5ee23f97533c991b82e2aadc06d4682d7d05d99ee2abaf1ef9a82225ba9d0858'
+ '9d03016a7c4ae1adb051f50f94407b3d7dee9d55924b5c1904261c9f0c1f86f6')
build() {
export CC="gcc -mx32"
@@ -30,7 +35,12 @@ build() {
cd $srcdir/$_pkgbasename-$pkgver
- patch -Np1 -i $srcdir/flex-2.5.37-no-bison.patch
+# These are no longer needed!
+# patch -Np1 -i $srcdir/flex-2.5.35-gcc44.patch
+# patch -Np1 -i $srcdir/flex-2.5.35-hardening.patch
+# patch -Np1 -i $srcdir/flex-2.5.35-missing-prototypes.patch
+
+ patch -Np1 -i $srcdir/flex-2.5.38-no-bison.patch
./configure --prefix=/usr --libdir=/usr/libx32 \
--mandir=/usr/share/man --infodir=/usr/share/info
diff --git a/flex-2.5.37-no-bison.patch b/flex-2.5.38-no-bison.patch
index df527817bf8b..dc2ef4f305c6 100644
--- a/flex-2.5.37-no-bison.patch
+++ b/flex-2.5.38-no-bison.patch
@@ -1,52 +1,52 @@
---- flex-2.5.37/tests/Makefile.am 2012-10-11 04:49:17.517445461 +0300
-+++ flex-2.5.37/tests/Makefile.am 2012-10-11 04:49:58.504048817 +0300
-@@ -35,9 +35,6 @@
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
-- test-bison-yylloc \
-- test-bison-yylval \
-- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \
-@@ -84,9 +81,6 @@
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
-- test-bison-yylloc \
-- test-bison-yylval \
-- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \
---- flex-2.5.37/tests/Makefile.in 2012-10-11 04:49:35.665941427 +0300
-+++ flex-2.5.37/tests/Makefile.in 2012-10-11 04:50:21.048847253 +0300
-@@ -120,7 +120,6 @@
- AUTOHEADER = @AUTOHEADER@
- AUTOMAKE = @AUTOMAKE@
- AWK = @AWK@
--BISON = @BISON@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
- CFLAGS = @CFLAGS@
-@@ -251,9 +250,6 @@
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
-- test-bison-yylloc \
-- test-bison-yylval \
-- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \
-@@ -300,9 +296,6 @@
- test-rescan-nr \
- test-basic-nr \
- test-basic-r \
-- test-bison-yylloc \
-- test-bison-yylval \
-- test-bison-nr \
- test-multiple-scanners-nr \
- test-multiple-scanners-r \
- test-header-nr \ \ No newline at end of file
+--- flex-2.5.37/tests/Makefile.am 2012-10-11 04:49:17.517445461 +0300
++++ flex-2.5.37/tests/Makefile.am 2012-10-11 04:49:58.504048817 +0300
+@@ -35,9 +35,6 @@
+ test-rescan-nr \
+ test-basic-nr \
+ test-basic-r \
+- test-bison-yylloc \
+- test-bison-yylval \
+- test-bison-nr \
+ test-multiple-scanners-nr \
+ test-multiple-scanners-r \
+ test-header-nr \
+@@ -84,9 +81,6 @@
+ test-rescan-nr \
+ test-basic-nr \
+ test-basic-r \
+- test-bison-yylloc \
+- test-bison-yylval \
+- test-bison-nr \
+ test-multiple-scanners-nr \
+ test-multiple-scanners-r \
+ test-header-nr \
+--- flex-2.5.37/tests/Makefile.in 2012-10-11 04:49:35.665941427 +0300
++++ flex-2.5.37/tests/Makefile.in 2012-10-11 04:50:21.048847253 +0300
+@@ -120,7 +120,6 @@
+ AUTOHEADER = @AUTOHEADER@
+ AUTOMAKE = @AUTOMAKE@
+ AWK = @AWK@
+-BISON = @BISON@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+@@ -251,9 +250,6 @@
+ test-rescan-nr \
+ test-basic-nr \
+ test-basic-r \
+- test-bison-yylloc \
+- test-bison-yylval \
+- test-bison-nr \
+ test-multiple-scanners-nr \
+ test-multiple-scanners-r \
+ test-header-nr \
+@@ -300,9 +296,6 @@
+ test-rescan-nr \
+ test-basic-nr \
+ test-basic-r \
+- test-bison-yylloc \
+- test-bison-yylval \
+- test-bison-nr \
+ test-multiple-scanners-nr \
+ test-multiple-scanners-r \
+ test-header-nr \
diff --git a/lex.sh b/lex.sh
new file mode 100644
index 000000000000..13e7de69282e
--- /dev/null
+++ b/lex.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/bin/flex -l "$@"