summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2014-07-29 14:25:39 +0800
committerFantix King2015-11-18 11:24:03 +0800
commit4f5c5fa5bf10165ab954b64bdae6c075c830b8e7 (patch)
tree7c25f78ba8a592811a89417988b88121430e5d72
parent40ee76757dac35db6a16bdc14d660a9e83a83b24 (diff)
downloadaur-libx32-fontconfig.tar.gz
2.11.1-1.1
-rw-r--r--.SRCINFO11
-rw-r--r--30-urw-aliases.patch13
-rw-r--r--PKGBUILD54
-rw-r--r--libx32-fontconfig.install11
4 files changed, 48 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eb29f014be0..8c399ab6cf68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = libx32-fontconfig
pkgdesc = A library for configuring and customizing font access (x32 ABI)
- pkgver = 2.10.1
+ pkgver = 2.11.1
pkgrel = 1.1
url = http://www.fontconfig.org/release/
+ install = libx32-fontconfig.install
arch = x86_64
license = custom
makedepends = gcc-multilib-x32
- depends = libx32-expat>=2.0.1
- depends = libx32-freetype2>=2.3.11
+ depends = libx32-expat
+ depends = libx32-freetype2
depends = fontconfig
options = !libtool
- source = http://www.fontconfig.org/release/fontconfig-2.10.1.tar.gz
- md5sums = c94e380eea42f2f23ca9537035ef1899
+ source = http://www.fontconfig.org/release/fontconfig-2.11.1.tar.bz2
+ sha256sums = dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99
pkgname = libx32-fontconfig
diff --git a/30-urw-aliases.patch b/30-urw-aliases.patch
deleted file mode 100644
index 8077b869e81c..000000000000
--- a/30-urw-aliases.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/conf.d/30-urw-aliases.conf 2009-08-06 16:23:57.000000000 +0100
-+++ b/conf.d/30-urw-aliases.conf 2009-08-06 16:25:07.000000000 +0100
-@@ -29,6 +29,10 @@
- <family>Zapf Dingbats</family>
- <accept><family>Dingbats</family></accept>
- </alias>
-+ <alias binding="same">
-+ <family>ZapfDingbats</family>
-+ <accept><family>Dingbats</family></accept>
-+ </alias>
- <match target="pattern">
- <test name="family">
- <string>Symbol</string>
diff --git a/PKGBUILD b/PKGBUILD
index b77fb281ad6b..41569a634bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,62 @@
-# $Id: PKGBUILD 78820 2012-10-25 06:47:28Z foutrelis $
-# Upstream Maintainer: Jan de Groot <jgc@archlinux.org>
-# Maintainer: Fantix King <fantix.king at gmail.com>
+# $Id: PKGBUILD 109875 2014-04-20 20:49:15Z bluewind $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# x32 Maintainer: Fantix King <fantix.king at gmail.com>
+
_pkgbasename=fontconfig
pkgname=libx32-$_pkgbasename
-pkgver=2.10.1
+pkgver=2.11.1
pkgrel=1.1
pkgdesc="A library for configuring and customizing font access (x32 ABI)"
arch=(x86_64)
url="http://www.fontconfig.org/release/"
license=('custom')
-depends=('libx32-expat>=2.0.1' 'libx32-freetype2>=2.3.11' $_pkgbasename)
+depends=('libx32-expat' 'libx32-freetype2' $_pkgbasename)
makedepends=(gcc-multilib-x32)
options=('!libtool')
-source=(http://www.fontconfig.org/release/${_pkgbasename}-${pkgver}.tar.gz)
-md5sums=('c94e380eea42f2f23ca9537035ef1899')
+install=libx32-fontconfig.install
+source=(http://www.fontconfig.org/release/${_pkgbasename}-${pkgver}.tar.bz2)
+sha256sums=('dc62447533bca844463a3c3fd4083b57c90f18a70506e7a9f4936b5a1e516a99')
+
+ # a nice page to test font matching:
+ # http://zipcon.net/~swhite/docs/computers/browsers/fonttest.html
build() {
+ cd $_pkgbasename-$pkgver
+
export CC="gcc -mx32"
export CXX="g++ -mx32"
export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
- cd "${srcdir}/${_pkgbasename}-${pkgver}"
# make sure there's no rpath trouble and sane .so versioning - FC and Gentoo do this as well
libtoolize -f
- autoreconf -f
+ autoreconf -fi
./configure --prefix=/usr \
- --sysconfdir=/etc \
- --with-templatedir=/etc/fonts/conf.avail \
- --with-xmldir=/etc/fonts \
- --localstatedir=/var \
- --disable-static \
- --with-default-fonts=/usr/share/fonts \
- --with-add-fonts=/usr/share/fonts \
- --libdir=/usr/libx32
-
+ --sysconfdir=/etc \
+ --with-templatedir=/etc/fonts/conf.avail \
+ --with-xmldir=/etc/fonts \
+ --localstatedir=/var \
+ --disable-static \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/share/fonts \
+ --libdir=/usr/libx32
make
}
check() {
- cd "$srcdir/$_pkgbasename-$pkgver"
- make -k check
+ cd $_pkgbasename-$pkgver
+ make -k check
}
package() {
- cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ cd $_pkgbasename-$pkgver
+ make DESTDIR="$pkgdir" install
- make DESTDIR="${pkgdir}" install
+ rm -rf "$pkgdir"/{etc,usr/{include,share}}
+ find "$pkgdir/usr/bin" -not -type d -not -name fc-cache -delete
+ mv "$pkgdir"/usr/bin/fc-cache{,-x32}
- rm -rf "${pkgdir}"/usr/{include,share,bin} "$pkgdir"/{etc,var}
+ # Install license
mkdir -p "$pkgdir/usr/share/licenses"
ln -s $_pkgbasename "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/libx32-fontconfig.install b/libx32-fontconfig.install
new file mode 100644
index 000000000000..b6979f6d3344
--- /dev/null
+++ b/libx32-fontconfig.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo -n "updating font cache... "
+ /usr/bin/fc-cache-x32 -f
+ echo "done."
+}
+
+post_upgrade() {
+ echo -n "updating font cache... "
+ /usr/bin/fc-cache-x32 -f
+ echo "done."
+}