summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-02-28 11:35:13 +0800
committerFantix King2015-11-17 12:41:07 +0800
commit1eb243a2e58393e0deec165ccd95b9797be27518 (patch)
treec350ebacec2f3966e5417d76744cca9b39a9895c
parent44e17568b94d1fbc850e34e1d70afcf7f1f299ec (diff)
downloadaur-1eb243a2e58393e0deec165ccd95b9797be27518.tar.gz
2.42.1-1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rwxr-xr-xrevert-warn-glib-compile-schemas.patch33
3 files changed, 58 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1007727f52f..084b417f3802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = libx32-glib2
pkgdesc = Common C routines used by GTK+ 2.4 and other libs (x32 ABI)
- pkgver = 2.40.0
- pkgrel = 1
+ pkgver = 2.42.1
+ pkgrel = 1.1
url = http://www.gtk.org/
arch = x86_64
license = LGPL
makedepends = gcc-multilib-x32
makedepends = python2
+ depends = libx32-dbus
+ depends = libx32-libffi
depends = libx32-pcre
depends = libx32-zlib
- depends = libx32-libdbus
- depends = libx32-libffi
depends = glib2
- options = !libtool
options = !docs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.40/glib-2.40.0.tar.xz
- sha256sums = 0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.42/glib-2.42.1.tar.xz
+ source = revert-warn-glib-compile-schemas.patch
+ sha256sums = 8f3f0865280e45b8ce840e176ef83bcfd511148918cc8d39df2ee89b67dcf89a
+ sha256sums = 049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97
pkgname = libx32-glib2
diff --git a/PKGBUILD b/PKGBUILD
index 0119c74968ba..62d4aa474854 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 109537 2014-04-15 14:55:45Z bluewind $
+# $Id: PKGBUILD 122984 2014-11-23 10:25:53Z bluewind $
# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
@@ -6,17 +6,24 @@
_pkgbasename=glib2
pkgname=libx32-$_pkgbasename
-pkgver=2.40.0
-pkgrel=1
+pkgver=2.42.1
+pkgrel=1.1
pkgdesc="Common C routines used by GTK+ 2.4 and other libs (x32 ABI)"
url="http://www.gtk.org/"
arch=('x86_64')
license=('LGPL')
-depends=('libx32-pcre' 'libx32-zlib' 'libx32-libdbus' libx32-libffi $_pkgbasename)
-makedepends=('gcc-multilib-x32' python2)
-options=('!libtool' '!docs')
-source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz)
-sha256sums=('0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5')
+depends=('libx32-dbus' 'libx32-libffi' 'libx32-pcre' 'libx32-zlib' "$_pkgbasename")
+makedepends=('gcc-multilib-x32' 'python2')
+options=('!docs')
+source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz"
+ 'revert-warn-glib-compile-schemas.patch')
+sha256sums=('8f3f0865280e45b8ce840e176ef83bcfd511148918cc8d39df2ee89b67dcf89a'
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
+
+prepare() {
+ cd "${srcdir}/glib-${pkgver}"
+ patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
+}
build() {
export CC="gcc -mx32"
@@ -24,9 +31,8 @@ build() {
export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
cd "${srcdir}/glib-${pkgver}"
-
- PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/libx32 \
- --enable-static --enable-shared --with-pcre=system --disable-fam
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc \
+ --libdir=/usr/libx32 --with-pcre=system --disable-fam
make
}
diff --git a/revert-warn-glib-compile-schemas.patch b/revert-warn-glib-compile-schemas.patch
new file mode 100755
index 000000000000..75b05103cd02
--- /dev/null
+++ b/revert-warn-glib-compile-schemas.patch
@@ -0,0 +1,33 @@
+From 6560b37450cd19c4a7c7b690e279fe97b7bfdcaa Mon Sep 17 00:00:00 2001
+From: Ryan Lortie <desrt@desrt.ca>
+Date: Thu, 12 Apr 2012 23:55:34 +0000
+Subject: glib-compile-schemas: warn about bad dconf paths
+
+For quite some time the recommended usage of GSettings and dconf has
+been to use paths like /org/gnome/example/. Use of /apps/ has spilled
+over from GConf and is continuing to make its way into a number of
+applications as they port.
+
+glib-compile-schemas will now warn about these types of paths being
+used. This generates a lot of noise, but hopefully it will reduce the
+number of ported applications making this mistake.
+---
+diff --git a/gio/glib-compile-schemas.c b/gio/glib-compile-schemas.c
+index cf02389..27d0181 100644
+--- a/gio/glib-compile-schemas.c
++++ b/gio/glib-compile-schemas.c
+@@ -1204,6 +1204,12 @@ parse_state_start_schema (ParseState *state,
+ return;
+ }
+
++ if (path && (g_str_has_prefix (path, "/apps/") ||
++ g_str_has_prefix (path, "/desktop/") ||
++ g_str_has_prefix (path, "/system/")))
++ g_printerr ("warning: Schema '%s' has path '%s'. Paths starting with "
++ "'/apps/', '/desktop/' or '/system/' are deprecated.\n", id, path);
++
+ state->schema_state = schema_state_new (path, gettext_domain,
+ extends, extends_name, list_of);
+
+--
+cgit v0.9.0.2