summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2014-07-29 13:57:59 +0800
committerFantix King2015-11-17 12:40:04 +0800
commit44e17568b94d1fbc850e34e1d70afcf7f1f299ec (patch)
tree7029422fe5da657d578f8c102b88f2a6c4ff8212
parentb3f1cf0d2fd8977f77f820462d7068f10a084692 (diff)
downloadaur-44e17568b94d1fbc850e34e1d70afcf7f1f299ec.tar.gz
2.40.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
-rw-r--r--glib-2.0_fix_for_x32.patch76
3 files changed, 18 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8e9068cdd8d..c1007727f52f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = libx32-glib2
pkgdesc = Common C routines used by GTK+ 2.4 and other libs (x32 ABI)
- pkgver = 2.34.1
- pkgrel = 1.1
+ pkgver = 2.40.0
+ pkgrel = 1
url = http://www.gtk.org/
arch = x86_64
license = LGPL
makedepends = gcc-multilib-x32
- makedepends = binx32-python2
+ makedepends = python2
depends = libx32-pcre
depends = libx32-zlib
- depends = libx32-dbus-core
+ depends = libx32-libdbus
depends = libx32-libffi
depends = glib2
options = !libtool
options = !docs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.34/glib-2.34.1.tar.xz
- source = glib-2.0_fix_for_x32.patch
- sha256sums = 6e84dc9d84b104725b34d255421ed7ac3629e49f437d37addde5ce3891c2e2f1
- sha256sums = a2018bad1f010c036fd6959d514046b5d6315f07aa6a2154f5e591e89ab48ea0
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.40/glib-2.40.0.tar.xz
+ sha256sums = 0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5
pkgname = libx32-glib2
diff --git a/PKGBUILD b/PKGBUILD
index 3673e73c271b..0119c74968ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
-# $Id: PKGBUILD 79203 2012-10-31 14:37:00Z bluewind $
-# Upstream Maintainer: Ionut Biru <ibiru@archlinux.org>
+# $Id: PKGBUILD 109537 2014-04-15 14:55:45Z bluewind $
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
-# Maintainer: Fantix King <fantix.king at gmail.com>
+# x32 Maintainer: Fantix King <fantix.king at gmail.com>
_pkgbasename=glib2
pkgname=libx32-$_pkgbasename
-pkgver=2.34.1
-pkgrel=1.1
+pkgver=2.40.0
+pkgrel=1
pkgdesc="Common C routines used by GTK+ 2.4 and other libs (x32 ABI)"
url="http://www.gtk.org/"
arch=('x86_64')
license=('LGPL')
-depends=('libx32-pcre' 'libx32-zlib' 'libx32-dbus-core' libx32-libffi $_pkgbasename)
-makedepends=('gcc-multilib-x32' binx32-python2)
+depends=('libx32-pcre' 'libx32-zlib' 'libx32-libdbus' libx32-libffi $_pkgbasename)
+makedepends=('gcc-multilib-x32' python2)
options=('!libtool' '!docs')
-source=(
-http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz
-glib-2.0_fix_for_x32.patch
-)
-sha256sums=(
-'6e84dc9d84b104725b34d255421ed7ac3629e49f437d37addde5ce3891c2e2f1'
-'a2018bad1f010c036fd6959d514046b5d6315f07aa6a2154f5e591e89ab48ea0'
-)
+source=(http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz)
+sha256sums=('0d27f195966ecb1995dcce0754129fd66ebe820c7cd29200d264b02af1aa28b5')
build() {
export CC="gcc -mx32"
@@ -31,9 +25,7 @@ build() {
cd "${srcdir}/glib-${pkgver}"
- patch -p1 -i "${srcdir}/glib-2.0_fix_for_x32.patch"
-
- PYTHON=/usr/bin/python2.7-x32 ./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/libx32 \
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/libx32 \
--enable-static --enable-shared --with-pcre=system --disable-fam
make
}
@@ -46,5 +38,6 @@ package() {
cd "${pkgdir}"/usr/bin
mv gio-querymodules gio-querymodules-x32
rm -f gdbus glib* gobject-query gsettings gtester*
- rm -rf "$pkgdir"/usr/{bin,libx32/gdbus-2.0}
+ rm -rf "$pkgdir"/usr/libx32/gdbus-2.0
+ find "$pkgdir/usr/bin" -type f -not -name gio-querymodules-x32 -delete
}
diff --git a/glib-2.0_fix_for_x32.patch b/glib-2.0_fix_for_x32.patch
deleted file mode 100644
index 70cbbbe915d6..000000000000
--- a/glib-2.0_fix_for_x32.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-UpstreamStatus: Pending
-
-Pass CC & CFLAGS vars so that tune parameters get used.
-This fixes compilation with x32 toolchain.
-
-Received this patch from H.J. Lu <hjl.tools@gmail.com>
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/07/13
-
-Index: glib-2.30.0/glib/Makefile.am
-===================================================================
---- glib-2.30.0.orig/glib/Makefile.am
-+++ glib-2.30.0/glib/Makefile.am
-@@ -359,10 +359,10 @@ INSTALL_PROGS=
-
- if ENABLE_DTRACE
- glib_probes.h: glib_probes.d Makefile
-- $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
- @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- glib_probes.o: glib_probes.d Makefile
-- $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
- BUILT_SOURCES += glib_probes.h glib_probes.o
- CLEANFILES += glib_probes.h glib_probes.h.tmp
- libglib_2_0_la_LIBADD += glib_probes.o
-Index: glib-2.30.0/glib/Makefile.in
-===================================================================
---- glib-2.30.0.orig/glib/Makefile.in
-+++ glib-2.30.0/glib/Makefile.in
-@@ -1691,10 +1691,10 @@ uninstall-local: uninstall-ms-lib uninst
- @OS_WIN32_AND_DLL_COMPILATION_FALSE@uninstall-def-file:
-
- @ENABLE_DTRACE_TRUE@glib_probes.h: glib_probes.d Makefile
--@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CC="$(CC)" CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
- @ENABLE_DTRACE_TRUE@ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- @ENABLE_DTRACE_TRUE@glib_probes.o: glib_probes.d Makefile
--@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CC="$(CC)" CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
-
- gspawn-win32-helper-console.c:
- echo '#define HELPER_CONSOLE' >$@
-Index: glib-2.30.0/gobject/Makefile.am
-===================================================================
---- glib-2.30.0.orig/gobject/Makefile.am
-+++ glib-2.30.0/gobject/Makefile.am
-@@ -141,10 +141,10 @@ gobject_c_sources = \
-
- if ENABLE_DTRACE
- gobject_probes.h: gobject_probes.d Makefile
-- $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
- @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- gobject_probes.o: gobject_probes.d Makefile
-- $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
- BUILT_SOURCES += gobject_probes.h gobject_probes.o
- CLEANFILES += gobject_probes.h
- libgobject_2_0_la_LIBADD += gobject_probes.o
-Index: glib-2.30.0/gobject/Makefile.in
-===================================================================
---- glib-2.30.0.orig/gobject/Makefile.in
-+++ glib-2.30.0/gobject/Makefile.in
-@@ -1581,10 +1581,10 @@ uninstall-ms-lib:
- @OS_WIN32_AND_DLL_COMPILATION_FALSE@uninstall-def-file:
-
- @ENABLE_DTRACE_TRUE@gobject_probes.h: gobject_probes.d Makefile
--@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -C -h -s $< -o $@.tmp
-+@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -C -h -s $< -o $@.tmp
- @ENABLE_DTRACE_TRUE@ @$(SED) -e "s,define STAP_HAS_SEMAPHORES 1,undef STAP_HAS_SEMAPHORES," < $@.tmp > $@ && rm -f $@.tmp
- @ENABLE_DTRACE_TRUE@gobject_probes.o: gobject_probes.d Makefile
--@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) $(DTRACE) -G -s $< -o $@
-+@ENABLE_DTRACE_TRUE@ $(AM_V_GEN) CFLAGS="$(CFLAGS)" $(DTRACE) -G -s $< -o $@
-
- # This is read by gobject-introspection/misc/ and gtk-doc
- gobject-public-headers.txt: Makefile