summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2012-11-02 07:22:13 +0000
committerFantix King2015-11-17 12:38:58 +0800
commitb3f1cf0d2fd8977f77f820462d7068f10a084692 (patch)
treeac966ae4a47e768e17e904cbc85ad67bf7725251
parent4f317892514c14aa7c6157e081219bbcb2bcabca (diff)
downloadaur-b3f1cf0d2fd8977f77f820462d7068f10a084692.tar.gz
2.34.1-1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f478548b60f..f8e9068cdd8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = libx32-glib2
pkgdesc = Common C routines used by GTK+ 2.4 and other libs (x32 ABI)
- pkgver = 2.32.4
+ pkgver = 2.34.1
pkgrel = 1.1
url = http://www.gtk.org/
arch = x86_64
license = LGPL
makedepends = gcc-multilib-x32
- makedepends = python2-x32
+ makedepends = binx32-python2
depends = libx32-pcre
depends = libx32-zlib
depends = libx32-dbus-core
@@ -14,9 +14,9 @@ pkgbase = libx32-glib2
depends = glib2
options = !libtool
options = !docs
- source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-2.32.4.tar.xz
+ source = http://ftp.gnome.org/pub/GNOME/sources/glib/2.34/glib-2.34.1.tar.xz
source = glib-2.0_fix_for_x32.patch
- sha256sums = a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b167fae2
+ sha256sums = 6e84dc9d84b104725b34d255421ed7ac3629e49f437d37addde5ce3891c2e2f1
sha256sums = a2018bad1f010c036fd6959d514046b5d6315f07aa6a2154f5e591e89ab48ea0
pkgname = libx32-glib2
diff --git a/PKGBUILD b/PKGBUILD
index 48c7c12a8cbb..3673e73c271b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 78820 2012-10-25 06:47:28Z foutrelis $
+# $Id: PKGBUILD 79203 2012-10-31 14:37:00Z bluewind $
# Upstream Maintainer: Ionut Biru <ibiru@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
# Contributor: Mikko Seppälä <t-r-a-y@mbnet.fi>
@@ -6,21 +6,21 @@
_pkgbasename=glib2
pkgname=libx32-$_pkgbasename
-pkgver=2.32.4
+pkgver=2.34.1
pkgrel=1.1
pkgdesc="Common C routines used by GTK+ 2.4 and other libs (x32 ABI)"
url="http://www.gtk.org/"
arch=('x86_64')
license=('LGPL')
depends=('libx32-pcre' 'libx32-zlib' 'libx32-dbus-core' libx32-libffi $_pkgbasename)
-makedepends=('gcc-multilib-x32' python2-x32)
+makedepends=('gcc-multilib-x32' binx32-python2)
options=('!libtool' '!docs')
source=(
-http://ftp.gnome.org/pub/GNOME/sources/glib/2.32/glib-${pkgver}.tar.xz
+http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-${pkgver}.tar.xz
glib-2.0_fix_for_x32.patch
)
sha256sums=(
-'a5d742a4fda22fb6975a8c0cfcd2499dd1c809b8afd4ef709bda4d11b167fae2'
+'6e84dc9d84b104725b34d255421ed7ac3629e49f437d37addde5ce3891c2e2f1'
'a2018bad1f010c036fd6959d514046b5d6315f07aa6a2154f5e591e89ab48ea0'
)
@@ -33,7 +33,7 @@ build() {
patch -p1 -i "${srcdir}/glib-2.0_fix_for_x32.patch"
- PYTHON=/opt/python2-x32/bin/python2.7 ./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/libx32 \
+ PYTHON=/usr/bin/python2.7-x32 ./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/libx32 \
--enable-static --enable-shared --with-pcre=system --disable-fam
make
}