summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-02-26 18:16:40 +0800
committerFantix King2015-11-13 01:19:13 +0800
commit4c5937009c6a4dea7f735631854e8bd4ac174746 (patch)
treea8f2ea063724e6a0e86dca1991a9f25bd10573a1
parentbb1197bb84e4471a1715562adef8c82376051cb5 (diff)
downloadaur-4c5937009c6a4dea7f735631854e8bd4ac174746.tar.gz
2.21-2.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--glibc-2.21-roundup.patch70
3 files changed, 80 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79af3ff72de1..4ba8c267300d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libx32-glibc
pkgdesc = GNU C Library (x32 ABI)
pkgver = 2.21
- pkgrel = 1.1
+ pkgrel = 2.1
url = http://www.gnu.org/software/libc
arch = x86_64
license = GPL
@@ -14,9 +14,11 @@ pkgbase = libx32-glibc
options = !emptydirs
source = http://ftp.gnu.org/gnu/libc/glibc-2.21.tar.xz
source = http://ftp.gnu.org/gnu/libc/glibc-2.21.tar.xz.sig
+ source = glibc-2.21-roundup.patch
source = libx32-glibc.conf
md5sums = 9cb398828e8f84f57d1f7d5588cf40cd
md5sums = SKIP
+ md5sums = bf9d96b11c76b113606aae102da63d9d
md5sums = 34a4169d2bdc5a3eb83676a0831aae57
pkgname = libx32-glibc
diff --git a/PKGBUILD b/PKGBUILD
index 838a01ea3e3d..fb4d9349454a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 127242 2015-02-07 13:22:34Z heftig $
+# $Id: PKGBUILD 127583 2015-02-12 00:16:48Z heftig $
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
@@ -9,7 +9,7 @@
_pkgbasename=glibc
pkgname=libx32-$_pkgbasename
pkgver=2.21
-pkgrel=1.1
+pkgrel=2.1
pkgdesc="GNU C Library (x32 ABI)"
arch=('x86_64')
url="http://www.gnu.org/software/libc"
@@ -25,16 +25,19 @@ provides=('glibc-x32-seed')
options=('!strip' 'staticlibs' '!emptydirs')
source=(http://ftp.gnu.org/gnu/libc/${_pkgbasename}-${pkgver}.tar.xz{,.sig}
+ glibc-2.21-roundup.patch
libx32-glibc.conf)
md5sums=('9cb398828e8f84f57d1f7d5588cf40cd'
'SKIP'
+ 'bf9d96b11c76b113606aae102da63d9d'
'34a4169d2bdc5a3eb83676a0831aae57')
+validpgpkeys=('F37CDAB708E65EA183FD1AF625EF0A436C2A4AFF') # Carlos O'Donell
prepare() {
cd ${srcdir}/glibc-${pkgver}
- # glibc-2.21..
- #patch -p1 -i $srcdir/glibc-2.21-roundup.patch
+ # glibc-2.21..75adf430
+ patch -p1 -i $srcdir/glibc-2.21-roundup.patch
mkdir ${srcdir}/glibc-build
}
diff --git a/glibc-2.21-roundup.patch b/glibc-2.21-roundup.patch
new file mode 100644
index 000000000000..66d3454ee9c0
--- /dev/null
+++ b/glibc-2.21-roundup.patch
@@ -0,0 +1,70 @@
+diff --git a/ChangeLog b/ChangeLog
+index dc1ed1b..45579de 100644
+--- a/ChangeLog
++++ b/ChangeLog
+@@ -1,3 +1,9 @@
++2015-02-10 Evangelos Foutras <evangelos@foutrelis.com>
++
++ [BZ #17949]
++ * sysdeps/i386/i686/multiarch/mempcpy_chk.S: Fix position of
++ jump label.
++
+ 2015-02-06 Carlos O'Donell <carlos@systemhalted.org>
+
+ * version.h (RELEASE): Set to "stable".
+@@ -7,6 +13,7 @@
+ * sysdeps/unix/sysv/linux/hppa/pthread.h: Sync with pthread.h.
+
+ 2015-02-05 Paul Pluzhnikov <ppluzhnikov@google.com>
++ Paul Eggert <eggert@cs.ucla.edu>
+
+ [BZ #16618]
+ * stdio-common/tst-sscanf.c (main): Test for buffer overflow.
+diff --git a/NEWS b/NEWS
+index 617cdbb..ff79f0d 100644
+--- a/NEWS
++++ b/NEWS
+@@ -5,6 +5,12 @@ See the end for copying conditions.
+ Please send GNU C library bug reports via <http://sourceware.org/bugzilla/>
+ using `glibc' in the "product" field.
+
++Version 2.21.1
++
++* The following bugs are resolved with this release:
++
++ 17949.
++
+ Version 2.21
+
+ * The following bugs are resolved with this release:
+@@ -21,10 +27,11 @@ Version 2.21
+ 17801, 17803, 17806, 17834, 17844, 17848, 17868, 17869, 17870, 17885,
+ 17892.
+
+-* CVE-2015-1472 Under certain conditions wscanf can allocate too little
+- memory for the to-be-scanned arguments and overflow the allocated
+- buffer. The implementation now correctly computes the required buffer
+- size when using malloc.
++* CVE-2015-1472 CVE-2015-1473 Under certain conditions wscanf can allocate
++ too little memory for the to-be-scanned arguments and overflow the
++ allocated buffer. The implementation now correctly computes the required
++ buffer size when using malloc, and switches to malloc from alloca as
++ intended.
+
+ * A new semaphore algorithm has been implemented in generic C code for all
+ machines. Previous custom assembly implementations of semaphore were
+diff --git a/sysdeps/i386/i686/multiarch/mempcpy_chk.S b/sysdeps/i386/i686/multiarch/mempcpy_chk.S
+index 207b648..b6fa202 100644
+--- a/sysdeps/i386/i686/multiarch/mempcpy_chk.S
++++ b/sysdeps/i386/i686/multiarch/mempcpy_chk.S
+@@ -36,8 +36,8 @@ ENTRY(__mempcpy_chk)
+ cmpl $0, KIND_OFFSET+__cpu_features@GOTOFF(%ebx)
+ jne 1f
+ call __init_cpu_features
+- leal __mempcpy_chk_ia32@GOTOFF(%ebx), %eax
+-1: testl $bit_SSE2, CPUID_OFFSET+index_SSE2+__cpu_features@GOTOFF(%ebx)
++1: leal __mempcpy_chk_ia32@GOTOFF(%ebx), %eax
++ testl $bit_SSE2, CPUID_OFFSET+index_SSE2+__cpu_features@GOTOFF(%ebx)
+ jz 2f
+ leal __mempcpy_chk_sse2_unaligned@GOTOFF(%ebx), %eax
+ testl $bit_Fast_Unaligned_Load, FEATURE_OFFSET+index_Fast_Unaligned_Load+__cpu_features@GOTOFF(%ebx)