summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-02-28 12:12:19 +0800
committerFantix King2015-11-08 12:05:52 +0800
commit4236b6404fa556f5cd9802a19f8c543f6bad1334 (patch)
treee1fe326ab1284fced9ba1f41652391d783c595c0
parent756fea3297a034ea901ef0b701b45eb8eca118c4 (diff)
downloadaur-4236b6404fa556f5cd9802a19f8c543f6bad1334.tar.gz
54.1-1.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--changeset_32780.diff67
3 files changed, 7 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9801546bc4a5..9d03fcff15f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = libx32-icu
pkgdesc = International Components for Unicode library (x32 ABI)
- pkgver = 53.1
- pkgrel = 1
+ pkgver = 54.1
+ pkgrel = 1.1
url = http://www.icu-project.org/
arch = x86_64
license = custom:icu
makedepends = gcc-multilib-x32
depends = libx32-gcc-libs
depends = icu
- source = http://download.icu-project.org/files/icu4c/53.1/icu4c-53_1-src.tgz
+ source = http://download.icu-project.org/files/icu4c/54.1/icu4c-54_1-src.tgz
source = icu.8198.revert.icu5431.patch
- md5sums = b73baa6fbdfef197608d1f69300919b9
+ md5sums = e844caed8f2ca24c088505b0d6271bc0
md5sums = 2e0fb97c7a64ea43c29c6142c22da35a
pkgname = libx32-icu
diff --git a/PKGBUILD b/PKGBUILD
index a2399e38118d..d738615d6c41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# x32 Maintainer: Fantix King <fantix.king at gmail.com>
pkgname=libx32-icu
-pkgver=53.1
-pkgrel=1
+pkgver=54.1
+pkgrel=1.1
pkgdesc="International Components for Unicode library (x32 ABI)"
arch=('x86_64')
url="http://www.icu-project.org/"
@@ -12,7 +12,7 @@ depends=('libx32-gcc-libs' 'icu')
makedepends=('gcc-multilib-x32')
source=(http://download.icu-project.org/files/icu4c/${pkgver}/icu4c-${pkgver//./_}-src.tgz
'icu.8198.revert.icu5431.patch')
-md5sums=('b73baa6fbdfef197608d1f69300919b9'
+md5sums=('e844caed8f2ca24c088505b0d6271bc0'
'2e0fb97c7a64ea43c29c6142c22da35a')
build() {
diff --git a/changeset_32780.diff b/changeset_32780.diff
deleted file mode 100644
index a77d64c63ff6..000000000000
--- a/changeset_32780.diff
+++ /dev/null
@@ -1,67 +0,0 @@
-Index: /icu/trunk/source/test/intltest/strtest.cpp
-===================================================================
---- /icu/trunk/source/test/intltest/strtest.cpp (revision 32779)
-+++ /icu/trunk/source/test/intltest/strtest.cpp (revision 32780)
-@@ -1,5 +1,5 @@
- /********************************************************************
- * COPYRIGHT:
-- * Copyright (c) 1997-2011, International Business Machines Corporation and
-+ * Copyright (c) 1997-2012, International Business Machines Corporation and
- * others. All Rights Reserved.
- ********************************************************************/
-@@ -95,5 +95,5 @@
- StringTest::Test_U_STRING() {
- U_STRING_INIT(ustringVar, "aZ0 -", 5);
-- if( sizeof(ustringVar)/sizeof(*ustringVar)!=6 ||
-+ if( u_strlen(ustringVar)!=5 ||
- ustringVar[0]!=0x61 ||
- ustringVar[1]!=0x5a ||
-Index: /icu/trunk/source/common/unicode/ustring.h
-===================================================================
---- /icu/trunk/source/common/unicode/ustring.h (revision 32779)
-+++ /icu/trunk/source/common/unicode/ustring.h (revision 32780)
-@@ -940,5 +940,5 @@
- */
- #if defined(U_DECLARE_UTF16)
--# define U_STRING_DECL(var, cs, length) static const UChar var[(length)+1]=U_DECLARE_UTF16(cs)
-+# define U_STRING_DECL(var, cs, length) static const UChar *var=(const UChar *)U_DECLARE_UTF16(cs)
- /**@stable ICU 2.0 */
- # define U_STRING_INIT(var, cs, length)
-Index: /icu/trunk/source/common/unicode/platform.h
-===================================================================
---- /icu/trunk/source/common/unicode/platform.h (revision 32779)
-+++ /icu/trunk/source/common/unicode/platform.h (revision 32780)
-@@ -665,7 +665,7 @@
- * gcc 4.4 defines the __CHAR16_TYPE__ macro to a usable type but
- * does not support u"abc" string literals.
-- * C++11 requires support for UTF-16 literals
-+ * C++11 and C11 require support for UTF-16 literals
- */
--# if (defined(__cplusplus) && __cplusplus >= 201103L)
-+# if (defined(__cplusplus) && __cplusplus >= 201103L) || (defined(__STDC_VERSION__) && __STDC_VERSION__ >= 201112L)
- # define U_HAVE_CHAR16_T 1
- # else
-Index: /icu/trunk/source/common/unicode/umachine.h
-===================================================================
---- /icu/trunk/source/common/unicode/umachine.h (revision 32779)
-+++ /icu/trunk/source/common/unicode/umachine.h (revision 32780)
-@@ -257,5 +257,5 @@
- /**
- * \var UChar
-- * Define UChar to be char16_t, if available,
-+ * Define UChar to be UCHAR_TYPE, if that is #defined (for example, to char16_t),
- * or wchar_t if that is 16 bits wide; always assumed to be unsigned.
- * If neither is available, then define UChar to be uint16_t.
-@@ -267,8 +267,8 @@
- * @stable ICU 4.4
- */
--
--/* Define UChar to be compatible with char16_t or wchar_t if possible. */
--#if U_HAVE_CHAR16_T
-- typedef char16_t UChar;
-+#if defined(UCHAR_TYPE)
-+ typedef UCHAR_TYPE UChar;
-+/* Not #elif U_HAVE_CHAR16_T -- because that is type-incompatible with pre-C++11 callers
-+ typedef char16_t UChar; */
- #elif U_SIZEOF_WCHAR_T==2
- typedef wchar_t UChar;