summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-07-09 10:21:18 +0200
committerFantix King2015-12-30 02:37:44 +0800
commitca087e81b00eadd9904609b367b5b9f2491ac5b1 (patch)
tree5c8bdc128e6bbe918672df977cca63aa513fb05c
downloadaur-ca087e81b00eadd9904609b367b5b9f2491ac5b1.tar.gz
2.7-1.1
-rw-r--r--.SRCINFO16
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD41
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0131392b79de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Dec 29 18:36:29 UTC 2015
+pkgbase = libx32-jansson
+ pkgdesc = C library for encoding, decoding and manipulating JSON data (x32 ABI)
+ pkgver = 2.7
+ pkgrel = 1.1
+ url = http://www.digip.org/jansson/
+ arch = x86_64
+ license = MIT
+ depends = jansson
+ depends = libx32-glibc
+ source = http://www.digip.org/jansson/releases/jansson-2.7.tar.bz2
+ sha256sums = 459f2b7cf22fb676286723f26169a17cf111fbfb6f54e3dc2ec6b6f9f4a97bdc
+
+pkgname = libx32-jansson
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..79b5a44bdbba
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=('libx32-jansson')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..641cff64f633
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Jakub Schmidtke <sjakub-at-gmail-dot-com>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+# Contributor: Dave Reisner <d@falconindy.com>
+# x32 Maintainer: Fantix King <fantix.king at gmail.com>
+
+pkgname=libx32-jansson
+pkgver=2.7
+pkgrel=1.1
+pkgdesc='C library for encoding, decoding and manipulating JSON data (x32 ABI)'
+arch=('x86_64')
+url='http://www.digip.org/jansson/'
+depends=('jansson' 'libx32-glibc')
+license=('MIT')
+source=("http://www.digip.org/jansson/releases/jansson-${pkgver}.tar.bz2")
+sha256sums=('459f2b7cf22fb676286723f26169a17cf111fbfb6f54e3dc2ec6b6f9f4a97bdc')
+
+build() {
+ cd jansson-${pkgver}
+
+ export CC='gcc -mx32'
+ export CXX='g++ -mx32'
+ export PKG_CONFIG_PATH='/usr/libx32/pkgconfig'
+
+ ./configure \
+ --prefix='/usr' \
+ --libdir='/usr/libx32'
+ make
+}
+
+package() {
+ cd jansson-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+ rm -rf "${pkgdir}"/usr/{share,include}
+
+ install -dm 755 "${pkgdir}"/usr/share/licenses
+ ln -s jansson "${pkgdir}"/usr/share/licenses/libx32-jansson
+}
+
+# vim:set ts=2 sw=2 et: