summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2012-09-22 17:18:48 +0800
committerFantix King2015-11-17 01:27:35 +0800
commit5426ac47eef041e28e7f0d0aa8679e385f51e6a9 (patch)
tree1bd02f75dfa55e6b2753c11bd66b36d878ca68b7
downloadaur-5426ac47eef041e28e7f0d0aa8679e385f51e6a9.tar.gz
1.6.4-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dca9e0f065a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libx32-dbus-core
+ pkgdesc = Freedesktop.org message bus system (x32 ABI)
+ pkgver = 1.6.4
+ pkgrel = 1.1
+ url = http://www.freedesktop.org/Software/dbus
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = gcc-multilib-x32
+ makedepends = libx32-libx11
+ depends = libx32-glibc
+ depends = libx32-expat
+ depends = dbus-core
+ options = !libtool
+ source = http://dbus.freedesktop.org/releases/dbus/dbus-1.6.4.tar.gz
+ md5sums = 5ec43dc4554cba638917317b2b4f7640
+
+pkgname = libx32-dbus-core
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccdfcba7cc83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# $Id: PKGBUILD 74440 2012-07-28 15:05:46Z bluewind $
+# Maintainer : Ionut Biru <ibiru@archlinux.org>
+
+pkgname=libx32-dbus-core
+_pkgbasename=dbus-core
+pkgver=1.6.4
+pkgrel=1.1
+pkgdesc="Freedesktop.org message bus system (x32 ABI)"
+arch=('x86_64')
+url="http://www.freedesktop.org/Software/dbus"
+license=('GPL' 'custom')
+depends=('libx32-glibc' 'libx32-expat' 'dbus-core')
+makedepends=('gcc-multilib-x32' libx32-libx11)
+options=(!libtool)
+source=(http://dbus.freedesktop.org/releases/dbus/dbus-${pkgver}.tar.gz)
+md5sums=('5ec43dc4554cba638917317b2b4f7640')
+
+build() {
+ export CC="gcc -mx32"
+ export CXX="g++ -mx32"
+ export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
+
+ cd "${srcdir}/dbus-${pkgver}"
+
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --libdir=/usr/libx32 \
+ --libexecdir=/usr/lib/dbus-1.0 --with-dbus-user=81 \
+ --with-system-pid-file=/var/run/dbus.pid \
+ --enable-inotify --disable-dnotify \
+ --disable-verbose-mode --disable-static \
+ --disable-tests --disable-asserts --disable-systemd \
+ --with-console-auth-dir=/run/console/
+
+ make
+}
+
+package() {
+ cd "${srcdir}/dbus-${pkgver}"
+ make DESTDIR=${pkgdir} install
+
+ rm -rf "${pkgdir}"/usr/{bin,include,lib,share}
+ rm -rf "${pkgdir}"/{etc,var}
+
+ mkdir -p "${pkgdir}/usr/share/licenses"
+ ln -s ${_pkgbasename} "${pkgdir}/usr/share/licenses/${pkgname}"
+}