summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-11-08 10:46:58 +0800
committerFantix King2015-11-15 19:29:12 +0800
commitf567893243ba107c217aa2b3292c837d1e84639a (patch)
tree9c279eb1bc7456e0f3c6857ca1eb5ca3060efe05
downloadaur-f567893243ba107c217aa2b3292c837d1e84639a.tar.gz
2.4.1-1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD36
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c78417848d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libx32-mpdecimal
+ pkgdesc = Package for correctly-rounded arbitrary precision decimal floating point arithmetic (x32 ABI)
+ pkgver = 2.4.1
+ pkgrel = 1.1
+ url = http://www.bytereef.org/mpdecimal/index.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libx32-glibc
+ depends = mpdecimal
+ source = http://www.bytereef.org/software/mpdecimal/releases/mpdecimal-2.4.1.tar.gz
+ sha512sums = 60073ec82faff1ef9a5955a98f7f1320b044ff03bf8589bfe139b4721ae44c943e16bb36e1e61d9c6016529ba460d879bcbb17ea17cd875b27caa7caea211d45
+
+pkgname = libx32-mpdecimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a269da63217
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 221617 2014-09-13 11:13:02Z fyan $
+# Maintainer: Felix Yan <felixonmars@gmail.com>
+# x32 Maintainer: Fantix King <fantix.king@gmail.com>
+
+_basepkgname=mpdecimal
+pkgname=libx32-$_basepkgname
+pkgver=2.4.1
+pkgrel=1.1
+pkgdesc="Package for correctly-rounded arbitrary precision decimal floating point arithmetic (x32 ABI)"
+arch=('i686' 'x86_64')
+url="http://www.bytereef.org/mpdecimal/index.html"
+license=('custom')
+depends=('libx32-glibc' $_basepkgname)
+source=(http://www.bytereef.org/software/${_basepkgname}/releases/${_basepkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${_basepkgname}-${pkgver}
+
+ export CC="gcc -mx32"
+ export CXX="g++ -mx32"
+ export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
+
+ ./configure --prefix=/usr --libdir=/usr/libx32
+ make
+}
+
+package() {
+ cd ${_basepkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+
+ rm -rf "${pkgdir}"/usr/{include,share}
+ mkdir -p "$pkgdir/usr/share/licenses"
+ ln -s $_basepkgname "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+sha512sums=('60073ec82faff1ef9a5955a98f7f1320b044ff03bf8589bfe139b4721ae44c943e16bb36e1e61d9c6016529ba460d879bcbb17ea17cd875b27caa7caea211d45')