summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-02-28 14:04:39 +0800
committerFantix King2015-11-07 16:09:07 +0800
commit7ce73ce66d81ec3d4d9edbbaedf24de20a789e3a (patch)
treed3c083be8725fbb7a0d965e72623aad856c406bb
parent50cb8d2156a482aff1dea1c2fd0e7fbe04bb8c02 (diff)
downloadaur-7ce73ce66d81ec3d4d9edbbaedf24de20a789e3a.tar.gz
1.0.2-1.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--openssl-1.0.1-x32.patch79
3 files changed, 10 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2259f4d62cc5..98065eb3cfab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libx32-openssl
pkgdesc = The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (x32 ABI)
- pkgver = 1.0.1.i
- pkgrel = 1
+ pkgver = 1.0.2
+ pkgrel = 1.1
url = https://www.openssl.org
arch = x86_64
license = custom:BSD
@@ -10,17 +10,15 @@ pkgbase = libx32-openssl
depends = openssl
optdepends = ca-certificates
options = !makeflags
- source = https://www.openssl.org/source/openssl-1.0.1i.tar.gz
- source = https://www.openssl.org/source/openssl-1.0.1i.tar.gz.asc
+ source = https://www.openssl.org/source/openssl-1.0.2.tar.gz
+ source = https://www.openssl.org/source/openssl-1.0.2.tar.gz.asc
source = no-rpath.patch
source = ca-dir.patch
- source = openssl-1.0.1-x32.patch
source = opensslconf-stub.h
- md5sums = c8dc151a671b9b92ff3e4c118b174972
+ md5sums = 38373013fc85c790aabf8837969c5eba
md5sums = SKIP
md5sums = dc78d3d06baffc16217519242ce92478
md5sums = 3bf51be3a1bbd262be46dc619f92aa90
- md5sums = 10d0cebf2d9c0f64c307e82542f519e3
md5sums = dbb0b2e285f9ba95f189a0eaf3586011
pkgname = libx32-openssl
diff --git a/PKGBUILD b/PKGBUILD
index 76c318b037b8..3d599c2ee6f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# $Id: PKGBUILD 116952 2014-08-07 08:19:38Z bluewind $
+# $Id: PKGBUILD 126573 2015-01-25 14:11:25Z pierre $
# Maintainer: Pierre Schmitz <pierre@archlinux.de>
# x32 Maintainer: Fantix King <fantix.king at gmail.com>
_pkgbasename=openssl
pkgname=libx32-$_pkgbasename
-_ver=1.0.1i
+_ver=1.0.2
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
#pkgver=$_ver
-pkgrel=1
+pkgrel=1.1
pkgdesc='The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (x32 ABI)'
arch=('x86_64')
url='https://www.openssl.org'
@@ -21,22 +21,18 @@ source=("https://www.openssl.org/source/${_pkgbasename}-${_ver}.tar.gz"
"https://www.openssl.org/source/${_pkgbasename}-${_ver}.tar.gz.asc"
'no-rpath.patch'
'ca-dir.patch'
- 'openssl-1.0.1-x32.patch'
'opensslconf-stub.h'
)
-md5sums=('c8dc151a671b9b92ff3e4c118b174972'
+validpgpkeys=(8657ABB260F056B1E5190839D9C4D26D0E604491)
+md5sums=('38373013fc85c790aabf8837969c5eba'
'SKIP'
'dc78d3d06baffc16217519242ce92478'
'3bf51be3a1bbd262be46dc619f92aa90'
- '10d0cebf2d9c0f64c307e82542f519e3'
'dbb0b2e285f9ba95f189a0eaf3586011')
prepare() {
cd $srcdir/$_pkgbasename-$_ver
- # x32 patch
- patch -p1 -i $srcdir/openssl-1.0.1-x32.patch
-
# remove rpath: http://bugs.archlinux.org/task/14367
patch -p0 -i $srcdir/no-rpath.patch
# set ca dir to /etc/ssl by default
diff --git a/openssl-1.0.1-x32.patch b/openssl-1.0.1-x32.patch
deleted file mode 100644
index 5106cb6e82a3..000000000000
--- a/openssl-1.0.1-x32.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-http://git.yoctoproject.org/cgit/cgit.cgi/poky/commit/?id=51bfed2e26fc13a66e8b5710aa2ce1d7a04af721
-
-UpstreamStatus: Pending
-
-Received from H J Liu @ Intel
-Make the assembly syntax compatible with x32 gcc. Othewise x32 gcc throws errors.
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/07/13
-
-ported the patch to the 1.0.0e version
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com> 2011/12/01
-Index: openssl-1.0.0e/Configure
-===================================================================
---- openssl-1.0.0e.orig/Configure
-+++ openssl-1.0.0e/Configure
-@@ -393,6 +393,7 @@ my %table=(
- "debug-linux-generic32","gcc:-DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -DTERMIO -g -Wall::-D_REENTRANT::-ldl:BN_LLONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "debug-linux-generic64","gcc:-DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -DTERMIO -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_UNROLL BF_PTR:${no_asm}:dlfcn:linux-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "debug-linux-x86_64","gcc:-DBN_DEBUG -DREF_CHECK -DCONF_DEBUG -DCRYPTO_MDEBUG -m64 -DL_ENDIAN -DTERMIO -g -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-m64:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR):::64",
-+"linux-x32", "gcc:-DL_ENDIAN -DTERMIO -O2 -pipe -g -feliminate-unused-debug-types -Wall::-D_REENTRANT::-ldl:SIXTY_FOUR_BIT RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:elf:dlfcn:linux-shared:-fPIC:-mx32:.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "dist", "cc:-O::(unknown)::::::",
-
- # Basic configs that should work on any (32 and less bit) box
-Index: openssl-1.0.0e/crypto/bn/asm/x86_64-gcc.c
-===================================================================
---- openssl-1.0.0e.orig/crypto/bn/asm/x86_64-gcc.c
-+++ openssl-1.0.0e/crypto/bn/asm/x86_64-gcc.c
-@@ -55,7 +55,7 @@
- * machine.
- */
-
--#ifdef _WIN64
-+#if defined _WIN64 || !defined __LP64__
- #define BN_ULONG unsigned long long
- #else
- #define BN_ULONG unsigned long
-@@ -192,9 +192,9 @@ BN_ULONG bn_add_words (BN_ULONG *rp, con
- asm (
- " subq %2,%2 \n"
- ".p2align 4 \n"
-- "1: movq (%4,%2,8),%0 \n"
-- " adcq (%5,%2,8),%0 \n"
-- " movq %0,(%3,%2,8) \n"
-+ "1: movq (%q4,%2,8),%0 \n"
-+ " adcq (%q5,%2,8),%0 \n"
-+ " movq %0,(%q3,%2,8) \n"
- " leaq 1(%2),%2 \n"
- " loop 1b \n"
- " sbbq %0,%0 \n"
-@@ -215,9 +215,9 @@ BN_ULONG bn_sub_words (BN_ULONG *rp, con
- asm (
- " subq %2,%2 \n"
- ".p2align 4 \n"
-- "1: movq (%4,%2,8),%0 \n"
-- " sbbq (%5,%2,8),%0 \n"
-- " movq %0,(%3,%2,8) \n"
-+ "1: movq (%q4,%2,8),%0 \n"
-+ " sbbq (%q5,%2,8),%0 \n"
-+ " movq %0,(%q3,%2,8) \n"
- " leaq 1(%2),%2 \n"
- " loop 1b \n"
- " sbbq %0,%0 \n"
-Index: openssl-1.0.0e/crypto/bn/bn.h
-===================================================================
---- openssl-1.0.0e.orig/crypto/bn/bn.h
-+++ openssl-1.0.0e/crypto/bn/bn.h
-@@ -172,6 +172,13 @@ extern "C" {
- # endif
- #endif
-
-+/* Address type. */
-+#ifdef _WIN64
-+#define BN_ADDR unsigned long long
-+#else
-+#define BN_ADDR unsigned long
-+#endif
-+
- /* assuming long is 64bit - this is the DEC Alpha
- * unsigned long long is only 64 bits :-(, don't define
- * BN_LLONG for the DEC Alpha */