summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFantix King2015-12-19 04:17:49 +0800
committerFantix King2015-12-19 04:21:59 +0800
commit92c99c1c71399e99ff708cef11c58bc3176ec27c (patch)
tree93e4ffdbc966a8169f632edf4e5c50797bb3d301
parentbfa70b2a4583a336ffcaa6bc9b10965446490651 (diff)
downloadaur-92c99c1c71399e99ff708cef11c58bc3176ec27c.tar.gz
3.5.1-1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--issue25150.patch78
-rw-r--r--test_gdb-version-fix.patch11
4 files changed, 22 insertions, 114 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94daffb3c61c..643d8a9636d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Dec 18 20:21:48 UTC 2015
pkgbase = libx32-python
pkgdesc = Next generation of the python high-level scripting language (x32 ABI)
- pkgver = 3.5.0
- pkgrel = 2.1
+ pkgver = 3.5.1
+ pkgrel = 1.1
url = http://www.python.org/
arch = x86_64
license = custom
@@ -21,22 +23,20 @@ pkgbase = libx32-python
depends = libx32-zlib
depends = python
optdepends = libx32-sqlite
+ optdepends = libx32-readline
+ optdepends = libx32-ncurses: for curses
optdepends = libx32-mpdecimal: for decimal
optdepends = libx32-xz: for lzma
optdepends = libx32-tk: for tkinter
options = !makeflags
- source = http://www.python.org/ftp/python/3.5.0/Python-3.5.0.tar.xz
+ source = http://www.python.org/ftp/python/3.5.1/Python-3.5.1.tar.xz
source = pyconfig-stub.h
source = venv-x32.patch
- source = test_gdb-version-fix.patch
source = dont-make-libpython-readonly.patch
- source = issue25150.patch
- sha1sums = 871a06df9ab70984b7398ac53047fe125c757a70
+ sha1sums = 0186da436db76776196612b98bb9c2f76acfe90e
sha1sums = 74e5b55b394b1dfe5c430734e2ce049d595fb50f
sha1sums = af6b854349f4992892471b9cb363e8a6ce19ea6b
- sha1sums = ab86515aff465385675e2e6e593f09596e0a8db0
sha1sums = c22b24324b8e53326702de439c401d97927ee3f2
- sha1sums = bd068695d22931320069200f240c425096bb5011
pkgname = libx32-python
install = libx32-python.install
diff --git a/PKGBUILD b/PKGBUILD
index a3c47fe56bd8..267fc3d31fd8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 248014 2015-10-01 16:04:08Z fyan $
+# $Id: PKGBUILD 255786 2015-12-11 07:23:13Z fyan $
# Maintainer: Angel Velasquez <angvp@archlinux.org>
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
@@ -8,8 +8,8 @@
_pkgbasename=python
pkgname=libx32-python
-pkgver=3.5.0
-pkgrel=2.1
+pkgver=3.5.1
+pkgrel=1.1
_pybasever=3.5
pkgdesc="Next generation of the python high-level scripting language (x32 ABI)"
arch=('x86_64')
@@ -19,6 +19,8 @@ depends=('libx32-expat' 'libx32-bzip2' 'libx32-gdbm' 'libx32-openssl' 'libx32-li
makedepends=('libx32-tk' 'libx32-sqlite' 'bluez-libs' 'libx32-mpdecimal' 'libx32-readline' 'libx32-xz')
checkdepends=('gdb' 'xorg-server-xvfb')
optdepends=('libx32-sqlite'
+ 'libx32-readline'
+ 'libx32-ncurses: for curses'
'libx32-mpdecimal: for decimal'
'libx32-xz: for lzma'
'libx32-tk: for tkinter')
@@ -26,28 +28,18 @@ options=('!makeflags')
source=("http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"
pyconfig-stub.h
venv-x32.patch
- test_gdb-version-fix.patch
- dont-make-libpython-readonly.patch
- issue25150.patch)
-sha1sums=('871a06df9ab70984b7398ac53047fe125c757a70'
+ dont-make-libpython-readonly.patch)
+sha1sums=('0186da436db76776196612b98bb9c2f76acfe90e'
'74e5b55b394b1dfe5c430734e2ce049d595fb50f'
'af6b854349f4992892471b9cb363e8a6ce19ea6b'
- 'ab86515aff465385675e2e6e593f09596e0a8db0'
- 'c22b24324b8e53326702de439c401d97927ee3f2'
- 'bd068695d22931320069200f240c425096bb5011')
+ 'c22b24324b8e53326702de439c401d97927ee3f2')
prepare() {
cd Python-${pkgver}
- # https://bugs.python.org/issue25096
- patch -p1 -i ../test_gdb-version-fix.patch
-
# FS#45809
patch -p1 -i ../dont-make-libpython-readonly.patch
- # https://bugs.python.org/issue25150
- patch -p1 -i ../issue25150.patch
-
# x32 venv
patch -p1 -i ../venv-x32.patch
@@ -102,15 +94,20 @@ build() {
check() {
# Failures:
# test_pathlib & test_posixpath: https://bugs.python.org/issue24950
+ # test_gdb
+ # test_distutils: because of our EXTRA_CFLAGS
+ # test_nntplib: downloading external files and failed
# Hacks:
# test_tk: xvfb-run
# test_unicode_file: LC_CTYPE=en_US.utf-8
+ # test_gdb: SHELL=/bin/sh
cd Python-${pkgver}
+ SHELL=/bin/sh \
LD_LIBRARY_PATH="${srcdir}/Python-${pkgver}":${LD_LIBRARY_PATH} \
LC_CTYPE=en_US.utf-8 xvfb-run \
- "${srcdir}/Python-${pkgver}/python-x32" -m test.regrtest -uall || warning "Expected failure"
+ "${srcdir}/Python-${pkgver}/python-x32" -m test.regrtest -v -uall || warning "Expected failure"
}
package() {
diff --git a/issue25150.patch b/issue25150.patch
deleted file mode 100644
index be77c2a4913a..000000000000
--- a/issue25150.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-
-# HG changeset patch
-# User Victor Stinner <victor.stinner@gmail.com>
-# Date 1442581594 -7200
-# Node ID d4fcb362f7c66b25b22ddc0d27db0cc96acc727b
-# Parent d04a0954e142f873adee88ec5bc1c1d81cd46bc4
-Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
-Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
-becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
-
-It is important that the _PyThreadState_Current variable is always accessed
-with the same implementation of pyatomic.h. Use the PyThreadState_Get()
-function so extension modules will all reuse the same implementation.
-
-diff --git a/Include/pyatomic.h b/Include/pyatomic.h
---- a/Include/pyatomic.h
-+++ b/Include/pyatomic.h
-@@ -1,8 +1,6 @@
--/* Issue #23644: <stdatomic.h> is incompatible with C++, see:
-- https://gcc.gnu.org/bugzilla/show_bug.cgi?id=60932 */
--#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
- #ifndef Py_ATOMIC_H
- #define Py_ATOMIC_H
-+#ifdef Py_BUILD_CORE
-
- #include "dynamic_annotations.h"
-
-@@ -248,5 +246,5 @@ static __inline__ void
- #define _Py_atomic_load_relaxed(ATOMIC_VAL) \
- _Py_atomic_load_explicit(ATOMIC_VAL, _Py_memory_order_relaxed)
-
-+#endif /* Py_BUILD_CORE */
- #endif /* Py_ATOMIC_H */
--#endif /* Py_LIMITED_API */
-diff --git a/Include/pystate.h b/Include/pystate.h
---- a/Include/pystate.h
-+++ b/Include/pystate.h
-@@ -177,20 +177,13 @@ PyAPI_FUNC(int) PyThreadState_SetAsyncEx
- /* Variable and macro for in-line access to current thread state */
-
- /* Assuming the current thread holds the GIL, this is the
-- PyThreadState for the current thread.
--
-- Issue #23644: pyatomic.h is incompatible with C++ (yet). Disable
-- PyThreadState_GET() optimization: declare it as an alias to
-- PyThreadState_Get(), as done for limited API. */
--#if !defined(Py_LIMITED_API) && !defined(__cplusplus)
-+ PyThreadState for the current thread. */
-+#ifdef Py_BUILD_CORE
- PyAPI_DATA(_Py_atomic_address) _PyThreadState_Current;
--#endif
--
--#if defined(Py_DEBUG) || defined(Py_LIMITED_API) || defined(__cplusplus)
--#define PyThreadState_GET() PyThreadState_Get()
-+# define PyThreadState_GET() \
-+ ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
- #else
--#define PyThreadState_GET() \
-- ((PyThreadState*)_Py_atomic_load_relaxed(&_PyThreadState_Current))
-+# define PyThreadState_GET() PyThreadState_Get()
- #endif
-
- typedef
-diff --git a/Misc/NEWS b/Misc/NEWS
---- a/Misc/NEWS
-+++ b/Misc/NEWS
-@@ -11,6 +11,10 @@ Release date: TBA
- Core and Builtins
- -----------------
-
-+- Issue #25150: Hide the private _Py_atomic_xxx symbols from the public
-+ Python.h header to fix a compilation error with OpenMP. PyThreadState_GET()
-+ becomes an alias to PyThreadState_Get() to avoid ABI incompatibilies.
-+
- Library
- -------
-
-
diff --git a/test_gdb-version-fix.patch b/test_gdb-version-fix.patch
deleted file mode 100644
index ed1ddbea5923..000000000000
--- a/test_gdb-version-fix.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Lib/test/test_gdb.py 2015-09-14 11:58:09.218811556 +0800
-+++ b/Lib/test/test_gdb.py 2015-09-14 11:58:24.845647558 +0800
-@@ -28,7 +28,7 @@
- # This is what "no gdb" looks like. There may, however, be other
- # errors that manifest this way too.
- raise unittest.SkipTest("Couldn't find gdb on the path")
--gdb_version_number = re.search(b"^GNU gdb [^\d]*(\d+)\.(\d)", gdb_version)
-+gdb_version_number = re.search(b"^GNU gdb [^\d]*(\d+)\.(\d+)", gdb_version)
- gdb_major_version = int(gdb_version_number.group(1))
- gdb_minor_version = int(gdb_version_number.group(2))
- if gdb_major_version < 7: